aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libnet
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-11-11 07:16:27 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-11 07:16:27 +0000
commit47bb3895991dd77781dee8274159b032ebbc6b31 (patch)
tree84eed5aee6183933f15875a58a96d800a08b3324 /packages/libnet
parent1c60e3ea33243897f1159d617a0bf0fb9e5916f3 (diff)
downloadopenembedded-47bb3895991dd77781dee8274159b032ebbc6b31.tar.gz
libnet: add uclibc support in 1.0.2a
Diffstat (limited to 'packages/libnet')
-rw-r--r--packages/libnet/libnet-1.0.2a/configure.uclibc.patch11
-rw-r--r--packages/libnet/libnet_1.0.2a.bb7
2 files changed, 16 insertions, 2 deletions
diff --git a/packages/libnet/libnet-1.0.2a/configure.uclibc.patch b/packages/libnet/libnet-1.0.2a/configure.uclibc.patch
new file mode 100644
index 0000000000..809640fb65
--- /dev/null
+++ b/packages/libnet/libnet-1.0.2a/configure.uclibc.patch
@@ -0,0 +1,11 @@
+--- Libnet-1.0.2a/config.sub.orig 2005-11-10 11:24:50.238457174 -0800
++++ Libnet-1.0.2a/config.sub 2005-11-10 11:25:23.704563063 -0800
+@@ -68,7 +68,7 @@ esac
+ # Here we must recognize all the valid KERNEL-OS combinations.
+ maybe_os=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\2/'`
+ case $maybe_os in
+- linux-gnu*)
++ linux-gnu*|linux-uclibc)
+ os=-$maybe_os
+ basic_machine=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\1/'`
+ ;;
diff --git a/packages/libnet/libnet_1.0.2a.bb b/packages/libnet/libnet_1.0.2a.bb
index c986bb9f90..9cfcdf8a2a 100644
--- a/packages/libnet/libnet_1.0.2a.bb
+++ b/packages/libnet/libnet_1.0.2a.bb
@@ -4,9 +4,12 @@ portable framework for low-level network packet shaping, \
handling, and injection."
SECTION = "libs/network"
LICENSE = "GPL"
+PR = "r1"
SRC_URI = "http://www.packetfactory.net/libnet/dist/deprecated/libnet-${PV}.tar.gz \
- file://configure.patch;patch=1"
+ file://configure.patch;patch=1 \
+ file://configure.uclibc.patch;patch=1 \
+ "
S = "${WORKDIR}/Libnet-${PV}"
inherit autotools
@@ -15,7 +18,7 @@ CPPFLAGS_prepend = "-I${S}/libnet/include -DHAVE_PF_PACKET "
EXTRA_OEMAKE = "'LIB_PREFIX=${libdir}/' 'MAN_PREFIX=${mandir}/' \
'BIN_PREFIX=${bindir}/' 'INC_PREFIX=${includedir}/'"
-#FIXME:
+#FIXME: (fixing this would remove the need for configure.uclibc.patch above)
do_configure() {
oe_runconf
}