aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libnet
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-11-05 23:46:51 +0000
committerJamie Lenehan <lenehan@twibble.org>2006-11-05 23:46:51 +0000
commit510d1444511affbe1dce824740e925f3360ea82d (patch)
treeec1f503464cf0dcc79738c01c9cdd8eeb7cd7dad /packages/libnet
parent430c89ba213aa6bcb053736bc5674f26bc2dd2e3 (diff)
downloadopenembedded-510d1444511affbe1dce824740e925f3360ea82d.tar.gz
libnet 1.1.2.1: Clean up the format of the .bb by running though
oe-stylize.py.
Diffstat (limited to 'packages/libnet')
-rw-r--r--packages/libnet/libnet_1.1.2.1.bb36
1 files changed, 17 insertions, 19 deletions
diff --git a/packages/libnet/libnet_1.1.2.1.bb b/packages/libnet/libnet_1.1.2.1.bb
index 65f56a492b..92457a8ff4 100644
--- a/packages/libnet/libnet_1.1.2.1.bb
+++ b/packages/libnet/libnet_1.1.2.1.bb
@@ -1,40 +1,38 @@
-SECTION = "libs"
DESCRIPTION = "A packet dissection and creation library"
HOMEPAGE = "http://www.packetfactory.net/libnet/"
-LICENSE = "BSD"
+SECTION = "libs"
PRIORITY = "optional"
+LICENSE = "BSD"
DEPENDS = "libpcap"
-PR = "r1"
-
# There are major API changes beween libnet v1.0 and libnet v1.1
PROVIDES = "libnet-1.1"
+PR = "r1"
SRC_URI = "http://www.packetfactory.net/libnet/dist/libnet-${PV}.tar.gz \
- file://support-uclibc.patch;patch=1 \
- file://fix-endianess-test.patch;patch=1"
+ file://support-uclibc.patch;patch=1 \
+ file://fix-endianess-test.patch;patch=1"
S = "${WORKDIR}/libnet"
inherit autotools binconfig
-CPPFLAGS_prepend = "-I${S}/libnet/include "
-
do_configure_prepend() {
rm -f aclocal.m4 Makefile.am ltmain.sh
}
-
-do_stage () {
- oe_runmake -C src 'DESTDIR=${STAGING_LIBDIR}' 'libdir=' install-libLIBRARIES
- oe_runmake -C include 'DESTDIR=${STAGING_INCDIR}' 'includedir=' install-includeHEADERS
- oe_runmake -C include/libnet 'DESTDIR=${STAGING_INCDIR}' 'includedir=' install-libnetincludeHEADERS
-}
-
do_install_append () {
- install -d ${D}${datadir}/man/man3/
- install -d ${D}${bindir}
- install -m 0644 ${S}/doc/man/man3/*.3 ${D}${datadir}/man/man3/
- install -m 0755 ${S}/libnet-config ${D}${bindir}
+ install -d ${D}${datadir}/man/man3/
+ install -d ${D}${bindir}
+ install -m 0644 ${S}/doc/man/man3/*.3 ${D}${datadir}/man/man3/
+ install -m 0755 ${S}/libnet-config ${D}${bindir}
+}
+do_stage () {
+ oe_runmake -C src 'DESTDIR=${STAGING_LIBDIR}' 'libdir=' install-libLIBRARIES
+ oe_runmake -C include 'DESTDIR=${STAGING_INCDIR}' 'includedir=' install-includeHEADERS
+ oe_runmake -C include/libnet 'DESTDIR=${STAGING_INCDIR}' 'includedir=' install-libnetincludeHEADERS
}
PACKAGES = "${PN}-dev ${PN}-doc"
+
FILES_${PN}-dev += "${bindir}/libnet-config"
+
+CPPFLAGS_prepend = "-I${S}/libnet/include "