aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libnl
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2008-05-09 14:12:25 +0000
committerGraeme Gregory <dp@xora.org.uk>2008-05-09 14:12:25 +0000
commit189a6af82b51537cdb7022a6d31b9e00472cc34c (patch)
tree8e4df18901c15b9acb6da461e0d596c37626a70c /packages/libnl
parent4813bca8399c36aa3721916f536b55f06b5bb129 (diff)
downloadopenembedded-189a6af82b51537cdb7022a6d31b9e00472cc34c.tar.gz
libnl_1.0-pre8.bb : new recipce from OM mtn
Diffstat (limited to 'packages/libnl')
-rw-r--r--packages/libnl/files/linux-header.patch24
-rw-r--r--packages/libnl/files/local-includes-and-avoid-wrong-ldflags.patch13
-rw-r--r--packages/libnl/libnl_1.0-pre8.bb19
3 files changed, 56 insertions, 0 deletions
diff --git a/packages/libnl/files/linux-header.patch b/packages/libnl/files/linux-header.patch
new file mode 100644
index 0000000000..cecb38dc9e
--- /dev/null
+++ b/packages/libnl/files/linux-header.patch
@@ -0,0 +1,24 @@
+Index: libnl-1.0-pre8/include/netlink/netlink.h
+===================================================================
+--- libnl-1.0-pre8.orig/include/netlink/netlink.h 2007-11-21 18:25:39.000000000 +0100
++++ libnl-1.0-pre8/include/netlink/netlink.h 2008-04-07 03:18:14.000000000 +0200
+@@ -24,7 +24,6 @@
+ #include <linux/netlink.h>
+ #include <linux/rtnetlink.h>
+ #include <linux/genetlink.h>
+-#include <linux/ip_mp_alg.h>
+ #include <linux/netfilter/nfnetlink.h>
+ #include <netlink/types.h>
+ #include <netlink/handlers.h>
+Index: libnl-1.0-pre8/lib/route/route_obj.c
+===================================================================
+--- libnl-1.0-pre8.orig/lib/route/route_obj.c 2008-04-07 03:20:25.000000000 +0200
++++ libnl-1.0-pre8/lib/route/route_obj.c 2008-04-07 03:20:35.000000000 +0200
+@@ -33,6 +33,7 @@
+ * @{
+ */
+
++#include <linux/ip_mp_alg.h>
+ #include <netlink-local.h>
+ #include <netlink/netlink.h>
+ #include <netlink/cache.h>
diff --git a/packages/libnl/files/local-includes-and-avoid-wrong-ldflags.patch b/packages/libnl/files/local-includes-and-avoid-wrong-ldflags.patch
new file mode 100644
index 0000000000..428df53a94
--- /dev/null
+++ b/packages/libnl/files/local-includes-and-avoid-wrong-ldflags.patch
@@ -0,0 +1,13 @@
+--- libnl-1.0-pre8/Makefile.opts.in.orig 2007-11-21 18:25:39.000000000 +0100
++++ libnl-1.0-pre8/Makefile.opts.in 2008-04-04 23:38:40.000000000 +0200
+@@ -10,8 +10,8 @@
+ #
+
+ CC := @CC@
+-CFLAGS := @CFLAGS@
+-LDFLAGS := @LDFLAGS@
++CFLAGS := -I./include -I. -I../include @CFLAGS@
++LDFLAGS :=
+ CPPFLAGS := @CPPFLAGS@
+ PACKAGE_NAME := @PACKAGE_NAME@
+ PACKAGE_VERSION := @PACKAGE_VERSION@
diff --git a/packages/libnl/libnl_1.0-pre8.bb b/packages/libnl/libnl_1.0-pre8.bb
new file mode 100644
index 0000000000..e80b5aa4bd
--- /dev/null
+++ b/packages/libnl/libnl_1.0-pre8.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "libnl is a library for applications dealing with netlink sockets"
+SECTION = "libs/network"
+LICENSE = "LGPL"
+HOMEPAGE = "http://people.suug.ch/~tgr/libnl/"
+PRIORITY = "optional"
+PV = "0.99+1.0-pre8"
+
+inherit autotools pkgconfig gpe
+
+SRC_URI= "http://people.suug.ch/~tgr/libnl/files/${PN}-1.0-pre8.tar.gz \
+ file://local-includes-and-avoid-wrong-ldflags.patch;patch=1 \
+ file://linux-header.patch;patch=1 "
+
+S = "${WORKDIR}/${PN}-1.0-pre8"
+
+do_stage () {
+ autotools_stage_all prefix=${prefix}
+}
+