aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libowl
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-07-31 20:09:42 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-07-31 20:09:42 +0000
commit582cafc92e1ffc1c3382a3aa119f5c517e7b612c (patch)
treec23a322470313c21eebe7e31face85a84ac33feb /packages/libowl
parent56c92c2ec5451ec270e01e646c06d63708e3c619 (diff)
downloadopenembedded-582cafc92e1ffc1c3382a3aa119f5c517e7b612c.tar.gz
add libowl (OpenedHand Widget Library) [taken from poky]
Diffstat (limited to 'packages/libowl')
-rw-r--r--packages/libowl/.mtn2git_empty0
-rw-r--r--packages/libowl/libowl_svn.bb48
2 files changed, 48 insertions, 0 deletions
diff --git a/packages/libowl/.mtn2git_empty b/packages/libowl/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libowl/.mtn2git_empty
diff --git a/packages/libowl/libowl_svn.bb b/packages/libowl/libowl_svn.bb
new file mode 100644
index 0000000000..2126e3d4d0
--- /dev/null
+++ b/packages/libowl/libowl_svn.bb
@@ -0,0 +1,48 @@
+# This recipe builds libowl and then stages the header and static lib;
+# it intentionally does not stage the shared lib and create a package.
+#
+# Libowl is currently a 'cut and paste' library; this package makes our
+# life a touch easier by not having to patch the source directly into
+# applications; instead we add -lowl to the linker cmdline. Also, when
+# we eventually make libowl into a normal shared library, this package
+# will make that transition rather simple.
+
+DESCRIPTION = "OpenedHand Widget Library"
+HOMEPAGE = "http://www.o-hand.com"
+LICENSE = "LGPL"
+SECTION = "libs"
+PR = "r3"
+PV = "0.0+svn${SRCDATE}"
+
+DEPENDS = "gtk+ glib-2.0"
+PACKAGES = ""
+
+SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=${PN};proto=http"
+
+S = "${WORKDIR}/${PN}"
+
+inherit autotools pkgconfig
+
+do_compile_prepend() {
+ # have to unstage the library first so that the tests build
+ rm -f ${STAGING_LIBDIR}/libowl*
+ rm -f ${STAGING_INCDIR}/owl*
+}
+
+do_stage() {
+ headers=`eval ls libowl/owl*.h`
+ for header in $headers; do
+ hdr_base=`eval basename $header`
+ install -m 644 $header ${STAGING_INCDIR}/$hdr_base
+ done
+ install -m 644 libowl/.libs/libowl.a ${STAGING_LIBDIR}/
+}
+
+do_install() {
+}
+
+do_package() {
+}
+
+do_package_write() {
+}