aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libpcre
diff options
context:
space:
mode:
authorMartin Dietze <di@fh-wedel.de>2006-09-11 15:04:34 +0000
committerMartin Dietze <di@fh-wedel.de>2006-09-11 15:04:34 +0000
commit4082ac4cf6c8d21399aa7aad6838137f9632f4b9 (patch)
tree016ba05eec3f74853bf4727bcfae1d4d29adafe7 /packages/libpcre
parent587007f5e56bcf229fc6597d12e798da9d58b487 (diff)
downloadopenembedded-4082ac4cf6c8d21399aa7aad6838137f9632f4b9.tar.gz
libpcre: fixes resulting from renaming pcre->libpcre
* the recipes in libpcre now contain the code from the removed pcre packages (sorry for the mess) * nylon-feed now DEPENDs on libpcre instead of pcre
Diffstat (limited to 'packages/libpcre')
-rw-r--r--packages/libpcre/libpcre-native_4.4.bb2
-rw-r--r--packages/libpcre/libpcre_4.4.bb40
2 files changed, 19 insertions, 23 deletions
diff --git a/packages/libpcre/libpcre-native_4.4.bb b/packages/libpcre/libpcre-native_4.4.bb
index 7caddc321d..7be8ffd0ac 100644
--- a/packages/libpcre/libpcre-native_4.4.bb
+++ b/packages/libpcre/libpcre-native_4.4.bb
@@ -1,4 +1,4 @@
SECTION = "unknown"
-include libpcre_${PV}.bb
+require libpcre_${PV}.bb
inherit native
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libpcre-${PV}"
diff --git a/packages/libpcre/libpcre_4.4.bb b/packages/libpcre/libpcre_4.4.bb
index f26b595894..941888577b 100644
--- a/packages/libpcre/libpcre_4.4.bb
+++ b/packages/libpcre/libpcre_4.4.bb
@@ -5,41 +5,37 @@ provides a POSIX calling interface to PCRE; the regular expressions \
themselves still follow Perl syntax and semantics. The header file for \
the POSIX-style functions is called pcreposix.h."
SECTION = "devel"
-PR = "r1"
-
+PR = "r6"
+LICENSE = "BSD"
SRC_URI = "ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-${PV}.tar.bz2"
S = "${WORKDIR}/pcre-${PV}"
-PARALLEL_MAKE = ""
-
inherit autotools binconfig
+PARALLEL_MAKE = ""
+
LEAD_SONAME = "libpcre.so"
CFLAGS_append = " -D_REENTRANT"
EXTRA_OECONF = " --with-link-size=2 --enable-newline-is-lf --with-match-limit=10000000"
-
do_compile () {
- ${BUILD_CC} -DLINK_SIZE=2 -I${S}/include -c dftables.c
- ${BUILD_CC} dftables.o -o dftables
- oe_runmake
+ # stop libtool from trying to link with host libraries - fix from #33
+ # this resolve build problem on amd64 - #1015
+ sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${TARGET_SYS}-libtool
+
+ # The generation of dftables can lead to timestamp problems with ccache
+ # because the generated config.h seems newer. It is sufficient to ensure that the
+ # attempt to build dftables inside make will actually work (foo_FOR_BUILD is
+ # only used for this).
+ oe_runmake CC_FOR_BUILD="${BUILD_CC}" CFLAGS_FOR_BUILD="-DLINK_SIZE=2 -I${S}/include" LINK_FOR_BUILD="${BUILD_CC}"
}
do_stage () {
- # Force all -L(dir) output to be prepended with the staging libdir to stop libtool
- # from trying to link to host libraries.
- sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/*libtool
-
- oe_libinstall -a -so libpcre ${STAGING_LIBDIR}
- oe_libinstall -a -so libpcreposix ${STAGING_LIBDIR}
- install -m 0644 pcre.h ${STAGING_INCDIR}/
- install -m 0644 pcreposix.h ${STAGING_INCDIR}/
-
- # pcreposix linked originally to the libpcre in it's working directory. That messed
- # the .la file up. I fix this manually here:
- sed -i 's:${S}:${STAGING_LIBDIR}:' ${STAGING_LIBDIR}/libpcreposix.la
+ oe_libinstall -a -so libpcre ${STAGING_LIBDIR}
+ oe_libinstall -a -so libpcreposix ${STAGING_LIBDIR}
+ install -m 0644 pcre.h ${STAGING_INCDIR}/
+ install -m 0644 pcreposix.h ${STAGING_INCDIR}/
}
-
FILES_${PN} = "${libdir}/lib*.so*"
-FILES_${PN}-dev += "${bindir}"
+FILES_${PN}-dev += "${bindir}/*"