aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libpcre
diff options
context:
space:
mode:
authorMartin Dietze <di@fh-wedel.de>2006-09-08 12:45:12 +0000
committerMartin Dietze <di@fh-wedel.de>2006-09-08 12:45:12 +0000
commitec33e91e3b1ec6a9845742879834893c4cda9764 (patch)
treebde551e6180267adfcd428c99536c0e07aac672f /packages/libpcre
parent624a8d827f1da93d61e853152294f2fbfcd93ff7 (diff)
downloadopenembedded-ec33e91e3b1ec6a9845742879834893c4cda9764.tar.gz
libpcre: added new port.
Diffstat (limited to 'packages/libpcre')
-rw-r--r--packages/libpcre/.mtn2git_empty0
-rw-r--r--packages/libpcre/libpcre-native_4.4.bb4
-rw-r--r--packages/libpcre/libpcre_4.4.bb33
3 files changed, 37 insertions, 0 deletions
diff --git a/packages/libpcre/.mtn2git_empty b/packages/libpcre/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libpcre/.mtn2git_empty
diff --git a/packages/libpcre/libpcre-native_4.4.bb b/packages/libpcre/libpcre-native_4.4.bb
new file mode 100644
index 0000000000..7caddc321d
--- /dev/null
+++ b/packages/libpcre/libpcre-native_4.4.bb
@@ -0,0 +1,4 @@
+SECTION = "unknown"
+include libpcre_${PV}.bb
+inherit native
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libpcre-${PV}"
diff --git a/packages/libpcre/libpcre_4.4.bb b/packages/libpcre/libpcre_4.4.bb
new file mode 100644
index 0000000000..9974e85806
--- /dev/null
+++ b/packages/libpcre/libpcre_4.4.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Perl-compatible regular expression library. PCRE has its own native \
+API, but a set of 'wrapper' functions that are based on the POSIX API \
+are also supplied in the library libpcreposix. Note that this just \
+provides a POSIX calling interface to PCRE; the regular expressions \
+themselves still follow Perl syntax and semantics. The header file for \
+the POSIX-style functions is called pcreposix.h."
+SECTION = "devel"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-${PV}.tar.bz2"
+S = "${WORKDIR}/pcre-${PV}"
+
+inherit autotools binconfig
+
+LEAD_SONAME = "libpcre.so"
+CFLAGS_append = " -D_REENTRANT"
+EXTRA_OECONF = " --with-link-size=2 --enable-newline-is-lf --with-match-limit=10000000"
+
+do_compile () {
+ ${BUILD_CC} -DLINK_SIZE=2 -I${S}/include -c dftables.c
+ ${BUILD_CC} dftables.o -o dftables
+ oe_runmake
+}
+
+do_stage () {
+ oe_libinstall -a -so libpcreposix ${STAGING_LIBDIR}
+ oe_libinstall -a -so libpcre ${STAGING_LIBDIR}
+ install -m 0644 pcre.h ${STAGING_INCDIR}/
+ install -m 0644 pcreposix.h ${STAGING_INCDIR}/
+}
+
+FILES_${PN} = "${libdir}/lib*.so*"
+FILES_${PN}-dev += "${bindir}"