aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libpcre
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2008-03-19 12:33:38 +0000
committerRichard Purdie <rpurdie@rpsys.net>2008-03-19 12:33:38 +0000
commitf173b1f9434fc5a9ec24c0daf470a09111b7536f (patch)
tree4289ded8d0aa1bc0a48cf13e65adc93a74b3a584 /packages/libpcre
parent2bf76e7170dcc4b31f1c0865e2ee65a4e2513504 (diff)
downloadopenembedded-f173b1f9434fc5a9ec24c0daf470a09111b7536f.tar.gz
libpcre-native: Fix linking issues when the build system doesn't have pcre installed
Diffstat (limited to 'packages/libpcre')
-rw-r--r--packages/libpcre/files/.mtn2git_empty0
-rw-r--r--packages/libpcre/files/native-rpath-link.patch19
-rw-r--r--packages/libpcre/libpcre-native_4.4.bb11
3 files changed, 30 insertions, 0 deletions
diff --git a/packages/libpcre/files/.mtn2git_empty b/packages/libpcre/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libpcre/files/.mtn2git_empty
diff --git a/packages/libpcre/files/native-rpath-link.patch b/packages/libpcre/files/native-rpath-link.patch
new file mode 100644
index 0000000000..69de2bea64
--- /dev/null
+++ b/packages/libpcre/files/native-rpath-link.patch
@@ -0,0 +1,19 @@
+Index: pcre-4.4/Makefile.in
+===================================================================
+--- pcre-4.4.orig/Makefile.in 2003-08-21 11:43:07.000000000 +0100
++++ pcre-4.4/Makefile.in 2008-03-19 10:34:08.000000000 +0000
+@@ -107,12 +107,12 @@
+
+ libpcre.la: $(OBJ)
+ -rm -f libpcre.la
+- $(LINKLIB) -rpath $(LIBDIR) -version-info \
++ $(LINKLIB) -rpath $(LIBDIR) -L$(LIBDIR) -version-info \
+ '$(PCRELIBVERSION)' -o libpcre.la $(LOBJ)
+
+ libpcreposix.la: pcreposix.@OBJEXT@
+ -rm -f libpcreposix.la
+- $(LINKLIB) -rpath $(LIBDIR) libpcre.la -version-info \
++ $(LINKLIB) -rpath $(LIBDIR) -L$(LIBDIR) libpcre.la -version-info \
+ '$(PCREPOSIXLIBVERSION)' -o libpcreposix.la pcreposix.lo
+
+ pcre.@OBJEXT@: $(top_srcdir)/chartables.c $(top_srcdir)/pcre.c \
diff --git a/packages/libpcre/libpcre-native_4.4.bb b/packages/libpcre/libpcre-native_4.4.bb
index 8a4211384a..1bbfde7f0a 100644
--- a/packages/libpcre/libpcre-native_4.4.bb
+++ b/packages/libpcre/libpcre-native_4.4.bb
@@ -6,3 +6,14 @@ FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libpcre-${PV}"
# NOTE: multiple providers are available (libpcre, libpcre-native);
# NOTE: consider defining PREFERRED_PROVIDER_pcre
PROVIDES = ""
+
+SRC_URI += "file://native-rpath-link.patch;patch=1"
+
+do_compile () {
+ # The generation of dftables can lead to timestamp problems with ccache
+ # because the generated config.h seems newer. It is sufficient to ensure that the
+ # attempt to build dftables inside make will actually work (foo_FOR_BUILD is
+ # only used for this).
+ oe_runmake CC_FOR_BUILD="${BUILD_CC}" CFLAGS_FOR_BUILD="-DLINK_SIZE=2 -I${S}/include" LINK_FOR_BUILD="${BUILD_CC}"
+}
+