aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libqpe
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2005-09-12 21:23:01 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-12 21:23:01 +0000
commit6418fc60db8a058f106f0efcc3a1bc79274387e7 (patch)
tree7a076fd84cba428c162bd103d7ab692d0dddc6a7 /packages/libqpe
parent7eef37e5616b94035732f961cedb799a7062f926 (diff)
downloadopenembedded-6418fc60db8a058f106f0efcc3a1bc79274387e7.tar.gz
libqpe/libqpe-opie_1.2.1:
last minute backport from http://opie-bugs.oszine.de/view.php?id=1695 to fix the font sizes for the Date selector on displays with higher resolution.
Diffstat (limited to 'packages/libqpe')
-rw-r--r--packages/libqpe/libqpe-opie/0905_datebookmonth.patch23
-rw-r--r--packages/libqpe/libqpe-opie_1.2.1.bb1
2 files changed, 24 insertions, 0 deletions
diff --git a/packages/libqpe/libqpe-opie/0905_datebookmonth.patch b/packages/libqpe/libqpe-opie/0905_datebookmonth.patch
new file mode 100644
index 0000000000..7c4d5fb389
--- /dev/null
+++ b/packages/libqpe/libqpe-opie/0905_datebookmonth.patch
@@ -0,0 +1,23 @@
+Index: datebookmonth.cpp
+===================================================================
+RCS file: /cvs/opie/library/datebookmonth.cpp,v
+retrieving revision 1.10
+diff -u -r1.10 datebookmonth.cpp
+--- datebookmonth.cpp 20 Mar 2005 18:29:19 -0000 1.10
++++ datebookmonth.cpp 5 Sep 2005 19:53:47 -0000
+@@ -661,7 +661,14 @@
+
+ // Finally, draw the number.
+ QFont f = p->font();
+- f.setPointSize( ( f.pointSize() / 3 ) * 2 );
++ if(qApp->desktop()->width() >= 480)
++ {
++ f.setPointSize( f.pointSize() - 2 );
++ }
++ else
++ {
++ f.setPointSize( ( f.pointSize() / 3 ) * 2 );
++ }
+ p->setFont( f );
+ QFontMetrics fm( f );
+ p->drawText( 1, 1 + fm.ascent(), QString::number( day() ) );
diff --git a/packages/libqpe/libqpe-opie_1.2.1.bb b/packages/libqpe/libqpe-opie_1.2.1.bb
index 93b1590bba..6cd4368187 100644
--- a/packages/libqpe/libqpe-opie_1.2.1.bb
+++ b/packages/libqpe/libqpe-opie_1.2.1.bb
@@ -3,5 +3,6 @@ include ${PN}.inc
TAG = "${@'v' + bb.data.getVar('PV',d,1).replace('.', '_')}"
SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/library \
+ file://0905_datebookmonth.patch;patch=1;pnum=0 \
file://fix-titleheight.patch;patch=1"