aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libsdl
diff options
context:
space:
mode:
authorFrederic Bompart <frederic@unknown.openembedded.org>2005-10-06 17:14:25 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-10-06 17:14:25 +0000
commit7e6de12a35e08e4f406e61d00fe38afb74bcb21f (patch)
treefe0e9501d47ce8f7e81cc83493b47198a9d4ffe1 /packages/libsdl
parentfb93ba77c32140949b0c5a655d40f74618e62a8d (diff)
downloadopenembedded-7e6de12a35e08e4f406e61d00fe38afb74bcb21f.tar.gz
libsdl: disable building static lib, don't install libtool .la file
libsdl-qpe: fix sdl-config flags for compatibility with libsdl-x11
Diffstat (limited to 'packages/libsdl')
-rw-r--r--packages/libsdl/libsdl-qpe-1.2.7/fixlibs.patch25
-rw-r--r--packages/libsdl/libsdl-qpe_1.2.7.bb6
-rw-r--r--packages/libsdl/libsdl-x11_1.2.7.bb3
3 files changed, 31 insertions, 3 deletions
diff --git a/packages/libsdl/libsdl-qpe-1.2.7/fixlibs.patch b/packages/libsdl/libsdl-qpe-1.2.7/fixlibs.patch
new file mode 100644
index 0000000000..899e31482c
--- /dev/null
+++ b/packages/libsdl/libsdl-qpe-1.2.7/fixlibs.patch
@@ -0,0 +1,25 @@
+--- SDL-1.2.7/configure.in~fixlibs 2005-10-06 10:27:59.025396872 +0200
++++ SDL-1.2.7/configure.in 2005-10-06 10:30:16.963087411 +0200
+@@ -1508,8 +1508,8 @@
+ AC_MSG_RESULT($video_qtopia)
+ if test x$video_qtopia = xyes; then
+ CFLAGS="$CFLAGS -DENABLE_QTOPIA -DQT_QWS_EBX -DQT_QWS_CUSTOM -DQWS -I${QPEDIR}/include -I${QTDIR}/include/ -DNO_DEBUG -fno-rtti -fno-exceptions"
+- SDL_LIBS="$SDL_LIBS -L${QPEDIR}/lib -L${QTDIR}/lib/ -lqpe -lqte"
+- SDL_CFLAGS="$SDL_CFLAGS -DQWS"
++ SDL_LIBS="$SDL_LIBS -Wl,-rpath-link -Wl,${QPEDIR}/lib -Wl,-rpath-link -Wl,${QTDIR}/lib"
++ SYSTEM_LIBS="$SYSTEM_LIBS -L${QPEDIR}/lib -L${QTDIR}/lib/ -lqpe -lqte"
+ VIDEO_SUBDIRS="$VIDEO_SUBDIRS qtopia"
+ VIDEO_DRIVERS="$VIDEO_DRIVERS qtopia/libvideo_qtopia.la"
+ else
+@@ -1803,11 +1803,6 @@
+ CheckPTHREAD
+ CheckSIGACTION
+ CheckAltivec
+- # Set up files for the main() stub
+- if test "x$video_qtopia" = "xyes"; then
+- SDL_CFLAGS="$SDL_CFLAGS -Dmain=SDL_main"
+-
+- fi
+ # Set up files for the audio library
+ # We use the OSS and ALSA API's, not the Sun audio API
+ #if test x$enable_audio = xyes; then
diff --git a/packages/libsdl/libsdl-qpe_1.2.7.bb b/packages/libsdl/libsdl-qpe_1.2.7.bb
index 54dc975fb5..a976f844eb 100644
--- a/packages/libsdl/libsdl-qpe_1.2.7.bb
+++ b/packages/libsdl/libsdl-qpe_1.2.7.bb
@@ -16,12 +16,13 @@ SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
file://mouse.patch;patch=1 \
file://kill-stdc++.patch;patch=1 \
file://ipaq.patch;patch=1 \
- file://SDL-Akita.patch;patch=1"
+ file://SDL-Akita.patch;patch=1 \
+ file://fixlibs.patch;patch=1"
S = "${WORKDIR}/SDL-${PV}"
inherit autotools binconfig
-EXTRA_OECONF = "--disable-debug --enable-cdrom --enable-threads --enable-timers --enable-endian \
+EXTRA_OECONF = "--disable-static --disable-debug --enable-cdrom --enable-threads --enable-timers --enable-endian \
--enable-file --enable-oss --disable-alsa --disable-esd --disable-arts \
--disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
--disable-mintaudio --disable-nasm --disable-video-x11 --disable-video-dga \
@@ -35,6 +36,7 @@ FILES_${PN}-dev += "${bindir}/*config"
do_stage() {
oe_libinstall -so -C src libSDL ${STAGING_LIBDIR}
+ rm ${STAGING_LIBDIR}/libSDL.la
ln -sf libSDL.so ${STAGING_LIBDIR}/libSDL-1.2.so
install -m 0655 src/main/libSDLmain.a src/main/.libs/
oe_libinstall -a -C src/main libSDLmain ${STAGING_LIBDIR}
diff --git a/packages/libsdl/libsdl-x11_1.2.7.bb b/packages/libsdl/libsdl-x11_1.2.7.bb
index 80c547b520..da96517041 100644
--- a/packages/libsdl/libsdl-x11_1.2.7.bb
+++ b/packages/libsdl/libsdl-x11_1.2.7.bb
@@ -16,7 +16,7 @@ S = "${WORKDIR}/SDL-${PV}"
inherit autotools binconfig
-EXTRA_OECONF = "--disable-debug --disable-cdrom --enable-threads --enable-timers --enable-endian \
+EXTRA_OECONF = "--disable-static --disable-debug --disable-cdrom --enable-threads --enable-timers --enable-endian \
--enable-file --enable-oss --enable-alsa --disable-esd --disable-arts \
--disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
--disable-mintaudio --disable-nasm --enable-video-x11 --disable-video-dga \
@@ -43,6 +43,7 @@ do_configure_append () {
do_stage() {
oe_libinstall -so -C src libSDL ${STAGING_LIBDIR}
+ rm ${STAGING_LIBDIR}/libSDL.la
ln -sf libSDL.so ${STAGING_LIBDIR}/libSDL-1.2.so
#oe_libinstall -a -C src/main libSDLmain ${STAGING_LIBDIR}
install -m 0644 src/main/libSDLmain.a ${STAGING_LIBDIR}