aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libsdl
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-08-03 00:07:52 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-03 00:07:52 +0000
commit9e3eafa27d785b1a357332d6183e33dd0eb8e56b (patch)
treea9e12ee983cf8427f4e21b5743d4ff51fead13cf /packages/libsdl
parent1f46d61330cef352542dede22fb1c654ea7ddbd4 (diff)
downloadopenembedded-9e3eafa27d785b1a357332d6183e33dd0eb8e56b.tar.gz
add crimsonfields, a popular tactical war game in the tradition of Battle Isle
NOTE: this was pretty complex and annoying as I had to add a native libsdl and a native libsdl-ttf as well as a native version of the crimsonfields tools :/
Diffstat (limited to 'packages/libsdl')
-rw-r--r--packages/libsdl/files/.mtn2git_empty (renamed from packages/libsdl/libsdl-x11-1.2.7/.mtn2git_empty)0
-rw-r--r--packages/libsdl/files/acinclude.m4 (renamed from packages/libsdl/libsdl-x11-1.2.7/acinclude.m4)0
-rw-r--r--packages/libsdl/files/extra-keys.patch (renamed from packages/libsdl/libsdl-x11-1.2.7/extra-keys.patch)0
-rw-r--r--packages/libsdl/libsdl-native_1.2.7.bb53
-rw-r--r--packages/libsdl/libsdl-ttf-native_2.0.3.bb10
5 files changed, 63 insertions, 0 deletions
diff --git a/packages/libsdl/libsdl-x11-1.2.7/.mtn2git_empty b/packages/libsdl/files/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/libsdl/libsdl-x11-1.2.7/.mtn2git_empty
+++ b/packages/libsdl/files/.mtn2git_empty
diff --git a/packages/libsdl/libsdl-x11-1.2.7/acinclude.m4 b/packages/libsdl/files/acinclude.m4
index ca2df9d5e5..ca2df9d5e5 100644
--- a/packages/libsdl/libsdl-x11-1.2.7/acinclude.m4
+++ b/packages/libsdl/files/acinclude.m4
diff --git a/packages/libsdl/libsdl-x11-1.2.7/extra-keys.patch b/packages/libsdl/files/extra-keys.patch
index f12f0c7efb..f12f0c7efb 100644
--- a/packages/libsdl/libsdl-x11-1.2.7/extra-keys.patch
+++ b/packages/libsdl/files/extra-keys.patch
diff --git a/packages/libsdl/libsdl-native_1.2.7.bb b/packages/libsdl/libsdl-native_1.2.7.bb
new file mode 100644
index 0000000000..9d1a73b852
--- /dev/null
+++ b/packages/libsdl/libsdl-native_1.2.7.bb
@@ -0,0 +1,53 @@
+DESCRIPTION = "Simple DirectMedia Layer - native Edition"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+PR = "r0"
+
+SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
+ file://extra-keys.patch;patch=1 \
+ file://acinclude.m4"
+S = "${WORKDIR}/SDL-${PV}"
+
+inherit autotools native
+
+EXTRA_OECONF = "--disable-debug --disable-cdrom --enable-threads --enable-timers --enable-endian \
+ --enable-file --disable-oss --disable-alsa --disable-esd --disable-arts \
+ --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
+ --disable-mintaudio --disable-nasm --disable-video-x11 --disable-video-dga \
+ --disable-video-fbcon --disable-video-directfb --disable-video-ps2gs \
+ --disable-video-xbios --disable-video-gem --disable-video-dummy \
+ --disable-video-opengl --enable-input-events --enable-pthreads \
+ --disable-video-picogui --disable-video-qtopia --enable-dlopen"
+
+do_configure_prepend() {
+ rm -f ${S}/acinclude.m4
+ cp ${WORKDIR}/acinclude.m4 ${S}/
+}
+
+do_configure_append () {
+ cd ${S}
+
+ # prevent libtool from linking libs against libstdc++, libgcc, ...
+ cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
+ mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
+}
+
+do_stage() {
+ oe_libinstall -so -C src libSDL ${STAGING_LIBDIR}
+ ln -sf libSDL.so ${STAGING_LIBDIR}/libSDL-1.2.so
+ #oe_libinstall -a -C src/main libSDLmain ${STAGING_LIBDIR}
+ install -m 0644 src/main/libSDLmain.a ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/SDL
+ for f in include/*.h
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/SDL/
+ done
+
+ cat >${STAGING_BINDIR}/sdl-config-native <<EOF
+#!/bin/sh
+echo ""
+EOF
+ chmod a+rx ${STAGING_BINDIR}/sdl-config-native
+}
diff --git a/packages/libsdl/libsdl-ttf-native_2.0.3.bb b/packages/libsdl/libsdl-ttf-native_2.0.3.bb
new file mode 100644
index 0000000000..ced6862ad7
--- /dev/null
+++ b/packages/libsdl/libsdl-ttf-native_2.0.3.bb
@@ -0,0 +1,10 @@
+include libsdl-ttf_${PV}.bb
+inherit native
+
+DEPENDS = "libsdl-native"
+FILESPATH = "${FILE_DIRNAME}/libsdl-ttf-${PV}:${FILE_DIRNAME}/libsdl-ttf:${FILE_DIRNAME}/files"
+
+EXTRA_OECONF = "--disable-sdltest --with-sdl-prefix=${STAGING_LIBDIR}/.."
+
+export SDL_CONFIG = "${STAGING_BINDIR}/sdl-config-native"
+