aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libtool
diff options
context:
space:
mode:
authorMichael Krelin <hacker@klever.net>2007-07-05 21:21:29 +0000
committerMichael Krelin <hacker@klever.net>2007-07-05 21:21:29 +0000
commit61eb548006d6689118062794da3d2b35d8b4638f (patch)
tree193dbe86968bb6f0ac4a0d5c8b29fc3ffeff469e /packages/libtool
parent596bc6198dbeaaaa74db3c894b67121d5f50dfb6 (diff)
downloadopenembedded-61eb548006d6689118062794da3d2b35d8b4638f.tar.gz
libtool-{cross,native} 1.5.10: rework rpath stripping to make it controllable
Diffstat (limited to 'packages/libtool')
-rw-r--r--packages/libtool/libtool-1.5.10/rpath-control.patch21
-rw-r--r--packages/libtool/libtool-cross_1.5.10.bb5
-rw-r--r--packages/libtool/libtool-native_1.5.10.bb5
3 files changed, 26 insertions, 5 deletions
diff --git a/packages/libtool/libtool-1.5.10/rpath-control.patch b/packages/libtool/libtool-1.5.10/rpath-control.patch
new file mode 100644
index 0000000000..310fe3f8ae
--- /dev/null
+++ b/packages/libtool/libtool-1.5.10/rpath-control.patch
@@ -0,0 +1,21 @@
+diff --git a/ltmain.in b/ltmain.in
+--- a/ltmain.in
++++ b/ltmain.in
+@@ -3688,6 +3705,7 @@ EOF
+ rpath="$finalize_rpath"
+ test "$mode" != relink && rpath="$compile_rpath$rpath"
+ for libdir in $rpath; do
++ if test "$OE_LT_RPATH_ALLOW" = "any" -o "${OE_LT_RPATH_ALLOW/:${libdir}:/}" != "$OE_LT_RPATH_ALLOW" ; then
+ if test -n "$hardcode_libdir_flag_spec"; then
+ if test -n "$hardcode_libdir_separator"; then
+ if test -z "$hardcode_libdirs"; then
+@@ -3712,6 +3730,9 @@ EOF
+ *) perm_rpath="$perm_rpath $libdir" ;;
+ esac
+ fi
++ else
++ echo "OE: Not hardcoding '$libdir' into rpath"
++ fi
+ done
+ # Substitute the hardcoded libdirs into the rpath.
+ if test -n "$hardcode_libdir_separator" &&
diff --git a/packages/libtool/libtool-cross_1.5.10.bb b/packages/libtool/libtool-cross_1.5.10.bb
index f4ca30ca6d..fbb37d88d7 100644
--- a/packages/libtool/libtool-cross_1.5.10.bb
+++ b/packages/libtool/libtool-cross_1.5.10.bb
@@ -1,15 +1,14 @@
SECTION = "devel"
require libtool_${PV}.bb
-PR = "r5"
+PR = "r6"
PACKAGES = ""
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libtool-${PV}"
SRC_URI_append = " file://libdir-la.patch;patch=1 \
file://prefix.patch;patch=1 \
file://tag.patch;patch=1 \
file://tag1.patch;patch=1 \
- file://install-path-check.patch;patch=1 \
- file://never-ever-do-rpath.patch;patch=1 "
+ file://install-path-check.patch;patch=1"
S = "${WORKDIR}/libtool-${PV}"
prefix = "${STAGING_DIR}"
diff --git a/packages/libtool/libtool-native_1.5.10.bb b/packages/libtool/libtool-native_1.5.10.bb
index 6d8b1a1d7c..2780ef64ff 100644
--- a/packages/libtool/libtool-native_1.5.10.bb
+++ b/packages/libtool/libtool-native_1.5.10.bb
@@ -1,13 +1,14 @@
SECTION = "devel"
require libtool_${PV}.bb
-PR = "r5"
+PR = "r6"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libtool-${PV}"
SRC_URI_append = " file://libdir-la.patch;patch=1 \
file://prefix.patch;patch=1 \
file://tag.patch;patch=1 \
file://tag1.patch;patch=1 \
- file://install-path-check.patch;patch=1"
+ file://install-path-check.patch;patch=1 \
+ file://rpath-control.patch;patch=1"
S = "${WORKDIR}/libtool-${PV}"
inherit native