aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libvncserver
diff options
context:
space:
mode:
authorHolger Schurig <schurig@mn-solutions.de>2005-04-26 13:19:17 +0000
committerHolger Schurig <schurig@mn-solutions.de>2005-04-26 13:19:17 +0000
commit39a0c662502096b8fd428f3e3edbbfd1a4f200f7 (patch)
tree781ca432e0a2a402be8393727fd68a21d8a7346d /packages/libvncserver
parent47fd32ea069830ca0e1d879e0def5cd6627936c9 (diff)
downloadopenembedded-39a0c662502096b8fd428f3e3edbbfd1a4f200f7.tar.gz
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded/
into mnz66.mn-solutions.de:/usr/src/mnci54/oe 2005/04/26 15:18:40+02:00 mn-solutions.de!schurig unbreak the libvncserver.bb file. Note: the name of this bb file contains the substring 'lib' and 'server'. So it's for a library only and not for clients. When I run it, it errored out at when trying to install x11vnc. But that app hasn't been built, maybe because ./configure don't find any X11 related libs in my Qt2/Qt3 only buildroot. And anyway, X11 wasn't in the DEPENDS. I suggest that therefore one that needs x11vnc creates a x11vnc.bb file with proper DEPENDS lines. Second bug: test client_examples of libvncclient tried to link against libsdl. Because these examples don't get installed, there's no need to depend this lib on SDL, so I removed the compilation of those utilities. BKrev: 426e3fd5_NvE--1zrnN7K941-wpAdQ
Diffstat (limited to 'packages/libvncserver')
-rw-r--r--packages/libvncserver/libvncserver_0.7.1.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/libvncserver/libvncserver_0.7.1.bb b/packages/libvncserver/libvncserver_0.7.1.bb
index e69de29bb2..1ae86ea69b 100644
--- a/packages/libvncserver/libvncserver_0.7.1.bb
+++ b/packages/libvncserver/libvncserver_0.7.1.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "library for easy implementation of a RDP/VNC server"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "zlib jpeg"
+LICENSE = "GPL"
+PACKAGES = "libvncserver-storepasswd libvncserver-javaapplet"
+FILES_libvncserver-storepasswd = "${bindir}/storepasswd"
+FILES_libvncserver-javaapplet = "/${datadir}fbvncserver/classes/index.vnc \
+ /${datadir}fbvncserver/classes/VncViewer.jar"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libvncserver/LibVNCServer-${PV}.tar.gz"
+
+CFLAGS_append = " -D_REENTRANT"
+S = "${WORKDIR}/LibVNCServer-${PV}"
+# Original SUBDIRS is='libvncserver examples contrib x11vnc vncterm classes libvncclient client_examples test'
+EXTRA_OEMAKE_append=" SUBDIRS='libvncserver examples classes'"
+
+inherit autotools
+
+do_stage () {
+ install -d ${STAGING_INCDIR}/rfb
+ install -m 0644 rfb/rfb.h rfb/rfbproto.h rfb/rfbint.h rfb/rfbconfig.h \
+ rfb/rfbclient.h rfb/rfbregion.h rfb/keysym.h \
+ rfb/default8x16.h ${STAGING_INCDIR}/rfb
+
+ oe_libinstall -a -C libvncserver libvncserver ${STAGING_LIBDIR}/
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 examples/storepasswd ${D}${bindir}
+ install -d ${D}${datadir}fbvncserver/classes
+ install -m 0644 classes/index.vnc ${D}${datadir}fbvncserver/classes/
+ install -m 0644 classes/VncViewer.jar ${D}${datadir}fbvncserver/classes/
+}