aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libvorbis
diff options
context:
space:
mode:
authorJeremy Laine <jeremy.laine@m4x.org>2007-12-19 09:29:35 +0000
committerJeremy Laine <jeremy.laine@m4x.org>2007-12-19 09:29:35 +0000
commit8d6d348ed5c1cc1d06a1d14efb60d3dd45800a50 (patch)
treefa75bd18f162d385d3837317a5a9eae00af063bd /packages/libvorbis
parentb2e432d75e8b038f151dbe4799d1c7244b677a1e (diff)
downloadopenembedded-8d6d348ed5c1cc1d06a1d14efb60d3dd45800a50.tar.gz
libvorbis: package version 1.2.0
Diffstat (limited to 'packages/libvorbis')
-rw-r--r--packages/libvorbis/libvorbis_1.2.0.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/libvorbis/libvorbis_1.2.0.bb b/packages/libvorbis/libvorbis_1.2.0.bb
new file mode 100644
index 0000000000..79b79e8f49
--- /dev/null
+++ b/packages/libvorbis/libvorbis_1.2.0.bb
@@ -0,0 +1,30 @@
+SECTION = "libs"
+DEPENDS = "libogg"
+DESCRIPTION = "Ogg Vorbis is a high-quality lossy audio codec \
+that is free of intellectual property restrictions. libvorbis \
+is the main vorbis codec library."
+LICENSE = "BSD"
+
+SRC_URI = "http://downloads.xiph.org/releases/vorbis/libvorbis-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+# vorbisfile.c reveals a problem in the gcc register spilling for the
+# thumb instruction set...
+FULL_OPTIMIZATION_thumb = "-O0"
+
+EXTRA_OECONF = "--with-ogg-libraries=${STAGING_LIBDIR} \
+ --with-ogg-includes=${STAGING_INCDIR}"
+
+do_stage () {
+ oe_libinstall -a -so -C lib libvorbis ${STAGING_LIBDIR}
+ oe_libinstall -a -so -C lib libvorbisfile ${STAGING_LIBDIR}
+ oe_libinstall -a -so -C lib libvorbisenc ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/vorbis
+ install -m 0644 include/vorbis/vorbisenc.h \
+ include/vorbis/vorbisfile.h \
+ include/vorbis/codec.h ${STAGING_INCDIR}/vorbis/
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 vorbis.m4 ${STAGING_DATADIR}/aclocal/
+}