aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libxfce4util
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-08-02 20:54:26 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-02 20:54:26 +0000
commit274d6a9be8e83511871c30909eb4675e81805d5e (patch)
tree99ce1284cf1f9311b24e6f78851a15ff33d789ce /packages/libxfce4util
parenta023b903bfd1a45a026b228dbde5d680fe8bdf6c (diff)
downloadopenembedded-274d6a9be8e83511871c30909eb4675e81805d5e.tar.gz
xfce changes:
- remove settings out of xfce.bbclass that affect only one package (bbclasses are destined to express similarities in packages, not for easy hacking) - remove 4.2.0 versions, since 4.2.2 versions build fine - unmark libxfce4util as BROKEN - install libxfce* header files into STAGING_INCDIR/<packagename>, no need to extragroup them by STAGING_INCDIR/xfce4/<packagename>
Diffstat (limited to 'packages/libxfce4util')
-rw-r--r--packages/libxfce4util/libxfce4util.inc21
-rw-r--r--packages/libxfce4util/libxfce4util_4.2.0.bb34
-rw-r--r--packages/libxfce4util/libxfce4util_4.2.2.bb8
3 files changed, 10 insertions, 53 deletions
diff --git a/packages/libxfce4util/libxfce4util.inc b/packages/libxfce4util/libxfce4util.inc
index fcd5b74ad8..dbe6501e42 100644
--- a/packages/libxfce4util/libxfce4util.inc
+++ b/packages/libxfce4util/libxfce4util.inc
@@ -7,16 +7,6 @@ SECTION = "x11/libs"
LICENSE = "GPL"
DEPENDS = "glib-2.0"
-# | checking whether putenv() implementation is broken... configure: error: cannot run test program while cross compiling
-BROKEN = "1"
-
-# Fixed on i386/i486/i586/i686 - needs to be confirmed on other platforms
-
-BROKEN_i386="0"
-BROKEN_i486="0"
-BROKEN_i586="0"
-BROKEN_i686="0"
-
inherit xfce pkgconfig
XFCE_HEADERS="debug.h utf8.h xfce-generics.h xfce-resource.h \
@@ -24,11 +14,18 @@ XFCE_HEADERS="debug.h utf8.h xfce-generics.h xfce-resource.h \
xfce-desktopentry.h xfce-miscutils.h libxfce4util.h \
xfce-fileutils.h xfce-rc.h"
+MACROS="m4/X11.m4 m4/debug.m4 m4/depends.m4 m4/i18n.m4"
+
do_stage() {
- install -d ${STAGING_LIBDIR} ${STAGING_INCDIR}/xfce4/libxfce4util
+ install -d ${STAGING_LIBDIR} ${STAGING_INCDIR}/libxfce4util
for file in ${XFCE_HEADERS}; do
- install -m 644 libxfce4util/$file ${STAGING_INCDIR}/xfce4/libxfce4util
+ install -m 644 libxfce4util/$file ${STAGING_INCDIR}/libxfce4util
done
oe_libinstall -C libxfce4util -so libxfce4util ${STAGING_LIBDIR}
+
+ install -d ${STAGING_DATADIR}/aclocal/
+ install -m 0644 ${MACROS} ${STAGING_DATADIR}/aclocal/
}
+
+FILES_${PN}-dev += " ${datadir}/xfce4/m4"
diff --git a/packages/libxfce4util/libxfce4util_4.2.0.bb b/packages/libxfce4util/libxfce4util_4.2.0.bb
deleted file mode 100644
index fcd5b74ad8..0000000000
--- a/packages/libxfce4util/libxfce4util_4.2.0.bb
+++ /dev/null
@@ -1,34 +0,0 @@
-# libxfce4util OE build file
-# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
-# Released under the MIT license (see packages/COPYING)
-
-DESCRIPTION = "Basic utility library for Xfce4"
-SECTION = "x11/libs"
-LICENSE = "GPL"
-DEPENDS = "glib-2.0"
-
-# | checking whether putenv() implementation is broken... configure: error: cannot run test program while cross compiling
-BROKEN = "1"
-
-# Fixed on i386/i486/i586/i686 - needs to be confirmed on other platforms
-
-BROKEN_i386="0"
-BROKEN_i486="0"
-BROKEN_i586="0"
-BROKEN_i686="0"
-
-inherit xfce pkgconfig
-
-XFCE_HEADERS="debug.h utf8.h xfce-generics.h xfce-resource.h \
- i18n.h util.h xfce-kiosk.h libxfce4util-config.h \
- xfce-desktopentry.h xfce-miscutils.h libxfce4util.h \
- xfce-fileutils.h xfce-rc.h"
-
-do_stage() {
- install -d ${STAGING_LIBDIR} ${STAGING_INCDIR}/xfce4/libxfce4util
- for file in ${XFCE_HEADERS}; do
- install -m 644 libxfce4util/$file ${STAGING_INCDIR}/xfce4/libxfce4util
- done
-
- oe_libinstall -C libxfce4util -so libxfce4util ${STAGING_LIBDIR}
-}
diff --git a/packages/libxfce4util/libxfce4util_4.2.2.bb b/packages/libxfce4util/libxfce4util_4.2.2.bb
index 0fbc5321bb..e89d2cfa97 100644
--- a/packages/libxfce4util/libxfce4util_4.2.2.bb
+++ b/packages/libxfce4util/libxfce4util_4.2.2.bb
@@ -3,11 +3,5 @@
# Released under the MIT license (see packages/COPYING)
include ${PN}.inc
+PR = "r1"
-MACROS="m4/X11.m4 m4/debug.m4 m4/depends.m4 m4/i18n.m4"
-FILES_${PN}-dev += " ${datadir}/xfce4/m4"
-
-do_stage() {
- install -d ${STAGING_DATADIR}/aclocal/
- install -m 0644 ${MACROS} ${STAGING_DATADIR}/aclocal/
-}