aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libxfce4util
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-04-05 13:38:54 +0000
committerMichael Lauer <mickey@vanille-media.de>2005-04-05 13:38:54 +0000
commit7d40090e8f4703760e346c22bc97cf56d571df95 (patch)
tree5e1ffd6ccac7237b1b60355f90505f22ed627c4b /packages/libxfce4util
parent4b8985e828204f078cc614968373b3fbb18661de (diff)
downloadopenembedded-7d40090e8f4703760e346c22bc97cf56d571df95.tar.gz
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
into r2d2.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/04/05 15:35:53+02:00 uni-frankfurt.de!mickeyl mark gs, libxfce4util and file as broken, upgrade postfix BKrev: 425294ee8I4-J8RLc8hmki8n8A-Jug
Diffstat (limited to 'packages/libxfce4util')
-rw-r--r--packages/libxfce4util/libxfce4util_4.2.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/libxfce4util/libxfce4util_4.2.0.bb b/packages/libxfce4util/libxfce4util_4.2.0.bb
index e69de29bb2..15e0d3447c 100644
--- a/packages/libxfce4util/libxfce4util_4.2.0.bb
+++ b/packages/libxfce4util/libxfce4util_4.2.0.bb
@@ -0,0 +1,27 @@
+# libxfce4util OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "Basic utility library for Xfce4"
+SECTION = "x11/libs"
+LICENSE = "GPL"
+DEPENDS = "glib-2.0"
+
+# | checking whether putenv() implementation is broken... configure: error: cannot run test program while cross compiling
+BROKEN = "1"
+
+inherit xfce pkgconfig
+
+XFCE_HEADERS="debug.h utf8.h xfce-generics.h xfce-resource.h \
+ i18n.h util.h xfce-kiosk.h libxfce4util-config.h \
+ xfce-desktopentry.h xfce-miscutils.h libxfce4util.h \
+ xfce-fileutils.h xfce-rc.h"
+
+do_stage() {
+ install -d ${STAGING_LIBDIR} ${STAGING_INCDIR}/xfce4/libxfce4util
+ for file in ${XFCE_HEADERS}; do
+ install -m 644 libxfce4util/$file ${STAGING_INCDIR}/xfce4/libxfce4util
+ done
+
+ oe_libinstall -C libxfce4util -so libxfce4util ${STAGING_LIBDIR}
+}