aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libxfce4util
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/libxfce4util
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/libxfce4util')
-rw-r--r--packages/libxfce4util/.mtn2git_empty0
-rw-r--r--packages/libxfce4util/libxfce4util.inc34
-rw-r--r--packages/libxfce4util/libxfce4util_4.2.2.bb13
3 files changed, 47 insertions, 0 deletions
diff --git a/packages/libxfce4util/.mtn2git_empty b/packages/libxfce4util/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libxfce4util/.mtn2git_empty
diff --git a/packages/libxfce4util/libxfce4util.inc b/packages/libxfce4util/libxfce4util.inc
index e69de29bb2..fcd5b74ad8 100644
--- a/packages/libxfce4util/libxfce4util.inc
+++ b/packages/libxfce4util/libxfce4util.inc
@@ -0,0 +1,34 @@
+# libxfce4util OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "Basic utility library for Xfce4"
+SECTION = "x11/libs"
+LICENSE = "GPL"
+DEPENDS = "glib-2.0"
+
+# | checking whether putenv() implementation is broken... configure: error: cannot run test program while cross compiling
+BROKEN = "1"
+
+# Fixed on i386/i486/i586/i686 - needs to be confirmed on other platforms
+
+BROKEN_i386="0"
+BROKEN_i486="0"
+BROKEN_i586="0"
+BROKEN_i686="0"
+
+inherit xfce pkgconfig
+
+XFCE_HEADERS="debug.h utf8.h xfce-generics.h xfce-resource.h \
+ i18n.h util.h xfce-kiosk.h libxfce4util-config.h \
+ xfce-desktopentry.h xfce-miscutils.h libxfce4util.h \
+ xfce-fileutils.h xfce-rc.h"
+
+do_stage() {
+ install -d ${STAGING_LIBDIR} ${STAGING_INCDIR}/xfce4/libxfce4util
+ for file in ${XFCE_HEADERS}; do
+ install -m 644 libxfce4util/$file ${STAGING_INCDIR}/xfce4/libxfce4util
+ done
+
+ oe_libinstall -C libxfce4util -so libxfce4util ${STAGING_LIBDIR}
+}
diff --git a/packages/libxfce4util/libxfce4util_4.2.2.bb b/packages/libxfce4util/libxfce4util_4.2.2.bb
index e69de29bb2..0fbc5321bb 100644
--- a/packages/libxfce4util/libxfce4util_4.2.2.bb
+++ b/packages/libxfce4util/libxfce4util_4.2.2.bb
@@ -0,0 +1,13 @@
+# libxfce4util OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+include ${PN}.inc
+
+MACROS="m4/X11.m4 m4/debug.m4 m4/depends.m4 m4/i18n.m4"
+FILES_${PN}-dev += " ${datadir}/xfce4/m4"
+
+do_stage() {
+ install -d ${STAGING_DATADIR}/aclocal/
+ install -m 0644 ${MACROS} ${STAGING_DATADIR}/aclocal/
+}