aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libxfcegui4
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-08-02 20:54:26 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-02 20:54:26 +0000
commit274d6a9be8e83511871c30909eb4675e81805d5e (patch)
tree99ce1284cf1f9311b24e6f78851a15ff33d789ce /packages/libxfcegui4
parenta023b903bfd1a45a026b228dbde5d680fe8bdf6c (diff)
downloadopenembedded-274d6a9be8e83511871c30909eb4675e81805d5e.tar.gz
xfce changes:
- remove settings out of xfce.bbclass that affect only one package (bbclasses are destined to express similarities in packages, not for easy hacking) - remove 4.2.0 versions, since 4.2.2 versions build fine - unmark libxfce4util as BROKEN - install libxfce* header files into STAGING_INCDIR/<packagename>, no need to extragroup them by STAGING_INCDIR/xfce4/<packagename>
Diffstat (limited to 'packages/libxfcegui4')
-rw-r--r--packages/libxfcegui4/libxfcegui4.inc19
-rw-r--r--packages/libxfcegui4/libxfcegui4_4.2.0.bb53
2 files changed, 9 insertions, 63 deletions
diff --git a/packages/libxfcegui4/libxfcegui4.inc b/packages/libxfcegui4/libxfcegui4.inc
index 36a125b747..882cf3a55b 100644
--- a/packages/libxfcegui4/libxfcegui4.inc
+++ b/packages/libxfcegui4/libxfcegui4.inc
@@ -2,15 +2,12 @@
# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
# Released under the MIT license (see packages/COPYING)
-DESCRIPTION="XFCE Widget library and X Window System interaction"
-DEPENDS="libxfce4util dbh libxml2 gtk+"
+DESCRIPTION = "XFCE Widget library and X Window System interaction"
+DEPENDS = "libxfce4util dbh libxml2 gtk+"
SECTION = "x11/libs"
inherit xfce pkgconfig
-FILES_${PN} += "/usr/lib/xfce4/modules/* /usr/share/xfce4/mime/ \
- /usr/share/icons/hicolor/"
-
XFCE_HEADERS= "dialogs.h netk-trayicon.h xfce-icontheme.h \
gtk_style.h netk-util.h xfce_aboutdialog.h \
gtktoxevent.h netk-window-action-menu.h xfce_clock.h \
@@ -29,17 +26,17 @@ XFCE_HEADERS= "dialogs.h netk-trayicon.h xfce-icontheme.h \
MODULE_HEADERS="combo.h constants.h mime.h mime_icons.h"
do_stage() {
- install -d ${STAGING_INCDIR}/xfce4/libxfcegui4
- install -d ${STAGING_INCDIR}/xfce4/xfce4-modules
- install -d ${STAGING_LIBDIR}/xfce4/modules
+ install -d ${STAGING_INCDIR}/libxfcegui4
+ install -d ${STAGING_INCDIR}/xfce4-modules
+ install -d ${STAGING_LIBDIR}/modules
for file in ${XFCE_HEADERS}; do
- install -m 644 libxfcegui4/$file ${STAGING_INCDIR}/xfce4/libxfcegui4
+ install -m 644 libxfcegui4/$file ${STAGING_INCDIR}/libxfcegui4
done
for file in ${MODULE_HEADERS}; do
install -m 644 xfce4-modules/headers/$file \
- ${STAGING_INCDIR}/xfce4/xfce4-modules
+ ${STAGING_INCDIR}/xfce4-modules
done
oe_libinstall -C libxfcegui4 -so libxfcegui4 ${STAGING_LIBDIR}
@@ -51,3 +48,5 @@ do_stage() {
oe_libinstall -C xfce4-modules/mime-applications -so libxfce4_mime \
${STAGING_LIBDIR}/xfce4/modules
}
+
+FILES_${PN} += "${libdir}/xfce4/modules ${datadir}/xfce4/mime ${datadir}/icons/hicolor"
diff --git a/packages/libxfcegui4/libxfcegui4_4.2.0.bb b/packages/libxfcegui4/libxfcegui4_4.2.0.bb
deleted file mode 100644
index 4eb5d8a781..0000000000
--- a/packages/libxfcegui4/libxfcegui4_4.2.0.bb
+++ /dev/null
@@ -1,53 +0,0 @@
-SECTION = "x11/libs"
-# libxfcegui4 OE build file
-# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
-# Released under the MIT license (see packages/COPYING)
-
-DESCRIPTION="XFCE Widget library and X Window System interaction"
-DEPENDS="libxfce4util dbh libxml2 gtk+"
-
-inherit xfce pkgconfig
-
-FILES_${PN} += "/usr/lib/xfce4/modules/* /usr/share/xfce4/mime/ \
- /usr/share/icons/hicolor/"
-
-XFCE_HEADERS= "dialogs.h netk-trayicon.h xfce-icontheme.h \
- gtk_style.h netk-util.h xfce_aboutdialog.h \
- gtktoxevent.h netk-window-action-menu.h xfce_clock.h \
- icons.h netk-window-menu.h xfce_decorbutton.h \
- libnetk.h netk-window.h xfce_decortoggle.h \
- libxfcegui4-config.h netk-workspace.h xfce_framebox.h \
- libxfcegui4.h preview_filesel.h xfce_iconbutton.h \
- netk-application.h session-client.h xfce_marshal.h \
- netk-class-group.h xfce-appmenuitem.h xfce_menubutton.h \
- netk-enum-types.h xfce-colorbutton.h xfce_movehandler.h \
- netk-marshal.h xfce-exec.h xfce_scaled_image.h \
- netk-pager.h xfce-filechooser.h xfce_systemtray.h \
- netk-screen.h xfce-gdk-extensions.h xfce_togglebutton.h \
- netk-tasklist.h xfce-gtk-extensions.h xinerama.h"
-
-MODULE_HEADERS="combo.h constants.h mime.h mime_icons.h"
-
-do_stage() {
- install -d ${STAGING_INCDIR}/xfce4/libxfcegui4
- install -d ${STAGING_INCDIR}/xfce4/xfce4-modules
- install -d ${STAGING_LIBDIR}/xfce4/modules
-
- for file in ${XFCE_HEADERS}; do
- install -m 644 libxfcegui4/$file ${STAGING_INCDIR}/xfce4/libxfcegui4
- done
-
- for file in ${MODULE_HEADERS}; do
- install -m 644 xfce4-modules/headers/$file \
- ${STAGING_INCDIR}/xfce4/xfce4-modules
- done
-
- oe_libinstall -C libxfcegui4 -so libxfcegui4 ${STAGING_LIBDIR}
-
- oe_libinstall -C xfce4-modules/mime-icons -so libxfce4_mime_icons \
- ${STAGING_LIBDIR}/xfce4/modules
- oe_libinstall -C xfce4-modules/combo -so libxfce4_combo \
- ${STAGING_LIBDIR}/xfce4/modules
- oe_libinstall -C xfce4-modules/mime-applications -so libxfce4_mime \
- ${STAGING_LIBDIR}/xfce4/modules
-}