aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libxml
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2008-01-29 11:58:52 +0000
committerRobert Schuster <thebohemian@gmx.net>2008-01-29 11:58:52 +0000
commit38b67b4fae5ff0e168f80c157e372ede8ca4e8f1 (patch)
tree641af94d16b604ee55bfb22b773f1c86c97b5654 /packages/libxml
parent77cb724357c5ced429a7c5445c4db6aa18fe84d7 (diff)
downloadopenembedded-38b67b4fae5ff0e168f80c157e372ede8ca4e8f1.tar.gz
libxml2: Provide common include
- added 2.6.27 recipe (for Maemo) - changed 2.6.29 recipe to use the include chinook-compat.conf: - fixed version preference for libxml2
Diffstat (limited to 'packages/libxml')
-rw-r--r--packages/libxml/libxml2.inc29
-rw-r--r--packages/libxml/libxml2_2.6.27.bb3
-rw-r--r--packages/libxml/libxml2_2.6.29.bb30
3 files changed, 34 insertions, 28 deletions
diff --git a/packages/libxml/libxml2.inc b/packages/libxml/libxml2.inc
new file mode 100644
index 0000000000..3f83f76ed5
--- /dev/null
+++ b/packages/libxml/libxml2.inc
@@ -0,0 +1,29 @@
+DESCRIPTION = "GNOME XML Parser library"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "MIT"
+
+SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz"
+
+inherit autotools pkgconfig binconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n"
+
+export LDFLAGS += "-ldl"
+
+do_stage() {
+ autotools_stage_all
+ install -d ${STAGING_DATADIR}/aclocal/
+ install -d ${STAGING_BINDIR_CROSS}
+
+ install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
+ #this is need it by php during its install
+ install -m 0755 xml2-config ${STAGING_BINDIR_CROSS}
+}
+
+DEBIANNAME_${PN} = "libxml2"
+
+PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/*-config"
+FILES_${PN}-utils += "${bindir}/*"
diff --git a/packages/libxml/libxml2_2.6.27.bb b/packages/libxml/libxml2_2.6.27.bb
new file mode 100644
index 0000000000..2a85ce8956
--- /dev/null
+++ b/packages/libxml/libxml2_2.6.27.bb
@@ -0,0 +1,3 @@
+# You want this old version for compatibility with Maemo OS2008.
+require libxml2.inc
+
diff --git a/packages/libxml/libxml2_2.6.29.bb b/packages/libxml/libxml2_2.6.29.bb
index 6f1c8632b1..b366a8278c 100644
--- a/packages/libxml/libxml2_2.6.29.bb
+++ b/packages/libxml/libxml2_2.6.29.bb
@@ -1,30 +1,4 @@
-DESCRIPTION = "GNOME XML Parser library"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "MIT"
-PR = "r5"
-
-SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz"
-
-inherit autotools pkgconfig binconfig
-
-EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n"
-
-export LDFLAGS += "-ldl"
+require libxml2.inc
-do_stage() {
- autotools_stage_all
- install -d ${STAGING_DATADIR}/aclocal/
- install -d ${STAGING_BINDIR_CROSS}
-
- install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
- #this is need it by php during its install
- install -m 0755 xml2-config ${STAGING_BINDIR_CROSS}
-}
-
-DEBIANNAME_${PN} = "libxml2"
-
-PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+PR = "r5"
-FILES_${PN}-dev += "${bindir}/*-config"
-FILES_${PN}-utils += "${bindir}/*"