aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libxml
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-09-29 21:38:40 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-09-29 21:38:40 +0000
commit79a652089c63bd0b00f794ebb2790ab50499c68f (patch)
treec646ab7804fe8731f4e5300ba1e691c91e55f622 /packages/libxml
parent3123faca484adb68e0bb77de716b00024a82f086 (diff)
downloadopenembedded-79a652089c63bd0b00f794ebb2790ab50499c68f.tar.gz
libxml: added 2.6.26
Diffstat (limited to 'packages/libxml')
-rw-r--r--packages/libxml/libxml2_2.6.26.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/libxml/libxml2_2.6.26.bb b/packages/libxml/libxml2_2.6.26.bb
new file mode 100644
index 0000000000..192eb14275
--- /dev/null
+++ b/packages/libxml/libxml2_2.6.26.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "GNOME XML library"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "MIT"
+
+SRC_URI = "http://xmlsoft.org/sources/libxml2/libxml2-${PV}.tar.gz"
+
+inherit autotools pkgconfig binconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --without-c14n"
+
+do_stage() {
+ autotools_stage_all
+ install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+python populate_packages_prepend () {
+ # autonamer would call this libxml2-2, but we don't want that
+ if bb.data.getVar('DEBIAN_NAMES', d, 1):
+ bb.data.setVar('PKG_libxml2', 'libxml2', d)
+}
+
+PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/*-config"
+FILES_${PN}-utils += "${bindir}/*"