aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libxml
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-11-13 13:37:47 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-13 13:37:47 +0000
commit7aad88d6c1e741b0917ebd74128cebc1277ce989 (patch)
tree45b4d09ee0314eb03af6ec42d0e23070eacca47f /packages/libxml
parent8ee2c7a7c6fb699904cf9a29c14ed181526abcd6 (diff)
downloadopenembedded-7aad88d6c1e741b0917ebd74128cebc1277ce989.tar.gz
libxml2: add 2.6.22 with a patch to remove the regression tester that fails to compile (the irony!)
Diffstat (limited to 'packages/libxml')
-rw-r--r--packages/libxml/files/.mtn2git_empty0
-rw-r--r--packages/libxml/files/no-testapi.patch51
-rw-r--r--packages/libxml/libxml2_2.6.22.bb40
3 files changed, 91 insertions, 0 deletions
diff --git a/packages/libxml/files/.mtn2git_empty b/packages/libxml/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libxml/files/.mtn2git_empty
diff --git a/packages/libxml/files/no-testapi.patch b/packages/libxml/files/no-testapi.patch
new file mode 100644
index 0000000000..15a4dea0ee
--- /dev/null
+++ b/packages/libxml/files/no-testapi.patch
@@ -0,0 +1,51 @@
+--- /tmp/Makefile.am 2005-11-13 14:33:15.844432536 +0100
++++ libxml2-2.6.22/Makefile.am 2005-11-13 14:33:25.796919528 +0100
+@@ -8,7 +8,7 @@
+
+ noinst_PROGRAMS=testSchemas testRelax testSAX testHTML testXPath testURI \
+ testThreads testC14N testAutomata testRegexp \
+- testReader testapi testModule runtest runsuite
++ testReader testModule runtest runsuite
+
+ bin_PROGRAMS = xmllint xmlcatalog
+
+@@ -135,20 +135,9 @@
+ testdso_la_LDFLAGS = -module -rpath $(libdir)
+
+ # that one forces the rebuild when "make rebuild" is run on doc/
+-rebuild_testapi:
+- -@(if [ "$(PYTHON)" != "" ] ; then \
+- $(PYTHON) $(srcdir)/gentest.py $(srcdir) ; fi )
+
+ # that one is just to make sure it is rebuilt if missing
+ # but adding the dependances generate mess
+-testapi.c:
+- -@(if [ "$(PYTHON)" != "" ] ; then \
+- $(PYTHON) $(srcdir)/gentest.py $(srcdir) ; fi )
+-
+-testapi_SOURCES=testapi.c
+-testapi_LDFLAGS =
+-testapi_DEPENDENCIES = $(DEPS)
+-testapi_LDADD= $(LDADDS)
+
+ #testOOM_SOURCES=testOOM.c testOOMlib.h testOOMlib.c
+ #testOOM_LDFLAGS =
+@@ -169,9 +158,6 @@
+ @echo '## Go get a cup of coffee it is gonna take a while ...'
+ $(MAKE) CHECKER='valgrind' tests
+
+-APItests: testapi$(EXEEXT)
+- @echo "## Running the API regression tests this may take a little while"
+- -@($(CHECKER) $(top_builddir)/testapi -q)
+
+ HTMLtests : testHTML$(EXEEXT)
+ @(echo > .memdump)
+@@ -1116,7 +1102,7 @@
+ dist-test: distdir
+ (mkdir -p $(distdir))
+ (cd $(srcdir) ; tar -cf - --exclude CVS xstc/Tests) | (cd $(distdir); tar xf -)
+- tar -cf - $(distdir)/test $(distdir)/result $(distdir)/xstc/Tests $(distdir)/Makefile.tests $(distdir)/README $(distdir)/README.tests $(distdir)/AUTHORS $(distdir)/testapi.c $(distdir)/runtest.c $(distdir)/runsuite.c | GZIP=$(GZIP_ENV) gzip -c >`echo "$(distdir)" | sed "s+libxml2+libxml2-tests+"`.tar.gz
++ tar -cf - $(distdir)/test $(distdir)/result $(distdir)/xstc/Tests $(distdir)/Makefile.tests $(distdir)/README $(distdir)/README.tests $(distdir)/AUTHORS $(distdir)/runtest.c $(distdir)/runsuite.c | GZIP=$(GZIP_ENV) gzip -c >`echo "$(distdir)" | sed "s+libxml2+libxml2-tests+"`.tar.gz
+ @(rm -rf $(distdir)/xstc/Test)
+
+ cleantar:
diff --git a/packages/libxml/libxml2_2.6.22.bb b/packages/libxml/libxml2_2.6.22.bb
new file mode 100644
index 0000000000..2aba2ea071
--- /dev/null
+++ b/packages/libxml/libxml2_2.6.22.bb
@@ -0,0 +1,40 @@
+PR = "r0"
+DESCRIPTION = "GNOME XML library"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "MIT"
+PACKAGES = "${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/xml-config"
+FILES_${PN}-utils += "${bindir}"
+
+SRC_URI = "http://xmlsoft.org/sources/libxml2-${PV}.tar.gz \
+ file://no-testapi.patch;patch=1"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-schemas --without-catalog --without-docbook --without-c14n"
+
+headers = "DOCBparser.h HTMLparser.h HTMLtree.h SAX.h SAX2.h c14n.h catalog.h chvalid.h debugXML.h dict.h encoding.h entities.h globals.h hash.h list.h nanoftp.h nanohttp.h parser.h parserInternals.h pattern.h relaxng.h schemasInternals.h threads.h tree.h uri.h valid.h xinclude.h xlink.h xmlIO.h xmlautomata.h xmlerror.h xmlexports.h xmlmemory.h xmlreader.h xmlregexp.h xmlschemas.h xmlschemastypes.h xmlstring.h xmlunicode.h xmlversion.h xmlwriter.h xpath.h xpathInternals.h xpointer.h"
+
+do_stage () {
+ oe_libinstall -so libxml2 ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/libxml2/libxml
+ for i in ${headers}; do
+ install -m 0644 include/libxml/$i ${STAGING_INCDIR}/libxml2/libxml/$i
+ done
+
+ cat xml2-config | sed -e "s,^prefix=.*,prefix=${STAGING_BINDIR}/..," \
+ -e "s,^exec_prefix=.*,exec_prefix=${STAGING_BINDIR}/..," \
+ -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \
+ -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR}/xml2-config
+ chmod a+rx ${STAGING_BINDIR}/xml2-config
+ install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+python populate_packages_prepend () {
+ # autonamer would call this libxml2-2, but we don't want that
+ if bb.data.getVar('DEBIAN_NAMES', d, 1):
+ bb.data.setVar('PKG_libxml2', 'libxml2', d)
+}