aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libxml
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-31 22:27:41 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-31 22:27:41 +0000
commit9c9c7139952b06112d99b5b11bfa3d36435a6459 (patch)
treefd0778f2b3d3d14f05cd4ff4b4cb341573e92d82 /packages/libxml
parentf73398ac656a31e2bbd214a3b2c3dc92eddaaecf (diff)
downloadopenembedded-9c9c7139952b06112d99b5b11bfa3d36435a6459.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2004/12/31 14:27:40-08:00 (none)!ggilbert Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into olddog.(none):/home/ggilbert/oe/openembedded 2004/12/31 14:27:30-08:00 (none)!ggilbert Add many licenses 2004/12/31 21:28:22+00:00 nexus.co.uk!pb fix typo introduced with recent LICENSE patches 2004/12/31 21:12:38+00:00 nexus.co.uk!pb gpe-soundbite is GPL 2004/12/31 21:11:57+00:00 nexus.co.uk!pb gpe-question is GPL 2004/12/31 21:11:12+00:00 nexus.co.uk!pb gpe-nmf is GPL 2004/12/31 21:10:28+00:00 nexus.co.uk!pb gpe-gallery is GPL 2004/12/31 21:09:42+00:00 nexus.co.uk!pb gpe-edit is GPL 2004/12/31 21:07:12+00:00 nexus.co.uk!pb gpe-ownerinfo is GPL 2004/12/31 21:03:44+00:00 nexus.co.uk!pb delete old gpe-bootsplash with no LICENSE 2004/12/31 21:02:29+00:00 nexus.co.uk!pb delete some old gpe-clock versions with no LICENSE 2004/12/31 21:00:16+00:00 nexus.co.uk!pb delete old hotplug-dbus versions with no LICENSE 2004/12/31 20:59:20+00:00 nexus.co.uk!pb Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into stealth.nexus.co.uk:/home/pb/oe/oe 2004/12/31 13:35:00-08:00 (none)!ggilbert Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into olddog.(none):/home/ggilbert/oe/openembedded 2004/12/31 13:34:19-08:00 (none)!ggilbert More licenses 2004/12/31 20:59:03+00:00 nexus.co.uk!pb add LICENSE for gpe-confd, and blow away some old versions BKrev: 41d5d25dQOnhk1FZOyFZXNL3fxoihA
Diffstat (limited to 'packages/libxml')
-rw-r--r--packages/libxml/libxml2_2.6.10.bb40
-rw-r--r--packages/libxml/libxml2_2.6.7.bb40
-rw-r--r--packages/libxml/libxml2_2.6.9.bb40
3 files changed, 120 insertions, 0 deletions
diff --git a/packages/libxml/libxml2_2.6.10.bb b/packages/libxml/libxml2_2.6.10.bb
index e69de29bb2..b98f8be47e 100644
--- a/packages/libxml/libxml2_2.6.10.bb
+++ b/packages/libxml/libxml2_2.6.10.bb
@@ -0,0 +1,40 @@
+PR = "r0"
+DESCRIPTION = "GNOME XML library"
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+LICENSE = "MIT"
+PACKAGES = "${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/xml-config"
+FILES_${PN}-utils += "${bindir}"
+
+SRC_URI = "http://xmlsoft.org/sources/libxml2-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-schemas --without-catalog --without-docbook --without-c14n"
+
+headers = "DOCBparser.h HTMLparser.h HTMLtree.h SAX.h SAX2.h c14n.h catalog.h chvalid.h debugXML.h dict.h encoding.h entities.h globals.h hash.h list.h nanoftp.h nanohttp.h parser.h parserInternals.h pattern.h relaxng.h schemasInternals.h threads.h tree.h uri.h valid.h xinclude.h xlink.h xmlIO.h xmlautomata.h xmlerror.h xmlexports.h xmlmemory.h xmlreader.h xmlregexp.h xmlschemas.h xmlschemastypes.h xmlstring.h xmlunicode.h xmlversion.h xmlwriter.h xpath.h xpathInternals.h xpointer.h"
+
+do_stage () {
+ oe_libinstall -so libxml2 ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/libxml2/libxml
+ for i in ${headers}; do
+ install -m 0644 include/libxml/$i ${STAGING_INCDIR}/libxml2/libxml/$i
+ done
+
+ cat xml2-config | sed -e "s,^prefix=.*,prefix=${STAGING_BINDIR}/..," \
+ -e "s,^exec_prefix=.*,exec_prefix=${STAGING_BINDIR}/..," \
+ -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \
+ -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR}/xml2-config
+ chmod a+rx ${STAGING_BINDIR}/xml2-config
+ install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+python populate_packages_prepend () {
+ # autonamer would call this libxml2-2, but we don't want that
+ if bb.data.getVar('DEBIAN_NAMES', d, 1):
+ bb.data.setVar('PKG_libxml2', 'libxml2', d)
+}
diff --git a/packages/libxml/libxml2_2.6.7.bb b/packages/libxml/libxml2_2.6.7.bb
index e69de29bb2..9441303e5e 100644
--- a/packages/libxml/libxml2_2.6.7.bb
+++ b/packages/libxml/libxml2_2.6.7.bb
@@ -0,0 +1,40 @@
+PR = "r1"
+DESCRIPTION = "GNOME XML library"
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+LICENSE = "MIT"
+PACKAGES = "${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/xml-config"
+FILES_${PN}-utils += "${bindir}"
+
+SRC_URI = "http://xmlsoft.org/sources/libxml2-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-schemas --without-catalog --without-docbook --without-c14n"
+
+headers = "DOCBparser.h HTMLparser.h HTMLtree.h SAX.h SAX2.h c14n.h catalog.h chvalid.h debugXML.h dict.h encoding.h entities.h globals.h hash.h list.h nanoftp.h nanohttp.h parser.h parserInternals.h pattern.h relaxng.h schemasInternals.h threads.h tree.h uri.h valid.h xinclude.h xlink.h xmlIO.h xmlautomata.h xmlerror.h xmlexports.h xmlmemory.h xmlreader.h xmlregexp.h xmlschemas.h xmlschemastypes.h xmlstring.h xmlunicode.h xmlversion.h xmlwriter.h xpath.h xpathInternals.h xpointer.h"
+
+do_stage () {
+ oe_libinstall -so libxml2 ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/libxml2/libxml
+ for i in ${headers}; do
+ install -m 0644 include/libxml/$i ${STAGING_INCDIR}/libxml2/libxml/$i
+ done
+
+ cat xml2-config | sed -e "s,^prefix=.*,prefix=${STAGING_BINDIR}/..," \
+ -e "s,^exec_prefix=.*,exec_prefix=${STAGING_BINDIR}/..," \
+ -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \
+ -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR}/xml2-config
+ chmod a+rx ${STAGING_BINDIR}/xml2-config
+ install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+python populate_packages_prepend () {
+ # autonamer would call this libxml2-2, but we don't want that
+ if bb.data.getVar('DEBIAN_NAMES', d, 1):
+ bb.data.setVar('PKG_libxml2', 'libxml2', d)
+}
diff --git a/packages/libxml/libxml2_2.6.9.bb b/packages/libxml/libxml2_2.6.9.bb
index e69de29bb2..b98f8be47e 100644
--- a/packages/libxml/libxml2_2.6.9.bb
+++ b/packages/libxml/libxml2_2.6.9.bb
@@ -0,0 +1,40 @@
+PR = "r0"
+DESCRIPTION = "GNOME XML library"
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+LICENSE = "MIT"
+PACKAGES = "${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/xml-config"
+FILES_${PN}-utils += "${bindir}"
+
+SRC_URI = "http://xmlsoft.org/sources/libxml2-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-schemas --without-catalog --without-docbook --without-c14n"
+
+headers = "DOCBparser.h HTMLparser.h HTMLtree.h SAX.h SAX2.h c14n.h catalog.h chvalid.h debugXML.h dict.h encoding.h entities.h globals.h hash.h list.h nanoftp.h nanohttp.h parser.h parserInternals.h pattern.h relaxng.h schemasInternals.h threads.h tree.h uri.h valid.h xinclude.h xlink.h xmlIO.h xmlautomata.h xmlerror.h xmlexports.h xmlmemory.h xmlreader.h xmlregexp.h xmlschemas.h xmlschemastypes.h xmlstring.h xmlunicode.h xmlversion.h xmlwriter.h xpath.h xpathInternals.h xpointer.h"
+
+do_stage () {
+ oe_libinstall -so libxml2 ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/libxml2/libxml
+ for i in ${headers}; do
+ install -m 0644 include/libxml/$i ${STAGING_INCDIR}/libxml2/libxml/$i
+ done
+
+ cat xml2-config | sed -e "s,^prefix=.*,prefix=${STAGING_BINDIR}/..," \
+ -e "s,^exec_prefix=.*,exec_prefix=${STAGING_BINDIR}/..," \
+ -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \
+ -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR}/xml2-config
+ chmod a+rx ${STAGING_BINDIR}/xml2-config
+ install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+python populate_packages_prepend () {
+ # autonamer would call this libxml2-2, but we don't want that
+ if bb.data.getVar('DEBIAN_NAMES', d, 1):
+ bb.data.setVar('PKG_libxml2', 'libxml2', d)
+}