aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libxml
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2008-09-19 23:59:19 +0000
committerKhem Raj <raj.khem@gmail.com>2008-09-19 23:59:19 +0000
commita23bdd1fc89e4a50d87280a225b410c8eec1d8e2 (patch)
tree46d9c6d3a8d4d0dc866c62d9adbc0ccf15268627 /packages/libxml
parenteaabdabd762138f056f347020df8717003887584 (diff)
downloadopenembedded-a23bdd1fc89e4a50d87280a225b410c8eec1d8e2.tar.gz
Add new recipes. Old recipes do not compile with gcc 4.3. They need backports.
Diffstat (limited to 'packages/libxml')
-rw-r--r--packages/libxml/libxml2-native_2.6.32.bb24
-rw-r--r--packages/libxml/libxml2_2.6.32.bb4
2 files changed, 28 insertions, 0 deletions
diff --git a/packages/libxml/libxml2-native_2.6.32.bb b/packages/libxml/libxml2-native_2.6.32.bb
new file mode 100644
index 0000000000..914a301a31
--- /dev/null
+++ b/packages/libxml/libxml2-native_2.6.32.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "GNOME XML library"
+DEPENDS = "python-native"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libxml2-${PV}"
+PR = "r0"
+
+SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz"
+S = "${WORKDIR}/libxml2-${PV}"
+
+inherit autotools native pkgconfig
+
+def libxml2_native_python_dir(d):
+ import os, bb
+ staging_incdir = bb.data.getVar( "STAGING_INCDIR", d, 1 )
+ if os.path.exists( "%s/python2.5" % staging_incdir ): return "python2.5"
+ if os.path.exists( "%s/python2.4" % staging_incdir ): return "python2.4"
+ if os.path.exists( "%s/python2.3" % staging_incdir ): return "python2.3"
+ raise "No Python in STAGING_INCDIR. Forgot to build python-native ?"
+
+EXTRA_OECONF = "--with-python=${STAGING_INCDIR}/${@libxml2_native_python_dir(d)} \
+ --without-debug --without-legacy --without-catalog --without-docbook --with-c14n"
+
+do_stage () {
+ oe_runmake install
+}
diff --git a/packages/libxml/libxml2_2.6.32.bb b/packages/libxml/libxml2_2.6.32.bb
new file mode 100644
index 0000000000..555a436a63
--- /dev/null
+++ b/packages/libxml/libxml2_2.6.32.bb
@@ -0,0 +1,4 @@
+require libxml2.inc
+
+PR = "r0"
+