aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libxml
diff options
context:
space:
mode:
authorRaymond Danks <raymond@edanks.com>2006-07-24 16:12:16 +0000
committerRaymond Danks <raymond@edanks.com>2006-07-24 16:12:16 +0000
commitbdc547481c8806779ce9b7eb99ae16a14f05f128 (patch)
treeb7144bf90279f8a0b6ac1698ef3d29fce812e0a0 /packages/libxml
parent715ce131f9d589314eb50aed86523d2c19e38085 (diff)
downloadopenembedded-bdc547481c8806779ce9b7eb99ae16a14f05f128.tar.gz
libxml-native - Initial add.
Diffstat (limited to 'packages/libxml')
-rw-r--r--packages/libxml/libxml2-native_2.6.10.bb17
-rw-r--r--packages/libxml/libxml2-native_2.6.9.bb17
2 files changed, 34 insertions, 0 deletions
diff --git a/packages/libxml/libxml2-native_2.6.10.bb b/packages/libxml/libxml2-native_2.6.10.bb
new file mode 100644
index 0000000000..1a387c4d81
--- /dev/null
+++ b/packages/libxml/libxml2-native_2.6.10.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "GNOME XML library"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+
+SRC_URI = "http://xmlsoft.org/sources/libxml2-${PV}.tar.gz"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libxml2-${PV}"
+S = "${WORKDIR}/libxml2-${PV}"
+
+inherit autotools native pkgconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-schemas --without-catalog --without-docbook --without-c14n"
+
+headers = "DOCBparser.h HTMLparser.h HTMLtree.h SAX.h SAX2.h c14n.h catalog.h chvalid.h debugXML.h dict.h encoding.h entities.h globals.h hash.h list.h nanoftp.h nanohttp.h parser.h parserInternals.h pattern.h relaxng.h schemasInternals.h threads.h tree.h uri.h valid.h xinclude.h xlink.h xmlIO.h xmlautomata.h xmlerror.h xmlexports.h xmlmemory.h xmlreader.h xmlregexp.h xmlschemas.h xmlschemastypes.h xmlstring.h xmlunicode.h xmlversion.h xmlwriter.h xpath.h xpathInternals.h xpointer.h"
+
+do_stage () {
+ oe_runmake install
+}
diff --git a/packages/libxml/libxml2-native_2.6.9.bb b/packages/libxml/libxml2-native_2.6.9.bb
new file mode 100644
index 0000000000..1a387c4d81
--- /dev/null
+++ b/packages/libxml/libxml2-native_2.6.9.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "GNOME XML library"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+
+SRC_URI = "http://xmlsoft.org/sources/libxml2-${PV}.tar.gz"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libxml2-${PV}"
+S = "${WORKDIR}/libxml2-${PV}"
+
+inherit autotools native pkgconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-schemas --without-catalog --without-docbook --without-c14n"
+
+headers = "DOCBparser.h HTMLparser.h HTMLtree.h SAX.h SAX2.h c14n.h catalog.h chvalid.h debugXML.h dict.h encoding.h entities.h globals.h hash.h list.h nanoftp.h nanohttp.h parser.h parserInternals.h pattern.h relaxng.h schemasInternals.h threads.h tree.h uri.h valid.h xinclude.h xlink.h xmlIO.h xmlautomata.h xmlerror.h xmlexports.h xmlmemory.h xmlreader.h xmlregexp.h xmlschemas.h xmlschemastypes.h xmlstring.h xmlunicode.h xmlversion.h xmlwriter.h xpath.h xpathInternals.h xpointer.h"
+
+do_stage () {
+ oe_runmake install
+}