aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libxml
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-09-26 18:41:12 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-09-26 18:41:12 +0000
commitc7c678114ca9242c676afed4b9ec51e3ae6bbf72 (patch)
tree2cc42242647a44816f72df1e7e2d82825295aa34 /packages/libxml
parent169805496d611cc67e5cdc5d8391da3ea493689a (diff)
downloadopenembedded-c7c678114ca9242c676afed4b9ec51e3ae6bbf72.tar.gz
libxml2-native all silence duplicated function warning by refactoring into .inc
Diffstat (limited to 'packages/libxml')
-rw-r--r--packages/libxml/libxml2-native.inc24
-rw-r--r--packages/libxml/libxml2-native_2.6.29.bb24
-rw-r--r--packages/libxml/libxml2-native_2.6.32.bb24
3 files changed, 26 insertions, 46 deletions
diff --git a/packages/libxml/libxml2-native.inc b/packages/libxml/libxml2-native.inc
new file mode 100644
index 0000000000..5672792db3
--- /dev/null
+++ b/packages/libxml/libxml2-native.inc
@@ -0,0 +1,24 @@
+DESCRIPTION = "GNOME XML library"
+DEPENDS = "python-native"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libxml2-${PV}"
+PR = "r3"
+
+SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz"
+S = "${WORKDIR}/libxml2-${PV}"
+
+inherit autotools native pkgconfig
+
+def libxml2_native_python_dir(d):
+ import os, bb
+ staging_incdir = bb.data.getVar( "STAGING_INCDIR", d, 1 )
+ if os.path.exists( "%s/python2.5" % staging_incdir ): return "python2.5"
+ if os.path.exists( "%s/python2.4" % staging_incdir ): return "python2.4"
+ if os.path.exists( "%s/python2.3" % staging_incdir ): return "python2.3"
+ raise "No Python in STAGING_INCDIR. Forgot to build python-native ?"
+
+EXTRA_OECONF = "--with-python=${STAGING_INCDIR}/${@libxml2_native_python_dir(d)} \
+ --without-debug --without-legacy --without-catalog --without-docbook --with-c14n"
+
+do_stage () {
+ oe_runmake install
+}
diff --git a/packages/libxml/libxml2-native_2.6.29.bb b/packages/libxml/libxml2-native_2.6.29.bb
index 5672792db3..f82c4e088f 100644
--- a/packages/libxml/libxml2-native_2.6.29.bb
+++ b/packages/libxml/libxml2-native_2.6.29.bb
@@ -1,24 +1,2 @@
-DESCRIPTION = "GNOME XML library"
-DEPENDS = "python-native"
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libxml2-${PV}"
+require libxml2-native.inc
PR = "r3"
-
-SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz"
-S = "${WORKDIR}/libxml2-${PV}"
-
-inherit autotools native pkgconfig
-
-def libxml2_native_python_dir(d):
- import os, bb
- staging_incdir = bb.data.getVar( "STAGING_INCDIR", d, 1 )
- if os.path.exists( "%s/python2.5" % staging_incdir ): return "python2.5"
- if os.path.exists( "%s/python2.4" % staging_incdir ): return "python2.4"
- if os.path.exists( "%s/python2.3" % staging_incdir ): return "python2.3"
- raise "No Python in STAGING_INCDIR. Forgot to build python-native ?"
-
-EXTRA_OECONF = "--with-python=${STAGING_INCDIR}/${@libxml2_native_python_dir(d)} \
- --without-debug --without-legacy --without-catalog --without-docbook --with-c14n"
-
-do_stage () {
- oe_runmake install
-}
diff --git a/packages/libxml/libxml2-native_2.6.32.bb b/packages/libxml/libxml2-native_2.6.32.bb
index 914a301a31..48e35986f6 100644
--- a/packages/libxml/libxml2-native_2.6.32.bb
+++ b/packages/libxml/libxml2-native_2.6.32.bb
@@ -1,24 +1,2 @@
-DESCRIPTION = "GNOME XML library"
-DEPENDS = "python-native"
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libxml2-${PV}"
+require libxml2-native.inc
PR = "r0"
-
-SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz"
-S = "${WORKDIR}/libxml2-${PV}"
-
-inherit autotools native pkgconfig
-
-def libxml2_native_python_dir(d):
- import os, bb
- staging_incdir = bb.data.getVar( "STAGING_INCDIR", d, 1 )
- if os.path.exists( "%s/python2.5" % staging_incdir ): return "python2.5"
- if os.path.exists( "%s/python2.4" % staging_incdir ): return "python2.4"
- if os.path.exists( "%s/python2.3" % staging_incdir ): return "python2.3"
- raise "No Python in STAGING_INCDIR. Forgot to build python-native ?"
-
-EXTRA_OECONF = "--with-python=${STAGING_INCDIR}/${@libxml2_native_python_dir(d)} \
- --without-debug --without-legacy --without-catalog --without-docbook --with-c14n"
-
-do_stage () {
- oe_runmake install
-}