aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libxml
diff options
context:
space:
mode:
authorAntti Andreimann <antti.andreimann@mail.ee>2007-08-02 12:17:30 +0000
committerKoen Kooi <koen@openembedded.org>2007-08-02 12:17:30 +0000
commitea0f8284c9d5a67c183236d655b3e7c068767365 (patch)
tree4176efb74689d04ccf2ff9272e45def215c97294 /packages/libxml
parent0913e0e77fb336111552ddfde1944bcfd0b3c25f (diff)
downloadopenembedded-ea0f8284c9d5a67c183236d655b3e7c068767365.tar.gz
libxml2: update to 2.6.29, closes #2702
Diffstat (limited to 'packages/libxml')
-rw-r--r--packages/libxml/libxml2-native_2.6.29.bb17
-rw-r--r--packages/libxml/libxml2_2.6.29.bb34
2 files changed, 51 insertions, 0 deletions
diff --git a/packages/libxml/libxml2-native_2.6.29.bb b/packages/libxml/libxml2-native_2.6.29.bb
new file mode 100644
index 0000000000..fc9c3697de
--- /dev/null
+++ b/packages/libxml/libxml2-native_2.6.29.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "GNOME XML library"
+PR = "r1"
+
+SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz"
+
+DEPENDS = "python-native"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libxml2-${PV}"
+S = "${WORKDIR}/libxml2-${PV}"
+
+inherit autotools native pkgconfig
+
+EXTRA_OECONF = "--with-python=${STAGING_INCDIR}/python2.4 --without-debug --without-legacy --without-catalog --without-docbook --with-c14n"
+
+do_stage () {
+ oe_runmake install
+}
diff --git a/packages/libxml/libxml2_2.6.29.bb b/packages/libxml/libxml2_2.6.29.bb
new file mode 100644
index 0000000000..224f3e3b96
--- /dev/null
+++ b/packages/libxml/libxml2_2.6.29.bb
@@ -0,0 +1,34 @@
+# NOTE! This is an update file and will go away when upstream updates
+# TODO: send this to upstream
+
+DESCRIPTION = "GNOME XML Parser library"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "MIT"
+PR = "r4"
+
+SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz"
+
+inherit autotools pkgconfig binconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n"
+
+export LDFLAGS += "-ldl"
+
+do_stage() {
+ autotools_stage_all
+ install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
+ #this is need it by php during its install
+ install -m 0755 xml2-config ${STAGING_BINDIR}
+}
+
+python populate_packages_prepend () {
+ # autonamer would call this libxml2-2, but we don't want that
+ if bb.data.getVar('DEBIAN_NAMES', d, 1):
+ bb.data.setVar('PKG_libxml2', 'libxml2', d)
+}
+
+PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/*-config"
+FILES_${PN}-utils += "${bindir}/*"