aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libxml
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-08-18 13:37:29 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-08-18 13:37:29 +0000
commiteb1bc6e2d48c04db954aa69f738109873dcbbcd3 (patch)
tree328e9933d0c15cc3245f7f9aab4106bc0593ccdb /packages/libxml
parent5ae14e052c68c2666a1152e33ddb227455913766 (diff)
downloadopenembedded-eb1bc6e2d48c04db954aa69f738109873dcbbcd3.tar.gz
libxml2-native: catch up with python2.5 update
Diffstat (limited to 'packages/libxml')
-rw-r--r--packages/libxml/libxml2-native_2.6.10.bb16
-rw-r--r--packages/libxml/libxml2-native_2.6.26.bb21
-rw-r--r--packages/libxml/libxml2-native_2.6.29.bb19
-rw-r--r--packages/libxml/libxml2-native_2.6.9.bb16
-rw-r--r--packages/libxml/libxml2_2.6.22.bb28
-rw-r--r--packages/libxml/libxml2_2.6.26.bb31
6 files changed, 13 insertions, 118 deletions
diff --git a/packages/libxml/libxml2-native_2.6.10.bb b/packages/libxml/libxml2-native_2.6.10.bb
deleted file mode 100644
index df3ab07460..0000000000
--- a/packages/libxml/libxml2-native_2.6.10.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-DESCRIPTION = "GNOME XML library"
-
-SRC_URI = "ftp://xmlsoft.org/libxml2/old/libxml2-${PV}.tar.gz"
-
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libxml2-${PV}"
-S = "${WORKDIR}/libxml2-${PV}"
-
-inherit autotools native pkgconfig
-
-EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-schemas --without-catalog --without-docbook --without-c14n"
-
-headers = "DOCBparser.h HTMLparser.h HTMLtree.h SAX.h SAX2.h c14n.h catalog.h chvalid.h debugXML.h dict.h encoding.h entities.h globals.h hash.h list.h nanoftp.h nanohttp.h parser.h parserInternals.h pattern.h relaxng.h schemasInternals.h threads.h tree.h uri.h valid.h xinclude.h xlink.h xmlIO.h xmlautomata.h xmlerror.h xmlexports.h xmlmemory.h xmlreader.h xmlregexp.h xmlschemas.h xmlschemastypes.h xmlstring.h xmlunicode.h xmlversion.h xmlwriter.h xpath.h xpathInternals.h xpointer.h"
-
-do_stage () {
- oe_runmake install
-}
diff --git a/packages/libxml/libxml2-native_2.6.26.bb b/packages/libxml/libxml2-native_2.6.26.bb
deleted file mode 100644
index 97ae5c47ec..0000000000
--- a/packages/libxml/libxml2-native_2.6.26.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-DESCRIPTION = "GNOME XML library"
-PR = "r1"
-
-SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz \
- file://no-testapi.patch;patch=1"
-
-DEPENDS = "python-native"
-
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libxml2-${PV}"
-S = "${WORKDIR}/libxml2-${PV}"
-
-inherit autotools native pkgconfig
-
-EXTRA_OECONF = "--with-python=${STAGING_INCDIR}/python2.4 --without-debug --without-legacy --without-schemas --without-catalog --without-docbook --with-c14n"
-
-headers = "DOCBparser.h HTMLparser.h HTMLtree.h SAX.h SAX2.h c14n.h catalog.h chvalid.h debugXML.h dict.h encoding.h entities.h globals.h hash.h list.h nanoftp.h nanohttp.h parser.h parserInternals.h pattern.h relaxng.h schemasInternals.h threads.h tree.h uri.h valid.h xinclude.h xlink.h xmlIO.h xmlautomata.h xmlerror.h xmlexports.h xmlmemory.h xmlreader.h xmlregexp.h xmlschemas.h xmlschemastypes.h xmlstring.h xmlunicode.h xmlversion.h xmlwriter.h xpath.h xpathInternals.h xpointer.h"
-
-do_stage () {
- oe_runmake install
-}
-
diff --git a/packages/libxml/libxml2-native_2.6.29.bb b/packages/libxml/libxml2-native_2.6.29.bb
index fc9c3697de..5672792db3 100644
--- a/packages/libxml/libxml2-native_2.6.29.bb
+++ b/packages/libxml/libxml2-native_2.6.29.bb
@@ -1,16 +1,23 @@
DESCRIPTION = "GNOME XML library"
-PR = "r1"
-
-SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz"
-
DEPENDS = "python-native"
-
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libxml2-${PV}"
+PR = "r3"
+
+SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz"
S = "${WORKDIR}/libxml2-${PV}"
inherit autotools native pkgconfig
-EXTRA_OECONF = "--with-python=${STAGING_INCDIR}/python2.4 --without-debug --without-legacy --without-catalog --without-docbook --with-c14n"
+def libxml2_native_python_dir(d):
+ import os, bb
+ staging_incdir = bb.data.getVar( "STAGING_INCDIR", d, 1 )
+ if os.path.exists( "%s/python2.5" % staging_incdir ): return "python2.5"
+ if os.path.exists( "%s/python2.4" % staging_incdir ): return "python2.4"
+ if os.path.exists( "%s/python2.3" % staging_incdir ): return "python2.3"
+ raise "No Python in STAGING_INCDIR. Forgot to build python-native ?"
+
+EXTRA_OECONF = "--with-python=${STAGING_INCDIR}/${@libxml2_native_python_dir(d)} \
+ --without-debug --without-legacy --without-catalog --without-docbook --with-c14n"
do_stage () {
oe_runmake install
diff --git a/packages/libxml/libxml2-native_2.6.9.bb b/packages/libxml/libxml2-native_2.6.9.bb
deleted file mode 100644
index df3ab07460..0000000000
--- a/packages/libxml/libxml2-native_2.6.9.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-DESCRIPTION = "GNOME XML library"
-
-SRC_URI = "ftp://xmlsoft.org/libxml2/old/libxml2-${PV}.tar.gz"
-
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libxml2-${PV}"
-S = "${WORKDIR}/libxml2-${PV}"
-
-inherit autotools native pkgconfig
-
-EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-schemas --without-catalog --without-docbook --without-c14n"
-
-headers = "DOCBparser.h HTMLparser.h HTMLtree.h SAX.h SAX2.h c14n.h catalog.h chvalid.h debugXML.h dict.h encoding.h entities.h globals.h hash.h list.h nanoftp.h nanohttp.h parser.h parserInternals.h pattern.h relaxng.h schemasInternals.h threads.h tree.h uri.h valid.h xinclude.h xlink.h xmlIO.h xmlautomata.h xmlerror.h xmlexports.h xmlmemory.h xmlreader.h xmlregexp.h xmlschemas.h xmlschemastypes.h xmlstring.h xmlunicode.h xmlversion.h xmlwriter.h xpath.h xpathInternals.h xpointer.h"
-
-do_stage () {
- oe_runmake install
-}
diff --git a/packages/libxml/libxml2_2.6.22.bb b/packages/libxml/libxml2_2.6.22.bb
deleted file mode 100644
index f74d33bcc4..0000000000
--- a/packages/libxml/libxml2_2.6.22.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-DESCRIPTION = "GNOME XML library"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "MIT"
-PR = "r3"
-
-SRC_URI = "http://xmlsoft.org/sources/libxml2/libxml2-${PV}.tar.gz \
- file://no-testapi.patch;patch=1"
-
-inherit autotools pkgconfig binconfig
-
-EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --without-c14n"
-
-do_stage() {
- autotools_stage_all
- install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
-}
-
-python populate_packages_prepend () {
- # autonamer would call this libxml2-2, but we don't want that
- if bb.data.getVar('DEBIAN_NAMES', d, 1):
- bb.data.setVar('PKG_libxml2', 'libxml2', d)
-}
-
-PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
-
-FILES_${PN}-dev += "${bindir}/*-config"
-FILES_${PN}-utils += "${bindir}/*"
diff --git a/packages/libxml/libxml2_2.6.26.bb b/packages/libxml/libxml2_2.6.26.bb
deleted file mode 100644
index 12fb6ca08e..0000000000
--- a/packages/libxml/libxml2_2.6.26.bb
+++ /dev/null
@@ -1,31 +0,0 @@
-DESCRIPTION = "GNOME XML Parser library"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "MIT"
-PR = "r4"
-
-SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz"
-
-inherit autotools pkgconfig binconfig
-
-EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n"
-
-export LDFLAGS += "-ldl"
-
-do_stage() {
- autotools_stage_all
- install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
- #this is need it by php during its install
- install -m 0755 xml2-config ${STAGING_BINDIR}
-}
-
-python populate_packages_prepend () {
- # autonamer would call this libxml2-2, but we don't want that
- if bb.data.getVar('DEBIAN_NAMES', d, 1):
- bb.data.setVar('PKG_libxml2', 'libxml2', d)
-}
-
-PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
-
-FILES_${PN}-dev += "${bindir}/*-config"
-FILES_${PN}-utils += "${bindir}/*"