aboutsummaryrefslogtreecommitdiffstats
path: root/packages/lineak
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-07-21 10:29:34 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-21 10:29:34 +0000
commitf7f75893eb029ffec166c6db9c0749b317246e5c (patch)
tree0919a19ada1f90b652d54251b015864d7a21c113 /packages/lineak
parent57c61f283d2bb9968b5f9b3b3c32693056b3caf2 (diff)
downloadopenembedded-f7f75893eb029ffec166c6db9c0749b317246e5c.tar.gz
add lineak (Linux support for Easy Access and Internet Keyboards) courtesy Justin Patrick. BUG #152
Diffstat (limited to 'packages/lineak')
-rw-r--r--packages/lineak/.mtn2git_empty0
-rw-r--r--packages/lineak/files/.mtn2git_empty0
-rw-r--r--packages/lineak/files/add-zaurus-remote-support.patch26
-rw-r--r--packages/lineak/lineak_0.8.3.bb22
4 files changed, 48 insertions, 0 deletions
diff --git a/packages/lineak/.mtn2git_empty b/packages/lineak/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/lineak/.mtn2git_empty
diff --git a/packages/lineak/files/.mtn2git_empty b/packages/lineak/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/lineak/files/.mtn2git_empty
diff --git a/packages/lineak/files/add-zaurus-remote-support.patch b/packages/lineak/files/add-zaurus-remote-support.patch
new file mode 100644
index 0000000000..a5cfe9f474
--- /dev/null
+++ b/packages/lineak/files/add-zaurus-remote-support.patch
@@ -0,0 +1,26 @@
+--- lineakd-0.8.3/lineakd/lineakkb.def 2005-03-02 04:15:39.000000000 -0800
++++ lineakd-0.8.3/lineakd/lineakkb.def.new 2005-07-14 20:50:40.000000000 -0700
+@@ -1166,6 +1166,23 @@
+
+ #### END CodeGen Keyboards ####
+
++#### Sharp Zaurus Remotes ####
++
++[CE-RH2]
++ brandname = "Sharp"
++ modelname = "Sharp CE-RH2"
++ [KEYS]
++ AudioPlay|Pause = 72
++ AudioRaiseVolume = 126
++ AudioLowerVolume = 127
++ AudioMute = 128
++ AudioStop = 76
++ AudioPrev = 124
++ AudioNext = 116
++ [END KEYS]
++[END CE-RH2]
++
++#### END Sharp Zaurus Remotes ####
+
+ #### Compaq keyboards ####
+
diff --git a/packages/lineak/lineak_0.8.3.bb b/packages/lineak/lineak_0.8.3.bb
new file mode 100644
index 0000000000..7b04db572d
--- /dev/null
+++ b/packages/lineak/lineak_0.8.3.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "lineakd"
+SECTION = "gpe/multimedia"
+HOMEPAGE = "http://lineak.sourceforge.net"
+LICENSE = "GPLv2"
+MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
+DEPENDS = "x11 xext"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/lineak/lineakd-${PV}.tar.gz \
+ file://add-zaurus-remote-support.patch;patch=1"
+
+inherit autotools
+
+do_install () {
+ oe_runmake 'mandir=${D}/usr/share/man' 'pkglibdir=${D}/usr/lib' 'sysconfdir=${D}/etc' 'DESTDIR=${D}' install
+}
+
+PACKAGES += "${PN}-lib"
+
+FILES_${PN}-lib += " \
+ ${libdir}/liblineak*"
+