aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux-libc-headers
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/linux-libc-headers
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/linux-libc-headers')
-rw-r--r--packages/linux-libc-headers/.mtn2git_empty0
-rw-r--r--packages/linux-libc-headers/files/.mtn2git_empty0
-rw-r--r--packages/linux-libc-headers/files/keyboard.patch78
-rw-r--r--packages/linux-libc-headers/linux-libc-headers-2.6.7.0/.mtn2git_empty0
-rw-r--r--packages/linux-libc-headers/linux-libc-headers-2.6.7.0/sh-missing.patch72
-rw-r--r--packages/linux-libc-headers/linux-libc-headers-2.6.8.1/.mtn2git_empty0
-rw-r--r--packages/linux-libc-headers/linux-libc-headers-2.6.8.1/mips-asm-atomic-system.diff11
-rw-r--r--packages/linux-libc-headers/linux-libc-headers_2.6.8.1.bb61
8 files changed, 222 insertions, 0 deletions
diff --git a/packages/linux-libc-headers/.mtn2git_empty b/packages/linux-libc-headers/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/linux-libc-headers/.mtn2git_empty
diff --git a/packages/linux-libc-headers/files/.mtn2git_empty b/packages/linux-libc-headers/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/linux-libc-headers/files/.mtn2git_empty
diff --git a/packages/linux-libc-headers/files/keyboard.patch b/packages/linux-libc-headers/files/keyboard.patch
index e69de29bb2..7df00418b1 100644
--- a/packages/linux-libc-headers/files/keyboard.patch
+++ b/packages/linux-libc-headers/files/keyboard.patch
@@ -0,0 +1,78 @@
+--- kernel/include/linux/keyboard.h 2004-01-17 23:04:30.000000000 +0000
++++ kernel/include/linux/keyboard.h 2004-08-30 12:49:41.000000000 +0100
+@@ -37,6 +44,8 @@
+ #define KT_ASCII 9
+ #define KT_LOCK 10
+ #define KT_SLOCK 12
++#define KT_X 13 /* A few useful symbols from the base X Keysym set, that go with... */
++#define KT_XF 14 /* The XFree86 Internet multimedia and PDA keyboard symbols */
+
+ #define K(t,v) (((t)<<8)|(v))
+ #define KTYP(x) ((x) >> 8)
+@@ -421,4 +430,66 @@
+ #define NR_LOCK 8
+
+ #define MAX_DIACR 256
++
++/*
++ * modifications to this section of this list should be coordinated with
++ * the X Window System keysym list; life is much easier that way
++ *
++ */
++
++/* These don't correspond identically. */
++#define K_XMENU K(KT_X, 0x1)
++#define K_XTELEPHONE K(KT_X, 0x2)
++
++/*
++ * XFree86 vendor specific keysyms.
++ *
++ * These map to XFree86 X keysym range is 0x1008FF01 - 0x1008FFFF;
++ * for simplicity's sake, we'll define a simple identity mapping for these.
++ *
++ * Please coordinate changes here with XFree86.org, so this simple
++ * identity mapping can be maintained (and old code "just works").
++ *
++ * Keys found on some "Internet" keyboards.
++ */
++#define K_XFSTANDBY K(KT_XF,0x10)
++#define K_XFAUDIOLOWERVOLUME K(KT_XF,0x11)
++#define K_XFAUDIOMUTE K(KT_XF,0x12)
++#define K_XFAUDIORAISEVOLUME K(KT_XF,0x13)
++#define K_XFAUDIOPLAY K(KT_XF,0x14)
++#define K_XFAUDIOSTOP K(KT_XF,0x15)
++#define K_XFAUDIOPREV K(KT_XF,0x16)
++#define K_XFAUDIONEXT K(KT_XF,0x17)
++#define K_XFHOMEPAGE K(KT_XF,0x18)
++#define K_XFMAIL K(KT_XF,0x19)
++#define K_XFSTART K(KT_XF,0x1A)
++#define K_XFSEARCH K(KT_XF,0x1B)
++#define K_XFAUDIORECORD K(KT_XF,0x1C)
++
++/* These are sometimes found on PDA's (e.g. Palm, PocketPC or elsewhere) */
++#define K_XFCALCULATOR K(KT_XF,0x1D)
++#define K_XFMEMO K(KT_XF,0x1E)
++#define K_XFTODOLIST K(KT_XF,0x1F)
++#define K_XFCALENDAR K(KT_XF,0x20)
++#define K_XFPOWERDOWN K(KT_XF,0x21)
++#define K_XFCONTRASTADJUST K(KT_XF,0x22)
++#define K_XFROCKERUP K(KT_XF,0x23)
++#define K_XFROCKERDOWN K(KT_XF,0x24)
++#define K_XFROCKERENTER K(KT_XF,0x25)
++
++/* Some more "Internet" keyboard symbols */
++#define K_XFBACK K(KT_XF,0x26)
++#define K_XFFORWARD K(KT_XF,0x27)
++#define K_XFSTOP K(KT_XF,0x28)
++#define K_XFREFRESH K(KT_XF,0x29)
++
++/* Some more ... */
++#define K_XFFAVORITES K(KT_XF,0x30)
++#define K_XFAUDIOPAUSE K(KT_XF,0x31)
++#define K_XFAUDIOMEDIA K(KT_XF,0x32)
++#define K_XFMYCOMPUTER K(KT_XF,0x33)
++#define K_XFVENDORHOME K(KT_XF,0x34)
++#define K_XFLIGHTBULB K(KT_XF,0x35)
++#define K_XFSHOP K(KT_XF,0x36)
++
+ #endif
diff --git a/packages/linux-libc-headers/linux-libc-headers-2.6.7.0/.mtn2git_empty b/packages/linux-libc-headers/linux-libc-headers-2.6.7.0/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/linux-libc-headers/linux-libc-headers-2.6.7.0/.mtn2git_empty
diff --git a/packages/linux-libc-headers/linux-libc-headers-2.6.7.0/sh-missing.patch b/packages/linux-libc-headers/linux-libc-headers-2.6.7.0/sh-missing.patch
index e69de29bb2..e97650a9de 100644
--- a/packages/linux-libc-headers/linux-libc-headers-2.6.7.0/sh-missing.patch
+++ b/packages/linux-libc-headers/linux-libc-headers-2.6.7.0/sh-missing.patch
@@ -0,0 +1,72 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- /dev/null 2004-06-02 16:28:12.000000000 -0500
++++ linux-libc-headers-2.6.7.0/include/asm-sh/cpu-sh4/sigcontext.h 2004-08-27 17:56:59.000000000 -0500
+@@ -0,0 +1,24 @@
++#ifndef __ASM_CPU_SH4_SIGCONTEXT_H
++#define __ASM_CPU_SH4_SIGCONTEXT_H
++
++struct sigcontext {
++ unsigned long oldmask;
++
++ /* CPU registers */
++ unsigned long sc_regs[16];
++ unsigned long sc_pc;
++ unsigned long sc_pr;
++ unsigned long sc_sr;
++ unsigned long sc_gbr;
++ unsigned long sc_mach;
++ unsigned long sc_macl;
++
++ /* FPU registers */
++ unsigned long sc_fpregs[16];
++ unsigned long sc_xfpregs[16];
++ unsigned int sc_fpscr;
++ unsigned int sc_fpul;
++ unsigned int sc_ownedfp;
++};
++
++#endif /* __ASM_CPU_SH4_SIGCONTEXT_H */
+--- /dev/null 2004-06-02 16:28:12.000000000 -0500
++++ linux-libc-headers-2.6.7.0/include/asm-sh/cpu-sh2/sigcontext.h 2004-08-27 17:57:54.000000000 -0500
+@@ -0,0 +1,17 @@
++#ifndef __ASM_CPU_SH2_SIGCONTEXT_H
++#define __ASM_CPU_SH2_SIGCONTEXT_H
++
++struct sigcontext {
++ unsigned long oldmask;
++
++ /* CPU registers */
++ unsigned long sc_regs[16];
++ unsigned long sc_pc;
++ unsigned long sc_pr;
++ unsigned long sc_sr;
++ unsigned long sc_gbr;
++ unsigned long sc_mach;
++ unsigned long sc_macl;
++};
++
++#endif /* __ASM_CPU_SH2_SIGCONTEXT_H */
+--- /dev/null 2004-06-02 16:28:12.000000000 -0500
++++ linux-libc-headers-2.6.7.0/include/asm-sh/cpu-sh3/sigcontext.h 2004-08-27 17:57:58.000000000 -0500
+@@ -0,0 +1,17 @@
++#ifndef __ASM_CPU_SH3_SIGCONTEXT_H
++#define __ASM_CPU_SH3_SIGCONTEXT_H
++
++struct sigcontext {
++ unsigned long oldmask;
++
++ /* CPU registers */
++ unsigned long sc_regs[16];
++ unsigned long sc_pc;
++ unsigned long sc_pr;
++ unsigned long sc_sr;
++ unsigned long sc_gbr;
++ unsigned long sc_mach;
++ unsigned long sc_macl;
++};
++
++#endif /* __ASM_CPU_SH3_SIGCONTEXT_H */
diff --git a/packages/linux-libc-headers/linux-libc-headers-2.6.8.1/.mtn2git_empty b/packages/linux-libc-headers/linux-libc-headers-2.6.8.1/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/linux-libc-headers/linux-libc-headers-2.6.8.1/.mtn2git_empty
diff --git a/packages/linux-libc-headers/linux-libc-headers-2.6.8.1/mips-asm-atomic-system.diff b/packages/linux-libc-headers/linux-libc-headers-2.6.8.1/mips-asm-atomic-system.diff
index e69de29bb2..a06b5affd9 100644
--- a/packages/linux-libc-headers/linux-libc-headers-2.6.8.1/mips-asm-atomic-system.diff
+++ b/packages/linux-libc-headers/linux-libc-headers-2.6.8.1/mips-asm-atomic-system.diff
@@ -0,0 +1,11 @@
+--- include/asm-mips/atomic.h.orig 2004-10-01 10:10:05.487734944 +0200
++++ include/asm-mips/atomic.h 2004-10-01 10:10:15.837161592 +0200
+@@ -15,8 +15,6 @@
+ #define _ASM_ATOMIC_H
+
+
+-#include <asm/system.h>
+-
+ typedef struct { volatile int counter; } atomic_t;
+ typedef struct { volatile __s64 counter; } atomic64_t;
+
diff --git a/packages/linux-libc-headers/linux-libc-headers_2.6.8.1.bb b/packages/linux-libc-headers/linux-libc-headers_2.6.8.1.bb
index e69de29bb2..c127e8a9e7 100644
--- a/packages/linux-libc-headers/linux-libc-headers_2.6.8.1.bb
+++ b/packages/linux-libc-headers/linux-libc-headers_2.6.8.1.bb
@@ -0,0 +1,61 @@
+SECTION = "devel"
+DESCRIPTION = "Sanitized set of 2.6 kernel headers for the C library's use."
+HOMEPAGE = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/"
+# license note from the package:
+# Linux-libc-headers are derived from linux kernel headers. For license of a
+# particular header, check it's content, and if copyright notice isn't present,
+# standard linux kernel license applies.
+# since we assume GPL for linux i think we can also assume it here
+LICENSE = "GPL"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+INHIBIT_DEFAULT_DEPS = "1"
+PR = "r7"
+
+# NOTE: no need to package these headers, since the c library includes them.
+PACKAGES = ""
+
+SRC_URI = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/linux-libc-headers-${PV}.tar.bz2 \
+ file://mips-asm-atomic-system.diff;patch=1;pnum=0 \
+ file://keyboard.patch;patch=1"
+
+S = "${WORKDIR}/linux-libc-headers-${PV}"
+
+do_configure () {
+ case ${TARGET_ARCH} in
+ alpha*) ARCH=alpha ;;
+ arm*) ARCH=arm ;;
+ cris*) ARCH=cris ;;
+ hppa*) ARCH=parisc ;;
+ i*86*) ARCH=i386 ;;
+ ia64*) ARCH=ia64 ;;
+ mips*) ARCH=mips ;;
+ m68k*) ARCH=m68k ;;
+ powerpc*) ARCH=ppc ;;
+ s390*) ARCH=s390 ;;
+ sh*) ARCH=sh ;;
+ sparc64*) ARCH=sparc64 ;;
+ sparc*) ARCH=sparc ;;
+ x86_64*) ARCH=x86_64 ;;
+ esac
+ if test ! -e include/asm-$ARCH; then
+ oefatal unable to create asm symlink in kernel headers
+ fi
+ cp -a "include/asm-$ARCH" "include/asm"
+ if test "$ARCH" = "arm"; then
+ cp -a include/asm/arch-ebsa285 include/asm/arch
+ elif test "$ARCH" = "sh"; then
+ cp -a include/asm/cpu-${TARGET_ARCH} include/asm/cpu || die "unable to create include/asm/cpu"
+ fi
+}
+
+do_stage () {
+ install -d ${STAGING_INCDIR}
+ rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm
+ cp -pfLR include/linux ${STAGING_INCDIR}/
+ cp -pfLR include/asm ${STAGING_INCDIR}/
+ rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/linux
+ rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/asm
+ install -d ${CROSS_DIR}/${TARGET_SYS}/include
+ cp -pfLR include/linux ${CROSS_DIR}/${TARGET_SYS}/include/
+ cp -pfLR include/asm ${CROSS_DIR}/${TARGET_SYS}/include/
+}