aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux-uml
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-20 10:40:08 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-20 10:40:08 +0000
commit1bb521fd96e47c6437bda16cf922d897a171fc14 (patch)
tree6579b2df48f9bf5f48192b377dd81d1a41c9f85b /packages/linux-uml
parent52da54beb1ebd89a0fcfdfea8247b357128e8e97 (diff)
downloadopenembedded-1bb521fd96e47c6437bda16cf922d897a171fc14.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/20 04:02:25-05:00 handhelds.org!kergoth automake 1.9.x build fixes: ice, libsm, libxcursor, libxfixes, libxft, libxss, xcomposite, xdamage, xpm, xt, xtst. 2005/01/20 04:00:34-05:00 handhelds.org!kergoth Disable PARALLEL_MAKE in opie-tinykate. 2005/01/20 03:58:05-05:00 handhelds.org!kergoth rosetta: inherit gettext and depend on virtual/libintl. 2005/01/20 03:57:40-05:00 handhelds.org!kergoth A few STAGING_KERNEL_DIR and PACKAGE_ARCH fixes for multimachine builds. 2005/01/20 03:53:46-05:00 handhelds.org!kergoth tosa.conf: don't bother installing the real modutils.. the busybox modutils is fine. 2005/01/20 03:52:08-05:00 handhelds.org!kergoth wireless-tools: Apply patch to stop poking into the kernel headers where it shouldnt be, clean things up, use the local wireless.h instead of the kernel's, and split out into more granular ipks. 2005/01/20 03:49:43-05:00 handhelds.org!kergoth Patch ipkg to fix a bug when built for relatively recent uclibc. BKrev: 41ef8a88apPGTS6jqkoO28j6FLNtjg
Diffstat (limited to 'packages/linux-uml')
-rw-r--r--packages/linux-uml/linux-uml_2.6.11-rc1-mm1.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/packages/linux-uml/linux-uml_2.6.11-rc1-mm1.bb b/packages/linux-uml/linux-uml_2.6.11-rc1-mm1.bb
index e69de29bb2..332dda499f 100644
--- a/packages/linux-uml/linux-uml_2.6.11-rc1-mm1.bb
+++ b/packages/linux-uml/linux-uml_2.6.11-rc1-mm1.bb
@@ -0,0 +1,55 @@
+DESCRIPTION = "User Mode Linux Kernel"
+SECTION = "kernel"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+KV = "${@bb.data.getVar('PV',d,True).split('-')[0]}"
+RCV = "${@bb.data.getVar('PV',d,True).split('-')[1]}"
+MMV = "${@bb.data.getVar('PV',d,True).split('-')[2]}"
+LV = "2.6.10"
+PR = "r0"
+
+SRC_URI = "http://www.kernel.org/pub/linux/kernel/v2.6/linux-${LV}.tar.bz2 \
+ http://www.kernel.org/pub/linux/kernel/v2.6/testing/patch-${KV}-${RCV}.bz2;patch=1 \
+ http://www.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/${KV}-${RCV}/${KV}-${RCV}-${MMV}/${KV}-${RCV}-${MMV}.gz;patch=1 \
+ file://defconfig"
+# file://compile-fix.patch;patch=1 \
+# file://defconfig"
+S = "${WORKDIR}/linux-${LV}"
+
+inherit kernel
+
+COMPATIBLE_HOST = 'i.86.*-linux'
+
+export OS = "Linux"
+ARCH = "um"
+SUBARCH = "${TARGET_ARCH}"
+KERNEL_IMAGETYPE = "linux"
+EXTRA_OEMAKE = "'CC=${KERNEL_CC}' 'LD=${KERNEL_LD}' \
+ 'SUBARCH=${SUBARCH}'"
+
+do_configure() {
+ install -m 0644 ${WORKDIR}/defconfig .config
+ oe_runmake oldconfig
+}
+
+do_compile() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ install -d arch/um/include/linux/
+ install -m 0644 include/linux/inet.h arch/um/include/linux/
+ kernel_do_compile
+# oe_runmake ${KERNEL_IMAGETYPE} 'CC=${KERNEL_CC}' 'LD=${KERNEL_LD}'
+}
+
+do_stage_prepend() {
+ install -d arch/um/boot/
+ ln -sf ${S}/linux arch/um/boot/linux
+}
+
+do_install() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ #oe_runmake DEPMOD=echo INSTALL_MOD_PATH="${D}" modules_install
+ install -d ${D}/boot
+ install -m 0755 linux ${D}/boot/linux-${PV}
+ install -m 0644 System.map ${D}/boot/System.map-${PV}
+ install -m 0644 .config ${D}/boot/config-${PV}
+}