aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux/LAB-kernel_2.6.13-hh2.bb
diff options
context:
space:
mode:
authorMatt Reimer <mattjreimer@gmail.com>2006-02-16 23:11:01 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-16 23:11:01 +0000
commit21b560f6fb943f70471666cf8ad715e1f98775e7 (patch)
treea88a3aa46a5585de4aca2f44d50924e9c403d64e /packages/linux/LAB-kernel_2.6.13-hh2.bb
parentf86df2427ee3246df8d17f2179182c681e7e8f33 (diff)
downloadopenembedded-21b560f6fb943f70471666cf8ad715e1f98775e7.tar.gz
LAB-kernel: Add a 2.6.13-hh2 bb.
Add a patch that teaches LAB to look for a LAB script named 'labrun' in the /boot directory of all the filesystems it checks. Now that we can boot from CF, check CF for a labrun script too.
Diffstat (limited to 'packages/linux/LAB-kernel_2.6.13-hh2.bb')
-rw-r--r--packages/linux/LAB-kernel_2.6.13-hh2.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/linux/LAB-kernel_2.6.13-hh2.bb b/packages/linux/LAB-kernel_2.6.13-hh2.bb
new file mode 100644
index 0000000000..f50baf64ad
--- /dev/null
+++ b/packages/linux/LAB-kernel_2.6.13-hh2.bb
@@ -0,0 +1,38 @@
+SECTION = "kernel"
+DESCRIPTION = "Liux As Bootloader kernelm"
+MAINTAINER = "Koen Kooi <koen@handhelds.org>"
+LICENSE = "GPL"
+
+KERNEL_CCSUFFIX = "-3.4.4"
+COMPATIBLE_HOST = "arm.*-linux"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/handhelds-pxa-${PV}"
+
+SRC_URI = "${HANDHELDS_CVS};module=linux/kernel26;tag=${@'K' + bb.data.getVar('PV',d,1).replace('.', '-')} \
+ file://labrun.patch;patch=1 \
+ file://defconfig"
+
+S = "${WORKDIR}/kernel26"
+
+inherit kernel
+
+K_MAJOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[0]}"
+K_MINOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[1]}"
+K_MICRO = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[2]}"
+HHV = "${@bb.data.getVar('PV',d,1).split('-')[1].split('hh')[-1]}"
+
+KERNEL_PRIORITY = "${@'%d' % (int(bb.data.getVar('K_MAJOR',d,1)) * 100000000 + int(bb.data.getVar('K_MINOR',d,1)) * 1000000 + int(bb.data.getVar('K_MICRO',d,1)) * 10000 + float(bb.data.getVar('HHV',d,1)))}"
+do_configure() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config || die "No default configuration for ${MACHINE} available."
+ yes '' | oe_runmake oldconfig
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR}/images
+ install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR}/images/LAB-image-${MACHINE}
+}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_build after do_compile
+