aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux/compulab-pxa270_2.6.16.bb
diff options
context:
space:
mode:
authorCliff Brake <cbrake@bec-systems.com>2007-04-04 12:44:07 +0000
committerCliff Brake <cbrake@bec-systems.com>2007-04-04 12:44:07 +0000
commit6d8a683342e9c2881bd29044b5512f4ec047d414 (patch)
treeae759dd29938fca9356d810e3db3bf9808ee2466 /packages/linux/compulab-pxa270_2.6.16.bb
parent0086fe0cf43e1e1c850418afcda3b69f8737222e (diff)
downloadopenembedded-6d8a683342e9c2881bd29044b5512f4ec047d414.tar.gz
compulab-pxa270 2.6.16: remove image creation code as it does not work on all distros
Diffstat (limited to 'packages/linux/compulab-pxa270_2.6.16.bb')
-rw-r--r--packages/linux/compulab-pxa270_2.6.16.bb26
1 files changed, 12 insertions, 14 deletions
diff --git a/packages/linux/compulab-pxa270_2.6.16.bb b/packages/linux/compulab-pxa270_2.6.16.bb
index 928bde8f6a..6e09281546 100644
--- a/packages/linux/compulab-pxa270_2.6.16.bb
+++ b/packages/linux/compulab-pxa270_2.6.16.bb
@@ -3,11 +3,6 @@ DESCRIPTION = "Linux kernel for the Compulab PXA270 system"
LICENSE = "GPL"
PR = "r3"
-# coreutils is required for the stat command which is used
-# to create the programming images used with USB. Version
-# >= 6.0 is required.
-DEPENDS = "coreutils-native"
-
# Note, the compulab package contains a binary NAND driver that is not
# EABI compatible
@@ -39,15 +34,18 @@ do_deploy() {
install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${KNAME}
# Create an image file that has the size prepended (used by cm-x270 BL)
# The following can only be done on a little endian machine
- size=$(stat --printf=%s ${KNAME})
- size_=$(printf '\%03o'\
- $((size & 0x000000FF))\
- $((size>>8 & 0x000000FF))\
- $((size>>16 & 0x000000FF))\
- $((size>>24 & 0x000000FF)))
- size_=${size_}'\c'
- echo -e $size_ > ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${MACHINE}-${DATETIME}.img
- cat ${KNAME} >> ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${MACHINE}-${DATETIME}.img
+ # the following does not work on all computers as it requires a recent
+ # version of coreutils (>= 6.0). We will eventually replace the following
+ # with python code.
+ #size=$(stat --printf=%s ${KNAME})
+ #size_=$(printf '\%03o'\
+ #$((size & 0x000000FF))\
+ #$((size>>8 & 0x000000FF))\
+ #$((size>>16 & 0x000000FF))\
+ #$((size>>24 & 0x000000FF)))
+ #size_=${size_}'\c'
+ #echo -e $size_ > ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${MACHINE}-${DATETIME}.img
+ #cat ${KNAME} >> ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${MACHINE}-${DATETIME}.img
}
do_deploy[dirs] = "${S}"