aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux/nslu2-kernel
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-10-24 17:26:04 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-10-24 17:26:04 +0000
commitdd6f6afd83f7c64f0252ce56e68fbb6069edfb73 (patch)
tree528840b8134dd867e3132a482d8d2aa78521b9d3 /packages/linux/nslu2-kernel
parent5fa85363aa958a11e78378db9c0dc207f8a73966 (diff)
downloadopenembedded-dd6f6afd83f7c64f0252ce56e68fbb6069edfb73.tar.gz
nslu2-kernel: delete unused patches, add Debian config in 2.6.14
Diffstat (limited to 'packages/linux/nslu2-kernel')
-rw-r--r--packages/linux/nslu2-kernel/2.6.14/10-ixp4xx-gpio.patch11
-rw-r--r--packages/linux/nslu2-kernel/2.6.14/10-mtdpart-redboot-fis-byteswap.patch6
-rw-r--r--packages/linux/nslu2-kernel/2.6.14/15-ixp4xx-set-irq-type-return.patch24
-rw-r--r--packages/linux/nslu2-kernel/2.6.14/90-arm-le.patch29
-rw-r--r--packages/linux/nslu2-kernel/2.6.14/defconfig11
5 files changed, 10 insertions, 71 deletions
diff --git a/packages/linux/nslu2-kernel/2.6.14/10-ixp4xx-gpio.patch b/packages/linux/nslu2-kernel/2.6.14/10-ixp4xx-gpio.patch
deleted file mode 100644
index f3f1bc3129..0000000000
--- a/packages/linux/nslu2-kernel/2.6.14/10-ixp4xx-gpio.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- linux-2.6.14-rc2/include/asm-arm/arch-ixp4xx/platform.h 2005-09-24 13:17:24.000000000 +0200
-+++ test3/include/asm-arm/arch-ixp4xx/platform.h 2005-09-24 16:41:17.000000000 +0200
-@@ -93,7 +93,7 @@
-
- static inline void gpio_line_config(u8 line, u32 direction)
- {
-- if (direction == IXP4XX_GPIO_OUT)
-+ if (direction == IXP4XX_GPIO_IN)
- *IXP4XX_GPIO_GPOER |= (1 << line);
- else
- *IXP4XX_GPIO_GPOER &= ~(1 << line);
diff --git a/packages/linux/nslu2-kernel/2.6.14/10-mtdpart-redboot-fis-byteswap.patch b/packages/linux/nslu2-kernel/2.6.14/10-mtdpart-redboot-fis-byteswap.patch
index bf115fd716..37d19bd1b0 100644
--- a/packages/linux/nslu2-kernel/2.6.14/10-mtdpart-redboot-fis-byteswap.patch
+++ b/packages/linux/nslu2-kernel/2.6.14/10-mtdpart-redboot-fis-byteswap.patch
@@ -1,3 +1,9 @@
+On IXP4XX systems the FIS directory is big endian even with a little
+endian kernel. This patch recognises the FIS directory on such a
+system and byte swaps it to obtain a valid table based on the 'size'
+field of the FIS directory (the size field is know to always match the
+erase block size on such systems, and probably all systems.)
+
--- linux-2.6.13/.pc/10-mtdpart-redboot-fis-byteswap.patch/drivers/mtd/redboot.c 2005-08-28 16:41:01.000000000 -0700
+++ linux-2.6.13/drivers/mtd/redboot.c 2005-10-23 21:44:59.999694674 -0700
@@ -89,8 +89,34 @@
diff --git a/packages/linux/nslu2-kernel/2.6.14/15-ixp4xx-set-irq-type-return.patch b/packages/linux/nslu2-kernel/2.6.14/15-ixp4xx-set-irq-type-return.patch
deleted file mode 100644
index a4130a3735..0000000000
--- a/packages/linux/nslu2-kernel/2.6.14/15-ixp4xx-set-irq-type-return.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-# The ixp4xx_set_irq_type API is missing return statements which causes
-# the result to be unusable and the error detection non existent.
-#
---- linux-2.6.13/arch/arm/mach-ixp4xx/orig/common.c 2005-09-25 09:52:57.658059680 -0700
-+++ linux-2.6.13/arch/arm/mach-ixp4xx/common.c 2005-09-25 09:53:02.354355199 -0700
-@@ -125,7 +125,8 @@
- } else if (type & IRQT_LOW) {
- int_style = IXP4XX_GPIO_STYLE_ACTIVE_LOW;
- irq_type = IXP4XX_IRQ_LEVEL;
-- }
-+ } else
-+ return -EINVAL;
-
- ixp4xx_config_irq(irq, irq_type);
-
-@@ -142,6 +143,8 @@
-
- /* Set the new style */
- *int_reg |= (int_style << (line * IXP4XX_GPIO_STYLE_SIZE));
-+
-+ return 0;
- }
-
- static void ixp4xx_irq_mask(unsigned int irq)
diff --git a/packages/linux/nslu2-kernel/2.6.14/90-arm-le.patch b/packages/linux/nslu2-kernel/2.6.14/90-arm-le.patch
deleted file mode 100644
index 7af75c736b..0000000000
--- a/packages/linux/nslu2-kernel/2.6.14/90-arm-le.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff -urpN linux-2.6.11.12/arch/arm/boot/compressed/little-endian.S linux-2.6.11.12-le2/arch/arm/boot/compressed/little-endian.S
---- linux-2.6.11.12/arch/arm/boot/compressed/little-endian.S 1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.11.12-le2/arch/arm/boot/compressed/little-endian.S 2005-07-17 12:13:55.000000000 +0200
-@@ -0,0 +1,13 @@
-+/*
-+ * linux/arch/arm/boot/compressed/little-endian.S
-+ *
-+ * Switch CPU into little endian mode.
-+ * Author: Nicolas Pitre
-+ */
-+
-+ .section ".start", #alloc, #execinstr
-+
-+ mrc p15, 0, r0, c1, c0, 0 @ read control reg
-+ bic r0, r0, #(1 << 7) @ enable little endian mode
-+ mcr p15, 0, r0, c1, c0, 0 @ write control reg
-+
-diff -urpN linux-2.6.11.12/arch/arm/boot/compressed/Makefile linux-2.6.11.12-le2/arch/arm/boot/compressed/Makefile
---- linux-2.6.11.12/arch/arm/boot/compressed/Makefile 2005-06-12 04:45:37.000000000 +0200
-+++ linux-2.6.11.12-le2/arch/arm/boot/compressed/Makefile 2005-07-17 12:13:55.000000000 +0200
-@@ -56,6 +56,8 @@ endif
-
- ifeq ($(CONFIG_CPU_BIG_ENDIAN),y)
- OBJS += big-endian.o
-+else
-+OBJS += little-endian.o
- endif
-
- #
diff --git a/packages/linux/nslu2-kernel/2.6.14/defconfig b/packages/linux/nslu2-kernel/2.6.14/defconfig
index e2704c2c97..5041d919c8 100644
--- a/packages/linux/nslu2-kernel/2.6.14/defconfig
+++ b/packages/linux/nslu2-kernel/2.6.14/defconfig
@@ -528,6 +528,7 @@ CONFIG_BLK_DEV_SD=y
# CONFIG_CHR_DEV_ST is not set
# CONFIG_CHR_DEV_OSST is not set
CONFIG_BLK_DEV_SR=m
+# CONFIG_BLK_DEV_SR_VENDOR is not set
CONFIG_CHR_DEV_SG=m
# CONFIG_CHR_DEV_SCH is not set
@@ -573,13 +574,7 @@ CONFIG_SCSI_MULTI_LUN=y
# CONFIG_SCSI_IPR is not set
# CONFIG_SCSI_QLOGIC_FC is not set
# CONFIG_SCSI_QLOGIC_1280 is not set
-CONFIG_SCSI_QLA2XXX=y
-# CONFIG_SCSI_QLA21XX is not set
-# CONFIG_SCSI_QLA22XX is not set
-# CONFIG_SCSI_QLA2300 is not set
-# CONFIG_SCSI_QLA2322 is not set
-# CONFIG_SCSI_QLA6312 is not set
-# CONFIG_SCSI_QLA24XX is not set
+CONFIG_SCSI_QLA2XXX=n
# CONFIG_SCSI_LPFC is not set
# CONFIG_SCSI_DC395x is not set
# CONFIG_SCSI_DC390T is not set
@@ -1124,6 +1119,7 @@ CONFIG_USB=y
CONFIG_USB_DEVICEFS=y
# CONFIG_USB_BANDWIDTH is not set
# CONFIG_USB_DYNAMIC_MINORS is not set
+# CONFIG_USB_SUSPEND is not set
# CONFIG_USB_OTG is not set
#
@@ -1372,6 +1368,7 @@ CONFIG_RAMFS=y
#
# CONFIG_ADFS_FS is not set
# CONFIG_AFFS_FS is not set
+# CONFIG_ASFS_FS is not set
# CONFIG_HFS_FS is not set
# CONFIG_HFSPLUS_FS is not set
# CONFIG_BEFS_FS is not set