aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-10-17 13:39:06 +0200
committerKoen Kooi <koen@openembedded.org>2008-10-17 13:39:06 +0200
commitf1201f2ad74e7f4b6715b9b609bf3be1d2e609fc (patch)
tree0eb7893012abffa19091fdc0922db5328bdc9d18 /packages/linux
parentc6a02df9feb64fc077c5a195de03a875cd3d0c02 (diff)
downloadopenembedded-f1201f2ad74e7f4b6715b9b609bf3be1d2e609fc.tar.gz
linux-openmoko 2.6.24+git: build in BT and sound modules to work around toolchain bugs
* various modules fail with "unknown relocation: 40", this works around that
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-openmoko/defconfig-oe27
-rw-r--r--packages/linux/linux-openmoko_2.6.24+git.bb2
2 files changed, 15 insertions, 14 deletions
diff --git a/packages/linux/linux-openmoko/defconfig-oe b/packages/linux/linux-openmoko/defconfig-oe
index 4154639d3e..4dd031ec8a 100644
--- a/packages/linux/linux-openmoko/defconfig-oe
+++ b/packages/linux/linux-openmoko/defconfig-oe
@@ -569,15 +569,15 @@ CONFIG_NET_SCH_FIFO=y
# CONFIG_NET_PKTGEN is not set
# CONFIG_HAMRADIO is not set
# CONFIG_IRDA is not set
-CONFIG_BT=m
-CONFIG_BT_L2CAP=m
-CONFIG_BT_SCO=m
-CONFIG_BT_RFCOMM=m
+CONFIG_BT=y
+CONFIG_BT_L2CAP=y
+CONFIG_BT_SCO=y
+CONFIG_BT_RFCOMM=y
CONFIG_BT_RFCOMM_TTY=y
-CONFIG_BT_BNEP=m
+CONFIG_BT_BNEP=y
CONFIG_BT_BNEP_MC_FILTER=y
CONFIG_BT_BNEP_PROTO_FILTER=y
-CONFIG_BT_HIDP=m
+CONFIG_BT_HIDP=y
#
# Bluetooth device drivers
@@ -1137,13 +1137,13 @@ CONFIG_SOUND=y
#
# Advanced Linux Sound Architecture
#
-CONFIG_SND=m
-CONFIG_SND_TIMER=m
-CONFIG_SND_PCM=m
+CONFIG_SND=y
+CONFIG_SND_TIMER=y
+CONFIG_SND_PCM=y
# CONFIG_SND_SEQUENCER is not set
CONFIG_SND_OSSEMUL=y
-CONFIG_SND_MIXER_OSS=m
-CONFIG_SND_PCM_OSS=m
+CONFIG_SND_MIXER_OSS=y
+CONFIG_SND_PCM_OSS=y
CONFIG_SND_PCM_OSS_PLUGINS=y
# CONFIG_SND_DYNAMIC_MINORS is not set
CONFIG_SND_SUPPORT_OLD_API=y
@@ -1176,10 +1176,11 @@ CONFIG_SND_VERBOSE_PROCFS=y
#
# System on Chip audio support
#
-CONFIG_SND_SOC=m
-CONFIG_SND_S3C24XX_SOC=m
+CONFIG_SND_SOC=y
+CONFIG_SND_S3C24XX_SOC=y
CONFIG_SND_S3C24XX_SOC_I2S=m
CONFIG_SND_S3C24XX_SOC_NEO1973_WM8753=m
+# CONFIG_SND_S3C24XX_SOC_NEO1973_WM8753_DEBUG is not set
CONFIG_SND_S3C24XX_SOC_NEO1973_GTA02_WM8753=m
#
diff --git a/packages/linux/linux-openmoko_2.6.24+git.bb b/packages/linux/linux-openmoko_2.6.24+git.bb
index 83979627b1..7c65d6c112 100644
--- a/packages/linux/linux-openmoko_2.6.24+git.bb
+++ b/packages/linux/linux-openmoko_2.6.24+git.bb
@@ -7,7 +7,7 @@ KERNEL_RELEASE = "2.6.24"
KERNEL_VERSION = "${KERNEL_RELEASE}"
PV = "${KERNEL_RELEASE}+${PR}+gitr${SRCREV}"
-FILE_PR = "r8"
+FILE_PR = "r9"
SRC_URI = "\
git://git.openmoko.org/git/kernel.git;protocol=git;branch=stable \