aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-01-06 21:46:25 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-01-06 21:46:25 +0000
commitba52a96c3d5ad7303c3386e2b0f1edfd60024798 (patch)
tree1dab8a18784d8f38fd958ae88a353f908e5808e6 /packages/linux
parent7297a182f627caa9023220f2130e362387132f26 (diff)
downloadopenembedded-ba52a96c3d5ad7303c3386e2b0f1edfd60024798.tar.gz
devkitidp-pxa255: use COMPATIBLE_MACHINE instead of python function, use KERNELORG_MIRROR
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/devkitidp-pxa255_2.6.19.bb12
1 files changed, 2 insertions, 10 deletions
diff --git a/packages/linux/devkitidp-pxa255_2.6.19.bb b/packages/linux/devkitidp-pxa255_2.6.19.bb
index a352751109..500c0535d2 100644
--- a/packages/linux/devkitidp-pxa255_2.6.19.bb
+++ b/packages/linux/devkitidp-pxa255_2.6.19.bb
@@ -4,13 +4,13 @@ LICENSE = "GPL"
PR = "r4"
DEPENDS = "u-boot"
-SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.19.tar.bz2 \
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.19.tar.bz2 \
file://linux-2.6.19_devkitidp1.patch;patch=1 \
file://defconfig"
S = "${WORKDIR}/linux-2.6.19"
-COMPATIBLE_HOST = 'arm.*-linux'
+COMPATIBLE_MACHINE = "devkitidp-pxa255"
inherit kernel
inherit package
@@ -37,11 +37,3 @@ do_deploy() {
do_deploy[dirs] = "${S}"
addtask deploy before do_build after do_compile
-
-python () {
- # Don't build openslug kernel unless we're targeting an nslu2
- mach = bb.data.getVar("MACHINE", d, 1)
- if mach != 'devkitidp-pxa255':
- raise bb.parse.SkipPackage("This kernel only builds for the PXA255 DevKitIDP")
-}
-