aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-01-09 08:41:36 +0000
committerRod Whitby <rod@whitby.id.au>2007-01-09 08:41:36 +0000
commite53297287a5bb9e25f42b50703e81257c25d018f (patch)
tree6a54021d06994525d33761fcd4f3fe77b6bb6811 /packages/linux
parent70e1bf1a453e4d7968b4a4481cf7e203aa793f95 (diff)
downloadopenembedded-e53297287a5bb9e25f42b50703e81257c25d018f.tar.gz
ixp4xx-kernel: Updated to 2.6.20-rc4, and made default for SlugOS. Includes latest 0.3.1 version of open source ixp npe driver.
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/ixp4xx-kernel.inc3
-rw-r--r--packages/linux/ixp4xx-kernel_2.6.19+2.6.20-rc4.bb22
2 files changed, 25 insertions, 0 deletions
diff --git a/packages/linux/ixp4xx-kernel.inc b/packages/linux/ixp4xx-kernel.inc
index a45a690955..099bfca2d3 100644
--- a/packages/linux/ixp4xx-kernel.inc
+++ b/packages/linux/ixp4xx-kernel.inc
@@ -72,6 +72,9 @@ python () {
# pre patches actually require the *preceding* kernel version the code
# fixes that up appropriately.
pv = bb.data.getVar("PV",d,1).split('-')
+ if pv[0].count('+'):
+ prev = pv[0].split('+')
+ pv[0] = prev[1];
kernel = pv[0].split('.')
base = pv[0]
name = [base]
diff --git a/packages/linux/ixp4xx-kernel_2.6.19+2.6.20-rc4.bb b/packages/linux/ixp4xx-kernel_2.6.19+2.6.20-rc4.bb
new file mode 100644
index 0000000000..d7d4de3b63
--- /dev/null
+++ b/packages/linux/ixp4xx-kernel_2.6.19+2.6.20-rc4.bb
@@ -0,0 +1,22 @@
+# Kernel for IXP4xx
+#
+# This bitbake file pulls patches and the defconfig straight
+# from the NSLU2-Linux SVN repository. Information about this
+# repository can be found at:
+# http://trac.nslu2-linux.org/kernel/
+#
+# The revision that is pulled from SVN is specified below
+IXP4XX_KERNEL_SVN_REV = "659"
+#
+# The directory containing the patches to be applied is
+# specified below
+IXP4XX_KERNEL_PATCH_DIR = "2.6.20"
+#
+# Increment the number below (i.e. the digits after PR) when
+# the changes in SVN between revisions include changes in the
+# patches applied to the kernel, rather than simply defconfig
+# changes
+PR = "r1.${IXP4XX_KERNEL_SVN_REV}"
+
+require ixp4xx-kernel.inc
+require ixp4xx-kernel-svnpatch.inc