aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-02-18 13:59:23 +0100
committerKoen Kooi <koen@openembedded.org>2009-02-18 14:02:47 +0100
commitef3439f88221ab81fabb155e3282aac104da556c (patch)
tree6d3a1f590da6f9145db49583329afc50da7c3aa8 /packages/linux
parent87360d6fd8ce0db2a47db70a468b470bb7fa372f (diff)
downloadopenembedded-ef3439f88221ab81fabb155e3282aac104da556c.tar.gz
linux-omap-pm: add patch to register all OPPs, tweak defconfig
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-omap-pm/beagleboard/defconfig16
-rw-r--r--packages/linux/linux-omap-pm/register-all-OPPs.diff12
-rw-r--r--packages/linux/linux-omap-pm_git.bb3
3 files changed, 24 insertions, 7 deletions
diff --git a/packages/linux/linux-omap-pm/beagleboard/defconfig b/packages/linux/linux-omap-pm/beagleboard/defconfig
index 518986359b..36881866d1 100644
--- a/packages/linux/linux-omap-pm/beagleboard/defconfig
+++ b/packages/linux/linux-omap-pm/beagleboard/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.28-omap1
-# Tue Feb 17 22:52:35 2009
+# Wed Feb 18 13:57:41 2009
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -1489,7 +1489,7 @@ CONFIG_USB_DEVICEFS=y
CONFIG_USB_DEVICE_CLASS=y
# CONFIG_USB_DYNAMIC_MINORS is not set
CONFIG_USB_SUSPEND=y
-# CONFIG_USB_OTG is not set
+CONFIG_USB_OTG=y
# CONFIG_USB_OTG_WHITELIST is not set
# CONFIG_USB_OTG_BLACKLIST_HUB is not set
CONFIG_USB_MON=y
@@ -1500,9 +1500,11 @@ CONFIG_USB_MON=y
# USB Host Controller Drivers
#
# CONFIG_USB_C67X00_HCD is not set
-# CONFIG_USB_EHCI_HCD is not set
-# CONFIG_OMAP_EHCI_PHY_MODE is not set
+CONFIG_USB_EHCI_HCD=y
+CONFIG_OMAP_EHCI_PHY_MODE=y
# CONFIG_OMAP_EHCI_TLL_MODE is not set
+# CONFIG_USB_EHCI_ROOT_HUB_TT is not set
+# CONFIG_USB_EHCI_TT_NEWSCHED is not set
# CONFIG_USB_ISP116X_HCD is not set
# CONFIG_USB_OHCI_HCD is not set
# CONFIG_USB_SL811_HCD is not set
@@ -1515,9 +1517,10 @@ CONFIG_USB_MUSB_SOC=y
# OMAP 343x high speed USB support
#
# CONFIG_USB_MUSB_HOST is not set
-CONFIG_USB_MUSB_PERIPHERAL=y
-# CONFIG_USB_MUSB_OTG is not set
+# CONFIG_USB_MUSB_PERIPHERAL is not set
+CONFIG_USB_MUSB_OTG=y
CONFIG_USB_GADGET_MUSB_HDRC=y
+CONFIG_USB_MUSB_HDRC_HCD=y
# CONFIG_MUSB_PIO_ONLY is not set
CONFIG_USB_INVENTRA_DMA=y
# CONFIG_USB_TI_CPPI_DMA is not set
@@ -1638,6 +1641,7 @@ CONFIG_USB_LED=m
# CONFIG_USB_IDMOUSE is not set
# CONFIG_USB_FTDI_ELAN is not set
# CONFIG_USB_APPLEDISPLAY is not set
+# CONFIG_USB_SISUSBVGA is not set
# CONFIG_USB_LD is not set
# CONFIG_USB_TRANCEVIBRATOR is not set
# CONFIG_USB_IOWARRIOR is not set
diff --git a/packages/linux/linux-omap-pm/register-all-OPPs.diff b/packages/linux/linux-omap-pm/register-all-OPPs.diff
new file mode 100644
index 0000000000..95e6b9bfab
--- /dev/null
+++ b/packages/linux/linux-omap-pm/register-all-OPPs.diff
@@ -0,0 +1,12 @@
+--- /tmp/clock34xx.c 2009-02-18 13:51:18.000000000 +0100
++++ git/arch/arm/mach-omap2/clock34xx.c 2009-02-18 13:51:51.000000000 +0100
+@@ -698,8 +698,7 @@
+ if (!mpu_opps)
+ return;
+
+- /* Avoid registering the 120% Overdrive with CPUFreq */
+- prcm = mpu_opps + MAX_VDD1_OPP - 1;
++ prcm = mpu_opps + MAX_VDD1_OPP;
+ for (; prcm->rate; prcm--) {
+ freq_table[i].index = i;
+ freq_table[i].frequency = prcm->rate / 1000;
diff --git a/packages/linux/linux-omap-pm_git.bb b/packages/linux/linux-omap-pm_git.bb
index 6481b0caf5..ddaff331a4 100644
--- a/packages/linux/linux-omap-pm_git.bb
+++ b/packages/linux/linux-omap-pm_git.bb
@@ -10,7 +10,7 @@ DEFAULT_PREFERENCE = "-1"
SRCREV = "65d02c2c7fe676369b7162459feec60268c7f4ba"
PV = "2.6.28-pm1+gitr${SRCREV}"
-PR = "r1"
+PR = "r2"
SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/khilman/linux-omap-pm.git;protocol=git;branch=pm \
file://defconfig"
@@ -45,6 +45,7 @@ SRC_URI_append = " \
file://0001-ASoC-Add-support-for-OMAP3-EVM.patch;patch=1 \
file://0001-This-merges-Steve-Kipisz-USB-EHCI-support.-He-star.patch;patch=1 \
file://dss2.diff;patch=1 \
+ file://register-all-OPPs.diff;patch=1 \
"