aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux
diff options
context:
space:
mode:
authorpieterg <pieterg@gmx.com>2008-11-13 16:06:33 +0100
committerpieterg <pieterg@gmx.com>2008-11-13 16:06:33 +0100
commitf38e5cd55923cc7206d9a960e9230b2d047f1790 (patch)
treedb1b900292d654358db4c2685d222121de341cac /packages/linux
parent4f2c25e8e81d864e3740771010091da64d8f15de (diff)
downloadopenembedded-f38e5cd55923cc7206d9a960e9230b2d047f1790.tar.gz
fix updating kernel image when /boot is not mounted readonly (custom/multiboot environments)
Conflicts: packages/linux/linux-dm800.bb packages/linux/linux-dm8000.bb
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-dm7025.bb6
-rw-r--r--packages/linux/linux-dm800.bb6
-rw-r--r--packages/linux/linux-dm8000.bb6
3 files changed, 15 insertions, 3 deletions
diff --git a/packages/linux/linux-dm7025.bb b/packages/linux/linux-dm7025.bb
index 69fdd45472..2d1a8480ff 100644
--- a/packages/linux/linux-dm7025.bb
+++ b/packages/linux/linux-dm7025.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Linux kernel for Dreambox DM7025"
LICENSE = "GPL"
KV = "2.6.12"
PV = "2.6.12.6"
-PR = "s4"
+PR = "s5"
DEPENDS = "zlib-native"
@@ -127,16 +127,20 @@ do_stage_append() {
pkg_preinst_kernel-image () {
[ -d /proc/stb ] && mount -o rw,remount /boot
+ true
}
pkg_postinst_kernel-image () {
[ -d /proc/stb ] && mount -o ro,remount /boot
+ true
}
pkg_prerm_kernel-image () {
[ -d /proc/stb ] && mount -o rw,remount /boot
+ true
}
pkg_postrm_kernel-image () {
[ -d /proc/stb ] && mount -o ro,remount /boot
+ true
}
diff --git a/packages/linux/linux-dm800.bb b/packages/linux/linux-dm800.bb
index d7387d7f82..4c7f19c284 100644
--- a/packages/linux/linux-dm800.bb
+++ b/packages/linux/linux-dm800.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Linux kernel for Dreambox DM800"
LICENSE = "GPL"
KV = "2.6.12"
PV = "2.6.12"
-PR = "r11"
+PR = "r12"
# note, the rX in the filename is *NOT* the packet revision - it's the patch revision.
SRC_URI += "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-${KV}.tar.bz2 \
@@ -69,16 +69,20 @@ do_install_append () {
pkg_preinst_kernel-image () {
[ -d /proc/stb ] && mount -o rw,remount /boot
+ true
}
pkg_postinst_kernel-image () {
[ -d /proc/stb ] && mount -o ro,remount /boot
+ true
}
pkg_prerm_kernel-image () {
[ -d /proc/stb ] && mount -o rw,remount /boot
+ true
}
pkg_postrm_kernel-image () {
[ -d /proc/stb ] && mount -o ro,remount /boot
+ true
}
diff --git a/packages/linux/linux-dm8000.bb b/packages/linux/linux-dm8000.bb
index 5810059358..4271aae01e 100644
--- a/packages/linux/linux-dm8000.bb
+++ b/packages/linux/linux-dm8000.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Linux kernel for Dreambox DM8000"
LICENSE = "GPL"
KV = "2.6.12"
PV = "2.6.12"
-PR = "r8"
+PR = "r9"
# note, the rX in the filename is *NOT* the packet revision - it's the patch revision.
SRC_URI += "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-${KV}.tar.bz2 \
@@ -71,16 +71,20 @@ do_install_append () {
pkg_preinst_kernel-image () {
[ -d /proc/stb ] && mount -o rw,remount /boot
+ true
}
pkg_postinst_kernel-image () {
[ -d /proc/stb ] && mount -o ro,remount /boot
+ true
}
pkg_prerm_kernel-image () {
[ -d /proc/stb ] && mount -o rw,remount /boot
+ true
}
pkg_postrm_kernel-image () {
[ -d /proc/stb ] && mount -o ro,remount /boot
+ true
}