aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-02-17 23:02:31 +0100
committerKoen Kooi <koen@openembedded.org>2009-02-17 23:02:31 +0100
commit58a9c3095b76801f86028bb3bc3b079ed4524e6e (patch)
treeba9889b4453fdb7fafecbb3a01e3446fcf88da2b /packages/linux
parent3bddcefdde968020c7b8b6cdf2bb7b7081b9e811 (diff)
downloadopenembedded-58a9c3095b76801f86028bb3bc3b079ed4524e6e.tar.gz
linux-omap-pm: update to current HEAD, refresh patches
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-omap-pm/0004-DSS-support-for-Beagle-Board.patch10
-rw-r--r--packages/linux/linux-omap-pm/beagle-cpufreq.diff86
-rw-r--r--packages/linux/linux-omap-pm/beagleboard/defconfig20
-rw-r--r--packages/linux/linux-omap-pm_git.bb5
4 files changed, 16 insertions, 105 deletions
diff --git a/packages/linux/linux-omap-pm/0004-DSS-support-for-Beagle-Board.patch b/packages/linux/linux-omap-pm/0004-DSS-support-for-Beagle-Board.patch
index e9fe999baf..769cbcbff0 100644
--- a/packages/linux/linux-omap-pm/0004-DSS-support-for-Beagle-Board.patch
+++ b/packages/linux/linux-omap-pm/0004-DSS-support-for-Beagle-Board.patch
@@ -1457,13 +1457,15 @@ diff --git a/arch/arm/mach-omap2/board-omap3beagle.c b/arch/arm/mach-omap2/board
index fe97bab..61f0fc9 100644
--- a/arch/arm/mach-omap2/board-omap3beagle.c
+++ b/arch/arm/mach-omap2/board-omap3beagle.c
-@@ -43,6 +43,8 @@
- #include <mach/gpmc.h>
- #include <mach/nand.h>
+--- /tmp/board-omap3beagle.c 2009-02-17 22:48:44.000000000 +0100
++++ git/arch/arm/mach-omap2/board-omap3beagle.c 2009-02-17 22:49:05.000000000 +0100
+@@ -45,6 +45,8 @@
#include <mach/mux.h>
+ #include <mach/omap-pm.h>
+ #include <mach/clock.h>
+#include <mach/omapfb.h>
+#include <mach/display.h>
-
+
#include "twl4030-generic-scripts.h"
#include "mmc-twl4030.h"
@@ -238,15 +240,6 @@ static void __init omap3_beagle_init_irq(void)
diff --git a/packages/linux/linux-omap-pm/beagle-cpufreq.diff b/packages/linux/linux-omap-pm/beagle-cpufreq.diff
deleted file mode 100644
index 811f1ed626..0000000000
--- a/packages/linux/linux-omap-pm/beagle-cpufreq.diff
+++ /dev/null
@@ -1,86 +0,0 @@
---- /tmp/board-omap3beagle.c 2009-01-13 19:49:19.000000000 +0100
-+++ git/arch/arm/mach-omap2/board-omap3beagle.c 2009-01-13 19:51:26.000000000 +0100
-@@ -41,13 +41,72 @@
- #include <mach/usb-ehci.h>
- #include <mach/common.h>
- #include <mach/gpmc.h>
-+#include <mach/omap-pm.h>
- #include <mach/nand.h>
- #include <mach/mux.h>
- #include <mach/omapfb.h>
- #include <mach/display.h>
-+#include <mach/clock.h>
-
- #include "twl4030-generic-scripts.h"
- #include "mmc-twl4030.h"
-+#include "pm.h"
-+
-+/* MPU speeds */
-+#define S600M 600000000
-+#define S550M 550000000
-+#define S500M 500000000
-+#define S250M 250000000
-+#define S125M 125000000
-+
-+/* DSP speeds */
-+#define S430M 430000000
-+#define S400M 400000000
-+#define S360M 360000000
-+#define S180M 180000000
-+#define S90M 90000000
-+
-+/* L3 speeds */
-+#define S83M 83000000
-+#define S166M 166000000
-+
-+static struct omap_opp mpu_rate_table[] = {
-+ {0, 0, 0},
-+ /*OPP1*/
-+ {S125M, VDD1_OPP1, 0x18},
-+ /*OPP2*/
-+ {S250M, VDD1_OPP2, 0x20},
-+ /*OPP3*/
-+ {S500M, VDD1_OPP3, 0x30},
-+ /*OPP4*/
-+ {S550M, VDD1_OPP4, 0x36},
-+ /*OPP5*/
-+ {S600M, VDD1_OPP5, 0x3C},
-+};
-+
-+static struct omap_opp l3_rate_table[] = {
-+ {0, 0, 0},
-+ /*OPP1*/
-+ {0, VDD2_OPP1, 0x18},
-+ /*OPP2*/
-+ {S83M, VDD2_OPP2, 0x20},
-+ /*OPP3*/
-+ {S166M, VDD2_OPP3, 0x2C},
-+};
-+
-+struct omap_opp dsp_rate_table[] = {
-+ {0, 0, 0},
-+ /*OPP1*/
-+ {S90M, VDD1_OPP1, 0x18},
-+ /*OPP2*/
-+ {S180M, VDD1_OPP2, 0x20},
-+ /*OPP3*/
-+ {S360M, VDD1_OPP3, 0x30},
-+ /*OPP4*/
-+ {S400M, VDD1_OPP4, 0x36},
-+ /*OPP5*/
-+ {S430M, VDD1_OPP5, 0x3C},
-+};
-
-
- #define GPMC_CS0_BASE 0x60
-@@ -227,7 +286,9 @@
-
- static void __init omap3_beagle_init_irq(void)
- {
-- omap2_init_common_hw(mt46h32m32lf6_sdrc_params, NULL, NULL, NULL);
-+ omap2_init_common_hw(mt46h32m32lf6_sdrc_params, mpu_rate_table,
-+ dsp_rate_table, l3_rate_table);
-+
- omap_init_irq();
- omap_gpio_init();
- }
diff --git a/packages/linux/linux-omap-pm/beagleboard/defconfig b/packages/linux/linux-omap-pm/beagleboard/defconfig
index dcddd2425c..518986359b 100644
--- a/packages/linux/linux-omap-pm/beagleboard/defconfig
+++ b/packages/linux/linux-omap-pm/beagleboard/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
-# Linux kernel version: 2.6.28-rc8-omap1
-# Mon Jan 12 15:57:49 2009
+# Linux kernel version: 2.6.28-omap1
+# Tue Feb 17 22:52:35 2009
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -195,6 +195,7 @@ CONFIG_OMAP_MCBSP=y
CONFIG_OMAP_32K_TIMER=y
# CONFIG_OMAP3_DEBOBS is not set
CONFIG_OMAP_32K_TIMER_HZ=128
+CONFIG_OMAP_TICK_GPTIMER=12
CONFIG_OMAP_DM_TIMER=y
# CONFIG_OMAP_LL_DEBUG_UART1 is not set
# CONFIG_OMAP_LL_DEBUG_UART2 is not set
@@ -223,7 +224,6 @@ CONFIG_MACH_OMAP3EVM=y
CONFIG_MACH_OMAP3_BEAGLE=y
# CONFIG_MACH_OVERO is not set
# CONFIG_MACH_OMAP3_PANDORA is not set
-CONFIG_OMAP_TICK_GPTIMER=12
#
# Boot options
@@ -1489,7 +1489,7 @@ CONFIG_USB_DEVICEFS=y
CONFIG_USB_DEVICE_CLASS=y
# CONFIG_USB_DYNAMIC_MINORS is not set
CONFIG_USB_SUSPEND=y
-CONFIG_USB_OTG=y
+# CONFIG_USB_OTG is not set
# CONFIG_USB_OTG_WHITELIST is not set
# CONFIG_USB_OTG_BLACKLIST_HUB is not set
CONFIG_USB_MON=y
@@ -1500,11 +1500,9 @@ CONFIG_USB_MON=y
# USB Host Controller Drivers
#
# CONFIG_USB_C67X00_HCD is not set
-CONFIG_USB_EHCI_HCD=y
-CONFIG_OMAP_EHCI_PHY_MODE=y
+# CONFIG_USB_EHCI_HCD is not set
+# CONFIG_OMAP_EHCI_PHY_MODE is not set
# CONFIG_OMAP_EHCI_TLL_MODE is not set
-CONFIG_USB_EHCI_ROOT_HUB_TT=y
-# CONFIG_USB_EHCI_TT_NEWSCHED is not set
# CONFIG_USB_ISP116X_HCD is not set
# CONFIG_USB_OHCI_HCD is not set
# CONFIG_USB_SL811_HCD is not set
@@ -1517,10 +1515,9 @@ CONFIG_USB_MUSB_SOC=y
# OMAP 343x high speed USB support
#
# CONFIG_USB_MUSB_HOST is not set
-# CONFIG_USB_MUSB_PERIPHERAL is not set
-CONFIG_USB_MUSB_OTG=y
+CONFIG_USB_MUSB_PERIPHERAL=y
+# CONFIG_USB_MUSB_OTG is not set
CONFIG_USB_GADGET_MUSB_HDRC=y
-CONFIG_USB_MUSB_HDRC_HCD=y
# CONFIG_MUSB_PIO_ONLY is not set
CONFIG_USB_INVENTRA_DMA=y
# CONFIG_USB_TI_CPPI_DMA is not set
@@ -1641,7 +1638,6 @@ CONFIG_USB_LED=m
# CONFIG_USB_IDMOUSE is not set
# CONFIG_USB_FTDI_ELAN is not set
# CONFIG_USB_APPLEDISPLAY is not set
-# CONFIG_USB_SISUSBVGA is not set
# CONFIG_USB_LD is not set
# CONFIG_USB_TRANCEVIBRATOR is not set
# CONFIG_USB_IOWARRIOR is not set
diff --git a/packages/linux/linux-omap-pm_git.bb b/packages/linux/linux-omap-pm_git.bb
index ce9b58480d..6481b0caf5 100644
--- a/packages/linux/linux-omap-pm_git.bb
+++ b/packages/linux/linux-omap-pm_git.bb
@@ -7,10 +7,10 @@ COMPATIBLE_MACHINE = "omap5912osk|omap1710h3|omap2430sdp|omap2420h4|beagleboard|
DEFAULT_PREFERENCE = "-1"
-SRCREV = "998bd5675a1e9ef646be771fbade01c585800765"
+SRCREV = "65d02c2c7fe676369b7162459feec60268c7f4ba"
PV = "2.6.28-pm1+gitr${SRCREV}"
-PR = "r0"
+PR = "r1"
SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/khilman/linux-omap-pm.git;protocol=git;branch=pm \
file://defconfig"
@@ -45,7 +45,6 @@ SRC_URI_append = " \
file://0001-ASoC-Add-support-for-OMAP3-EVM.patch;patch=1 \
file://0001-This-merges-Steve-Kipisz-USB-EHCI-support.-He-star.patch;patch=1 \
file://dss2.diff;patch=1 \
- file://beagle-cpufreq.diff;patch=1 \
"