aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-02-09 18:24:11 +0100
committerJeremy Lainé <jeremy.laine@m4x.org>2009-02-09 18:24:11 +0100
commitc06246d44d181869d0047d5142fec0486cd5fcba (patch)
tree045b53fcc5415ac2fdc72d3a616c9758b028c03e /packages/linux
parentd768e61faa9f59ea5fdd9c51b8e23d8dd53c2263 (diff)
downloadopenembedded-c06246d44d181869d0047d5142fec0486cd5fcba.tar.gz
linux-2.6.27: refresh patches for boc01
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-2.6.27/boc01/013-090209-lcd.patch (renamed from packages/linux/linux-2.6.27/boc01/013-090116-lcd.patch)2
-rw-r--r--packages/linux/linux-2.6.27/boc01/014-090209-pm-wakeup.patch (renamed from packages/linux/linux-2.6.27/boc01/014-090115-pm-wakeup.patch)20
-rw-r--r--packages/linux/linux_2.6.27.bb6
3 files changed, 14 insertions, 14 deletions
diff --git a/packages/linux/linux-2.6.27/boc01/013-090116-lcd.patch b/packages/linux/linux-2.6.27/boc01/013-090209-lcd.patch
index 46a7534d2f..c867e2cf3a 100644
--- a/packages/linux/linux-2.6.27/boc01/013-090116-lcd.patch
+++ b/packages/linux/linux-2.6.27/boc01/013-090209-lcd.patch
@@ -160,7 +160,7 @@ Index: linux-2.6.27/drivers/video/nt7506fb.c
+#define LCD_NPAGES (LCD_HEIGHT/8) /* LCD pages of 8 vertical pixels */
+
+#define DEFAULT_CONTRAST 20
-+#define DEFAULT_FPS 5
++#define DEFAULT_FPS 10
+
+static struct resource *lcd_mem = NULL;
+static void * _lcd_io = NULL;
diff --git a/packages/linux/linux-2.6.27/boc01/014-090115-pm-wakeup.patch b/packages/linux/linux-2.6.27/boc01/014-090209-pm-wakeup.patch
index 536a788ffc..3acbf40c32 100644
--- a/packages/linux/linux-2.6.27/boc01/014-090115-pm-wakeup.patch
+++ b/packages/linux/linux-2.6.27/boc01/014-090209-pm-wakeup.patch
@@ -1,8 +1,8 @@
Index: linux-2.6.27/arch/powerpc/platforms/83xx/Kconfig
===================================================================
---- linux-2.6.27.orig/arch/powerpc/platforms/83xx/Kconfig
-+++ linux-2.6.27/arch/powerpc/platforms/83xx/Kconfig
-@@ -104,6 +104,13 @@ config ASP834x
+--- linux-2.6.27.orig/arch/powerpc/platforms/83xx/Kconfig 2008-10-10 00:13:53.000000000 +0200
++++ linux-2.6.27/arch/powerpc/platforms/83xx/Kconfig 2009-01-23 10:54:03.000000000 +0100
+@@ -104,6 +104,13 @@
endif
@@ -18,17 +18,17 @@ Index: linux-2.6.27/arch/powerpc/platforms/83xx/Kconfig
bool
Index: linux-2.6.27/arch/powerpc/platforms/83xx/Makefile
===================================================================
---- linux-2.6.27.orig/arch/powerpc/platforms/83xx/Makefile
-+++ linux-2.6.27/arch/powerpc/platforms/83xx/Makefile
-@@ -14,3 +14,4 @@ obj-$(CONFIG_MPC837x_MDS) += mpc837x_mds
+--- linux-2.6.27.orig/arch/powerpc/platforms/83xx/Makefile 2008-10-10 00:13:53.000000000 +0200
++++ linux-2.6.27/arch/powerpc/platforms/83xx/Makefile 2009-01-23 10:54:03.000000000 +0100
+@@ -14,3 +14,4 @@
obj-$(CONFIG_SBC834x) += sbc834x.o
obj-$(CONFIG_MPC837x_RDB) += mpc837x_rdb.o
obj-$(CONFIG_ASP834x) += asp834x.o
+obj-$(CONFIG_WAKEUP_IT) += wakeup-it.o
Index: linux-2.6.27/arch/powerpc/platforms/83xx/wakeup-it.c
===================================================================
---- /dev/null
-+++ linux-2.6.27/arch/powerpc/platforms/83xx/wakeup-it.c
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ linux-2.6.27/arch/powerpc/platforms/83xx/wakeup-it.c 2009-01-23 10:49:09.000000000 +0100
@@ -0,0 +1,163 @@
+/*
+ * This support a driver to be used as a wakeup source on the MPC8313.
@@ -77,8 +77,8 @@ Index: linux-2.6.27/arch/powerpc/platforms/83xx/wakeup-it.c
+{
+ //printk(KERN_INFO "===== WAKEUP INTERRUPT %d !!\n", irq);
+
-+ if ( suspend )
-+ kernel_restart(NULL);
++// if ( suspend )
++// kernel_restart(NULL);
+ return IRQ_HANDLED ;
+}
+
diff --git a/packages/linux/linux_2.6.27.bb b/packages/linux/linux_2.6.27.bb
index 7da406a0d3..4b094bf48c 100644
--- a/packages/linux/linux_2.6.27.bb
+++ b/packages/linux/linux_2.6.27.bb
@@ -1,6 +1,6 @@
require linux.inc
-PR = "r3"
+PR = "r4"
# Mark archs/machines that this kernel supports
DEFAULT_PREFERENCE = "-1"
@@ -21,8 +21,8 @@ SRC_URI_append_boc01 = "\
file://010-090112-mii.patch;patch=1 \
file://011-090115-gpio.patch;patch=1 \
file://012-090115-cy3218-btns.patch;patch=1 \
- file://013-090116-lcd.patch;patch=1 \
- file://014-090115-pm-wakeup.patch;patch=1 \
+ file://013-090209-lcd.patch;patch=1 \
+ file://014-090209-pm-wakeup.patch;patch=1 \
"
SRC_URI_append_progear = "file://progear-bl.patch;patch=1\