aboutsummaryrefslogtreecommitdiffstats
path: root/packages/lm_sensors
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-10-07 17:46:24 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-10-07 17:46:24 +0000
commit9156fc13516db49e349c2ce8421484e618f1457d (patch)
tree3c5adeb83e8666487fc4c67e14b047898d4dcf2c /packages/lm_sensors
parent6f5e67843c881c0e3839b73a663c469c7ef9603a (diff)
downloadopenembedded-9156fc13516db49e349c2ce8421484e618f1457d.tar.gz
lmsensors-apps: ugly fix to get it properly packaged
Diffstat (limited to 'packages/lm_sensors')
-rw-r--r--packages/lm_sensors/lmsensors-apps_2.10.1.bb14
1 files changed, 9 insertions, 5 deletions
diff --git a/packages/lm_sensors/lmsensors-apps_2.10.1.bb b/packages/lm_sensors/lmsensors-apps_2.10.1.bb
index 84fe358647..ce188beb64 100644
--- a/packages/lm_sensors/lmsensors-apps_2.10.1.bb
+++ b/packages/lm_sensors/lmsensors-apps_2.10.1.bb
@@ -5,22 +5,26 @@ LICENSE = "GPL"
PR = "r2"
SRC_URI = "http://dl.lm-sensors.org/lm-sensors/releases/lm_sensors-${PV}.tar.gz \
- file://iconv.patch;patch=1 \
file://prefix-fix.patch;patch=1 \
file://add-sysfs-ldflags.patch;patch=1"
+SRC_URI_append_uclibc = "file://iconv.patch;patch=1"
+
S = "${WORKDIR}/lm_sensors-${PV}"
do_compile() {
- oe_runmake LINUX=${STAGING_KERNEL_DIR} EXLDFLAGS="${LDFLAGS}" user PROG_EXTRA=sensors PREFIX=${prefix}
+ oe_runmake LINUX=${STAGING_KERNEL_DIR} EXLDFLAGS="${LDFLAGS}" user PROG_EXTRA=sensors
}
do_install() {
oe_runmake user_install DESTDIR=${D}
- # backward compatibility with older OE packages
- mv ${D}${sbindir}/* ${D}${bindir}
+ install -d ${D}/.usr
+ mv ${D}/* ${D}/.usr
+ mv ${D}/.usr ${D}/usr
+ install -d ${D}${sysconfdir}
+ mv ${D}/usr/etc/sensors.conf ${D}${sysconfdir}
# move manuals into proper place
install -d ${D}${mandir}
rm -rf ${D}${mandir}/*
@@ -28,7 +32,7 @@ do_install() {
# remove perl or bash scripts
rm ${D}${bindir}/*.pl ${D}${bindir}/ddcmon
- rm ${D}${bindir}/fancontrol ${D}${bindir}/pwmconfig ${D}${bindir}/sensors-detect
+ rm ${D}${sbindir}/fancontrol* ${D}${sbindir}/pwmconfig ${D}${sbindir}/sensors-detect
rm ${D}${mandir}/man8/fancontrol.8 ${D}${mandir}/man8/pwmconfig.8 ${D}${mandir}/man8/sensors-detect.8
}