aboutsummaryrefslogtreecommitdiffstats
path: root/packages/lockstat
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2006-11-18 16:55:13 +0000
committerHolger Freyther <zecke@selfish.org>2006-11-18 16:55:13 +0000
commit56b7d78a034187f66e08f3b3e2de55bd878cf9b5 (patch)
treed6f4033c0064f41c2205502d10c651e8710c96aa /packages/lockstat
parent9e61974759ef6e4ff9538a33bab0e82b1b4381dd (diff)
downloadopenembedded-56b7d78a034187f66e08f3b3e2de55bd878cf9b5.tar.gz
Micro-Optimisation decreasing initial parsing time by 10%
python () {} and python __anonymous () {} are as the same says functions without a name. They get executed when the main bb file is completely parsed. This is used to set information like FILESDIR. This is a python method so it gets evaled which means compiled and executed a lot of times. By moving the code of the anonfunc into a proper method this is only compiled once. The result is is the 10% speed up when parsing. Reindent anonfuncs and new defs without tabs and four spaces
Diffstat (limited to 'packages/lockstat')
-rw-r--r--packages/lockstat/lockstat_1.4.10.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/packages/lockstat/lockstat_1.4.10.bb b/packages/lockstat/lockstat_1.4.10.bb
index 7c6c84dd01..61f4a61b0d 100644
--- a/packages/lockstat/lockstat_1.4.10.bb
+++ b/packages/lockstat/lockstat_1.4.10.bb
@@ -10,9 +10,9 @@ export KERNEL_SOURCE = ${@base_read_file('${STAGING_KERNEL_DIR}/kernel-source')}
CFLAGS += " -I${KERNEL_SOURCE}/include"
python () {
-# NOTE: any target machines with kernels supporting spinlock metering should
-# check the MACHINE variable here to prevent the SkipPackage.
- raise bb.parse.SkipPackage("The target machine's kernel does not appear able to use spinlock metering.")
+ # NOTE: any target machines with kernels supporting spinlock metering should
+ # check the MACHINE variable here to prevent the SkipPackage.
+ raise bb.parse.SkipPackage("The target machine's kernel does not appear able to use spinlock metering.")
}
do_compile () {