aboutsummaryrefslogtreecommitdiffstats
path: root/packages/lua
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2006-08-05 14:01:52 +0000
committerHolger Freyther <zecke@selfish.org>2006-08-05 14:01:52 +0000
commit803427eedbf62d58bd250d577f2c0afb5b68383d (patch)
tree1f984a0def072ada0b90ebfaf05fdaa549cefdb3 /packages/lua
parente09f555a30a573e1f8025b4123d1132e67c558ad (diff)
downloadopenembedded-803427eedbf62d58bd250d577f2c0afb5b68383d.tar.gz
packages: sed -i s/^"include "/"require "/ */*.bb GNU sed rocks!
Use require for the BitBake files within packages. In contrast to the conf files the authors of these files expected these files to be included.
Diffstat (limited to 'packages/lua')
-rw-r--r--packages/lua/lua-native_5.0.2.bb4
-rw-r--r--packages/lua/lua_5.0.2.bb4
2 files changed, 4 insertions, 4 deletions
diff --git a/packages/lua/lua-native_5.0.2.bb b/packages/lua/lua-native_5.0.2.bb
index 16ae4290c8..bf70f84ac0 100644
--- a/packages/lua/lua-native_5.0.2.bb
+++ b/packages/lua/lua-native_5.0.2.bb
@@ -1,4 +1,4 @@
-include lua.inc
+require lua.inc
PR = "r2"
DEPENDS += "readline-native"
@@ -11,5 +11,5 @@ S = "${WORKDIR}/lua-${PV}"
FILESPATH = "${FILE_DIRNAME}/lua-${PV}:${FILE_DIRNAME}/lua:${FILE_DIRNAME}/files"
inherit native
-include lua-build.inc
+require lua-build.inc
diff --git a/packages/lua/lua_5.0.2.bb b/packages/lua/lua_5.0.2.bb
index 570659af97..6dbb656166 100644
--- a/packages/lua/lua_5.0.2.bb
+++ b/packages/lua/lua_5.0.2.bb
@@ -1,4 +1,4 @@
-include lua.inc
+require lua.inc
DEPENDS += "readline"
PR = "r3"
@@ -10,5 +10,5 @@ SRC_URI = "http://www.lua.org/ftp/lua-${PV}.tar.gz \
S = "${WORKDIR}/lua-${PV}"
FILESPATH = "${FILE_DIRNAME}/lua-${PV}:${FILE_DIRNAME}/lua:${FILE_DIRNAME}/files"
-include lua-build.inc
+require lua-build.inc
inherit binconfig