aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mISDN/misdn_cvs.bb
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-05-25 23:35:21 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-05-25 23:35:21 +0000
commit9d5812a11d0f7a0994ba4abbcc1b50189cf3fd71 (patch)
treef3812bbaa2e2136af293904144f76011aa60775c /packages/mISDN/misdn_cvs.bb
parent36132a0bb4e269e156ef08a8707e5391363b1d0d (diff)
downloadopenembedded-9d5812a11d0f7a0994ba4abbcc1b50189cf3fd71.tar.gz
mISDN: initial "early and often"-release. Partly closes bug 240.
* compilation runs through * no functionality tests on-device, yet * hfcs_usb_endianchecks.diff committed, but does not apply cleanly Disabled in bb
Diffstat (limited to 'packages/mISDN/misdn_cvs.bb')
-rw-r--r--packages/mISDN/misdn_cvs.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/mISDN/misdn_cvs.bb b/packages/mISDN/misdn_cvs.bb
new file mode 100644
index 0000000000..865e41b2f9
--- /dev/null
+++ b/packages/mISDN/misdn_cvs.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "mISDN kernel packages"
+PRIORITY = "optional"
+SECTION = "kernel/modules"
+LICENSE = "GPL"
+PR = "r0"
+
+DEFAULT_PREFERENCE = "-1"
+
+# hfcs_usb_endianchecks.diff does not apply cleanly anymore (cf. bug 240)
+# without it the package at least compiles. no guarantees about functionality.
+SRC_URI = "cvs://anonymous:readonly@cvs.isdn4linux.de/i4ldev;module=mISDN;method=pserver \
+# file://hfcs_usb_endianchecks.diff;patch=1 \
+ file://Makefile"
+
+S = "${WORKDIR}/mISDN/"
+
+inherit module
+
+do_compile_prepend() {
+ cp -f ${WORKDIR}/Makefile ${S}/
+ cp ${S}/drivers/isdn/hardware/mISDN/Makefile.v2.6 ${S}/drivers/isdn/hardware/mISDN/Makefile
+}
+
+do_compile () {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake 'KDIR=${STAGING_KERNEL_DIR}' \
+ 'CC=${KERNEL_CC}' \
+ 'LD=${KERNEL_LD}'
+}
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/isdn/hardware/mISDN/
+ install -m 0644 ${S}/drivers/isdn/hardware/mISDN/*${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/isdn/hardware/mISDN
+}
+