aboutsummaryrefslogtreecommitdiffstats
path: root/packages/madwifi
diff options
context:
space:
mode:
authorFelix Domke <tmbinc@elitedvb.ne>2008-06-12 01:30:59 +0000
committerFelix Domke <tmbinc@elitedvb.ne>2008-06-12 01:30:59 +0000
commit0476b6928e191eca9dcfd5c64f491cb07995509d (patch)
treeb7ddd4dccd16ad686d926bf7d122d42d680a8456 /packages/madwifi
parent41d24bb62d9588000a1b61d406b2c927da167ce1 (diff)
downloadopenembedded-0476b6928e191eca9dcfd5c64f491cb07995509d.tar.gz
madwifi-ng: backport r3314 from .dev, add compile fix for mips1 / gcc4
Diffstat (limited to 'packages/madwifi')
-rw-r--r--packages/madwifi/files/40-fix-mips.patch49
-rw-r--r--packages/madwifi/madwifi-ng_r3314-20080131.bb15
2 files changed, 64 insertions, 0 deletions
diff --git a/packages/madwifi/files/40-fix-mips.patch b/packages/madwifi/files/40-fix-mips.patch
new file mode 100644
index 0000000000..f4e55d4a80
--- /dev/null
+++ b/packages/madwifi/files/40-fix-mips.patch
@@ -0,0 +1,49 @@
+Index: madwifi-ng-r3314-20080131/ath/if_athvar.h
+===================================================================
+--- madwifi-ng-r3314-20080131.orig/ath/if_athvar.h 2008-06-12 03:19:30.000000000 +0200
++++ madwifi-ng-r3314-20080131/ath/if_athvar.h 2008-06-12 03:19:41.000000000 +0200
+@@ -522,7 +522,7 @@
+ atomic_t av_beacon_alloc; /* set to 1 when the next beacon needs
+ to be recomputed */
+ #else
+- unsigned int av_beacon_alloc;
++ unsigned long av_beacon_alloc;
+ #endif
+ };
+ #define ATH_VAP(_v) ((struct ath_vap *)(_v))
+Index: madwifi-ng-r3314-20080131/hal/public/mips1-le-elf.inc
+===================================================================
+--- madwifi-ng-r3314-20080131.orig/hal/public/mips1-le-elf.inc 2008-06-12 03:18:14.000000000 +0200
++++ madwifi-ng-r3314-20080131/hal/public/mips1-le-elf.inc 2008-06-12 03:18:34.000000000 +0200
+@@ -68,5 +68,5 @@
+
+ LDOPTS= -EL
+ COPTS+= -DAH_BYTE_ORDER=AH_LITTLE_ENDIAN
+-COPTS+= -G 0 -EL -mno-abicalls -fno-pic -mips1 -Wa,--trap \
++COPTS+= -G 0 -mno-abicalls -fno-pic -Wa,--trap \
+ -fno-strict-aliasing -fno-common -fomit-frame-pointer -mlong-calls
+Index: madwifi-ng-r3314-20080131/ath_hal/ah_os.h
+===================================================================
+--- madwifi-ng-r3314-20080131.orig/ath_hal/ah_os.h 2008-06-12 03:20:15.000000000 +0200
++++ madwifi-ng-r3314-20080131/ath_hal/ah_os.h 2008-06-12 03:22:16.000000000 +0200
+@@ -156,6 +156,11 @@
+ #endif
+ #endif /* AH_BYTE_ORDER */
+
++#if LINUX_VERSION_CODE == KERNEL_VERSION(2,6,12)
++#define iowrite32 writel
++#define ioread32 readl
++#endif
++
+ /*
+ * Some big-endian architectures don't set CONFIG_GENERIC_IOMAP, but fail to
+ * implement iowrite32be and ioread32be. Provide compatibility macros when
+@@ -169,7 +174,7 @@
+ */
+ #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,12)) && \
+ !defined(CONFIG_GENERIC_IOMAP) && \
+- !defined(__mips__) && !defined(__hppa__) && !defined(__powerpc__)
++ !defined(__hppa__) && !defined(__powerpc__)
+ # ifndef iowrite32be
+ # define iowrite32be(_val, _addr) iowrite32(swab32((_val)), (_addr))
+ # endif
diff --git a/packages/madwifi/madwifi-ng_r3314-20080131.bb b/packages/madwifi/madwifi-ng_r3314-20080131.bb
new file mode 100644
index 0000000000..ab4519c932
--- /dev/null
+++ b/packages/madwifi/madwifi-ng_r3314-20080131.bb
@@ -0,0 +1,15 @@
+# Bitbake recipe for the madwifi-ng driver
+
+# Disable stripping of kernel modules, since this action strips too
+# much out, and the resulting module won't load.
+INHIBIT_PACKAGE_STRIP = "1"
+
+require madwifi-ng_r.inc
+
+SRC_URI += " \
+ file://30-define-ioreadwrite32be-for-little-endian-too.patch;patch=1 \
+ file://40-fix-mips.patch;patch=1 \
+ "
+
+# PR set after the include, to override what's set in the included file.
+PR = "r6"