aboutsummaryrefslogtreecommitdiffstats
path: root/packages/madwifi
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-07-25 07:38:42 +0000
committerJamie Lenehan <lenehan@twibble.org>2006-07-25 07:38:42 +0000
commit9ef3f8ee2d8145892fc97d068ce9bd041a16a502 (patch)
tree5415bf1424398ce50aead53875cec296e57c2a0b /packages/madwifi
parent7f3fb2feff6111b09dc5081644fa5fa6d2b693b6 (diff)
downloadopenembedded-9ef3f8ee2d8145892fc97d068ce9bd041a16a502.tar.gz
madwifi-ng r1527: Fix to build and work for sh4. The compiler options that
areused by default are for gcc 4.x and don't work with 3.x and kernels built with 4.x don't work on sh4, So patch the options to those required to build with gcc 3.x. Tested on the titan sh4 board. Does not seem to work if sharing an IRQ, but works fine otherwise.
Diffstat (limited to 'packages/madwifi')
-rw-r--r--packages/madwifi/files/10-sh4-le-elf-copts.patch12
-rw-r--r--packages/madwifi/madwifi-ng_r1527-20060425.bb3
2 files changed, 14 insertions, 1 deletions
diff --git a/packages/madwifi/files/10-sh4-le-elf-copts.patch b/packages/madwifi/files/10-sh4-le-elf-copts.patch
new file mode 100644
index 0000000000..f6a9e0020b
--- /dev/null
+++ b/packages/madwifi/files/10-sh4-le-elf-copts.patch
@@ -0,0 +1,12 @@
+The -mno-implicit-fp is for gcc 4.x while for gcc 3.x we need -m4-nofpu.
+Since kernels built with gcc 4.x don't work on sh4 anwyay we patch this
+unconditionally for building with gcc 3.x
+
+--- madwifi-ng-r1527-20060425/hal/public/sh4-le-elf.inc~ 2006-07-25 13:41:29.000000000 +1000
++++ madwifi-ng-r1527-20060425/hal/public/sh4-le-elf.inc 2006-07-25 13:41:29.000000000 +1000
+@@ -59,4 +59,4 @@
+
+ LDOPTS= -EL
+ COPTS+= -DAH_BYTE_ORDER=AH_LITTLE_ENDIAN
+-COPTS+= -ml -m4 -mno-implicit-fp
++COPTS+= -ml -m4 -m4-nofpu
diff --git a/packages/madwifi/madwifi-ng_r1527-20060425.bb b/packages/madwifi/madwifi-ng_r1527-20060425.bb
index aa03b048a2..488d9aefa4 100644
--- a/packages/madwifi/madwifi-ng_r1527-20060425.bb
+++ b/packages/madwifi/madwifi-ng_r1527-20060425.bb
@@ -9,7 +9,8 @@ PR="r0"
SRC_URI = "http://snapshots.madwifi.org/${PN}/${PN}-${PV}.tar.gz \
file://10-xscale-be-elf-copts.patch;patch=1 \
- file://10-xscale-le-elf-copts.patch;patch=1"
+ file://10-xscale-le-elf-copts.patch;patch=1 \
+ file://10-sh4-le-elf-copts.patch;patch=1"
S = "${WORKDIR}/${PN}-${PV}"