aboutsummaryrefslogtreecommitdiffstats
path: root/packages/maemo4
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2008-03-03 16:11:04 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2008-03-03 16:11:04 +0000
commitf6ed49ce7687ec7275dd4ffd062c9413dec49a40 (patch)
tree6161f288b542276999a4ffb6eee48e0537b8b654 /packages/maemo4
parenteaae4ed7dfc78615d78806092f13293f2f47a4f4 (diff)
downloadopenembedded-f6ed49ce7687ec7275dd4ffd062c9413dec49a40.tar.gz
hildon-control-panel: added 2.0.1
Diffstat (limited to 'packages/maemo4')
-rw-r--r--packages/maemo4/hildon-control-panel_2.0.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/maemo4/hildon-control-panel_2.0.1.bb b/packages/maemo4/hildon-control-panel_2.0.1.bb
new file mode 100644
index 0000000000..d7dd6c3e90
--- /dev/null
+++ b/packages/maemo4/hildon-control-panel_2.0.1.bb
@@ -0,0 +1,20 @@
+LICENSE = "GPL"
+
+DEPENDS = "libosso libhildon gnome-vfs libhildonhelp"
+
+SRC_URI = "http://repository.maemo.org/pool/os2008/free/source/h/hildon-control-panel/hildon-control-panel_2.0.1-1.tar.gz"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "${libdir}/dbus-1.0 ${datadir}/applications"
+
+do_stage() {
+ autotools_stage_all
+}
+
+# pkg-config file will get broken after pkgconfig.bbclass work
+#
+# This code will fix it
+#
+# sed -i -e 's:${STAGING_LIBDIR}/hildon:${libdir}/hildon:g' -e 's:${STAGING_DATADIR}/applications/hildon:${datadir}/applications/hildon:g' ${PKG_CONFIG_DIR}/hildon-control-panel.pc
+#