aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mamona
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo.salveti@openbossa.org>2008-07-02 10:02:29 -0300
committerRodrigo Vivi <rodrigo.vivi@openbossa.org>2008-10-23 17:47:13 -0300
commiteebb01309431e69d7f26d62a14aa6fc37477aab6 (patch)
treec9ade314ac17f190626a80994af45186bf653e76 /packages/mamona
parent4ed900f9f30be47407fc71aba77eb4c4dc52da76 (diff)
downloadopenembedded-eebb01309431e69d7f26d62a14aa6fc37477aab6.tar.gz
Adding the recipe of mamona-input-methods.
At the moment mamona-input-methods has both ecore and gtk support, but it's compiling just the ecore-im as we don't want it to compile everything it needs to support gtk-im. In the future, if we want or need, we can just modify the recipe to compile the gtk-im, or create another recipe just for this.
Diffstat (limited to 'packages/mamona')
-rw-r--r--packages/mamona/mamona-input-methods_git.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/packages/mamona/mamona-input-methods_git.bb b/packages/mamona/mamona-input-methods_git.bb
new file mode 100644
index 0000000000..a051eeebf9
--- /dev/null
+++ b/packages/mamona/mamona-input-methods_git.bb
@@ -0,0 +1,46 @@
+# Copyright (C) 2008 Instituto Nokia de Tecnologia
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "Mamona input methods"
+HOMEPAGE = "http://dev.openbossa.org/trac/mamona/wiki"
+LICENSE = "GPL"
+SECTION = "x11"
+DEPENDS = "ecore"
+PR = "r0"
+
+PV = "0.1+git"
+
+inherit autotools pkgconfig lib_package
+
+SRC_URI = "git://dev.openbossa.org/mamona/mamona_input_methods.git;protocol=http"
+
+S = "${WORKDIR}/git"
+
+PACKAGES += "\
+ ${PN}-im-ecore \
+ ${PN}-im-ecore-dev \
+ ${PN}-im-ecore-dbg \
+ "
+
+FILES_${PN}-im-ecore = "\
+ ${libdir}/ecore/immodules/mamona-im-ecore-module.so \
+ "
+FILES_${PN}-im-ecore-dev = "\
+ ${libdir}/ecore/immodules/mamona-im-ecore-module.la \
+ ${libdir}/ecore/immodules/mamona-im-ecore-module.a \
+ "
+FILES_${PN}-im-ecore-dbg = "\
+ ${libdir}/ecore/immodules/.debug \
+ "
+
+EXTRA_OECONF = "\
+ --enable-ecore-im \
+ "
+
+do_configure_prepend() {
+ ./autogen.sh
+}
+
+do_stage() {
+ autotools_stage_all
+}