aboutsummaryrefslogtreecommitdiffstats
path: root/packages/matchbox-keyboard
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-02-09 19:29:20 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-02-09 19:29:20 +0000
commit3a36bfdd84850f028bf4f8985007d8e4e721b587 (patch)
tree61dd29d279f504d0e64791a7625b7d52fc3b5033 /packages/matchbox-keyboard
parent8f23150cd6525a4c8e015b016a0d79fea9aee15e (diff)
downloadopenembedded-3a36bfdd84850f028bf4f8985007d8e4e721b587.tar.gz
matchbox-keyboard svn: Add patches to make it work decent on QVGA devices.
* Note: these patched don't affect other devices, as being applied to matchnox-keyboard's own "smallscreen" handling paths (smallscreen defined as having width/height <=320).
Diffstat (limited to 'packages/matchbox-keyboard')
-rw-r--r--packages/matchbox-keyboard/files/.mtn2git_empty0
-rw-r--r--packages/matchbox-keyboard/files/smallscreen-fontsize.patch22
-rw-r--r--packages/matchbox-keyboard/matchbox-keyboard_svn.bb5
3 files changed, 25 insertions, 2 deletions
diff --git a/packages/matchbox-keyboard/files/.mtn2git_empty b/packages/matchbox-keyboard/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/matchbox-keyboard/files/.mtn2git_empty
diff --git a/packages/matchbox-keyboard/files/smallscreen-fontsize.patch b/packages/matchbox-keyboard/files/smallscreen-fontsize.patch
new file mode 100644
index 0000000000..9a5f7a32a1
--- /dev/null
+++ b/packages/matchbox-keyboard/files/smallscreen-fontsize.patch
@@ -0,0 +1,22 @@
+--- matchbox-keyboard-0.1/src/matchbox-keyboard.c.orig 2006-11-04 00:41:52.000000000 +0100
++++ matchbox-keyboard-0.1/src/matchbox-keyboard.c 2006-11-04 00:29:25.000000000 +0100
+@@ -77,7 +77,7 @@
+ kb->key_pad = 0;
+ kb->col_spacing = 0;
+ kb->row_spacing = 0;
+- kb->font_pt_size = 8;
++ kb->font_pt_size = 5;
+ }
+
+ if (!mb_kbd_config_load(kb, variant))
+--- matchbox-keyboard-0.1/src/matchbox-keyboard-ui.c.org 2006-07-14 00:50:25.000000000 +0000
++++ matchbox-keyboard-0.1/src/matchbox-keyboard-ui.c 2007-02-09 17:38:19.000000000 +0000
+@@ -291,7 +291,7 @@
+ /* FIXME: hack for small displays */
+ if (mb_kbd_ui_display_height(ui) <= 320)
+ {
+- *height += 4;
++ *height += 1;
+ }
+
+ }
diff --git a/packages/matchbox-keyboard/matchbox-keyboard_svn.bb b/packages/matchbox-keyboard/matchbox-keyboard_svn.bb
index e0c3e4d578..8c7584d4f4 100644
--- a/packages/matchbox-keyboard/matchbox-keyboard_svn.bb
+++ b/packages/matchbox-keyboard/matchbox-keyboard_svn.bb
@@ -3,9 +3,10 @@ LICENSE = "GPL"
DEPENDS = "libfakekey expat libxft"
SECTION = "x11"
PV = "0.0+svn${SRCDATE}"
-PR="r2"
+PR="r3"
-SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http"
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \
+ file://smallscreen-fontsize.patch;patch=1"
S = "${WORKDIR}/${PN}"