aboutsummaryrefslogtreecommitdiffstats
path: root/packages/matchbox-sato
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-12-18 15:17:02 +0000
committerKoen Kooi <koen@openembedded.org>2007-12-18 15:17:02 +0000
commit9e7021307a438de709cd45f474454b7d58353b66 (patch)
treec6941fe9c89f2300d62e1b6c1ffb4d017a2d67b1 /packages/matchbox-sato
parentfe0ea02e82f9d3e46513095d84cf6be560edd6f4 (diff)
downloadopenembedded-9e7021307a438de709cd45f474454b7d58353b66.tar.gz
poky-base-image: add an image that offers a basic "poky" gui, and its dependencies
* untested, needs work * has a workaround to not require formfactor for touchscreen detection
Diffstat (limited to 'packages/matchbox-sato')
-rw-r--r--packages/matchbox-sato/.mtn2git_empty0
-rw-r--r--packages/matchbox-sato/matchbox-sato/.mtn2git_empty0
-rw-r--r--packages/matchbox-sato/matchbox-sato/etc/.mtn2git_empty0
-rw-r--r--packages/matchbox-sato/matchbox-sato/etc/matchbox/.mtn2git_empty0
-rwxr-xr-xpackages/matchbox-sato/matchbox-sato/etc/matchbox/session15
-rw-r--r--packages/matchbox-sato/matchbox-sato/matchbox-session24
-rw-r--r--packages/matchbox-sato/matchbox-sato_0.1.bb29
7 files changed, 68 insertions, 0 deletions
diff --git a/packages/matchbox-sato/.mtn2git_empty b/packages/matchbox-sato/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/matchbox-sato/.mtn2git_empty
diff --git a/packages/matchbox-sato/matchbox-sato/.mtn2git_empty b/packages/matchbox-sato/matchbox-sato/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/matchbox-sato/matchbox-sato/.mtn2git_empty
diff --git a/packages/matchbox-sato/matchbox-sato/etc/.mtn2git_empty b/packages/matchbox-sato/matchbox-sato/etc/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/matchbox-sato/matchbox-sato/etc/.mtn2git_empty
diff --git a/packages/matchbox-sato/matchbox-sato/etc/matchbox/.mtn2git_empty b/packages/matchbox-sato/matchbox-sato/etc/matchbox/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/matchbox-sato/matchbox-sato/etc/matchbox/.mtn2git_empty
diff --git a/packages/matchbox-sato/matchbox-sato/etc/matchbox/session b/packages/matchbox-sato/matchbox-sato/etc/matchbox/session
new file mode 100755
index 0000000000..8c8f953b47
--- /dev/null
+++ b/packages/matchbox-sato/matchbox-sato/etc/matchbox/session
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+. /etc/formfactor/config
+
+if [ -e /dev/touchscreen/touchscreen0 ]; then
+ SHOWCURSOR="no"
+else
+ SHOWCURSOR="yes"
+fi
+
+matchbox-desktop &
+
+matchbox-panel --titlebar --start-applets showdesktop,windowselector --end-applets clock,battery,systray,startup &
+
+exec matchbox-window-manager -theme Sato -use_desktop_mode decorated -use_cursor $SHOWCURSOR $@
diff --git a/packages/matchbox-sato/matchbox-sato/matchbox-session b/packages/matchbox-sato/matchbox-sato/matchbox-session
new file mode 100644
index 0000000000..65f1ce72ca
--- /dev/null
+++ b/packages/matchbox-sato/matchbox-sato/matchbox-session
@@ -0,0 +1,24 @@
+#!/bin/sh
+#
+# Very simple session manager for matchbox tools
+#
+
+# Uncomment below to enable parsing of debian menu entrys
+# export MB_USE_DEB_MENUS=1
+
+if [ -e $HOME/.matchbox/session ]
+then
+exec $HOME/.matchbox/session
+fi
+
+if [ -e /etc/matchbox/session ]
+then
+exec /etc/matchbox/session
+fi
+
+# Default files to run if $HOME/.matchbox/session or /etc/matchbox/session
+# dont exist.
+
+matchbox-desktop &
+matchbox-panel --orientation south &
+exec matchbox-window-manager $@
diff --git a/packages/matchbox-sato/matchbox-sato_0.1.bb b/packages/matchbox-sato/matchbox-sato_0.1.bb
new file mode 100644
index 0000000000..b622f24586
--- /dev/null
+++ b/packages/matchbox-sato/matchbox-sato_0.1.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Custom MB session files for poky"
+LICENSE = "GPL"
+SECTION = "x11"
+RDEPENDS = "gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato"
+RCONFLICTS = "matchbox-common"
+PR = "r17"
+
+SRC_URI = "file://etc file://matchbox-session"
+S = ${WORKDIR}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/matchbox-session ${D}/${bindir}
+ cp -R ${S}/etc ${D}/etc
+ rm -fR ${D}/etc/.svn
+ rm -fR ${D}/etc/matchbox/.svn
+ chmod -R 755 ${D}/etc
+}
+
+pkg_postinst_matchbox-sato () {
+#!/bin/sh -e
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/theme Sato
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/icon_theme Sato
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/font_name "Sans 9"
+}