aboutsummaryrefslogtreecommitdiffstats
path: root/packages/matchbox-wm
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/matchbox-wm
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/matchbox-wm')
-rw-r--r--packages/matchbox-wm/matchbox-wm_0.8.3.bb27
-rw-r--r--packages/matchbox-wm/matchbox-wm_0.8.4.bb27
-rw-r--r--packages/matchbox-wm/matchbox-wm_0.9.2.bb4
-rw-r--r--packages/matchbox-wm/matchbox-wm_0.9.3.bb31
-rw-r--r--packages/matchbox-wm/matchbox-wm_0.9.bb26
-rw-r--r--packages/matchbox-wm/matchbox-wm_svn.bb4
6 files changed, 115 insertions, 4 deletions
diff --git a/packages/matchbox-wm/matchbox-wm_0.8.3.bb b/packages/matchbox-wm/matchbox-wm_0.8.3.bb
index e69de29bb2..0a005d1f81 100644
--- a/packages/matchbox-wm/matchbox-wm_0.8.3.bb
+++ b/packages/matchbox-wm/matchbox-wm_0.8.3.bb
@@ -0,0 +1,27 @@
+SECTION = "x11/wm"
+DESCRIPTION = "Matchbox window manager"
+LICENSE = "GPL"
+DEPENDS = "libmatchbox x11 xext xcomposite libxfixes xdamage libxrender startup-notification expat gconf matchbox-common"
+RDEPENDS = "matchbox-common"
+
+SRC_URI = "ftp://ftp.handhelds.org/matchbox/sources/matchbox-window-manager/0.8/matchbox-window-manager-${PV}.tar.bz2 \
+ file://kbdconfig_keylaunch_simpad.patch;patch=1;pnum=0"
+S = "${WORKDIR}/matchbox-window-manager-${PV}"
+
+inherit autotools pkgconfig
+
+FILES_${PN} = "${bindir} \
+ ${datadir}/matchbox \
+ ${datadir}/themes/blondie/matchbox \
+ ${datadir}/themes/bluebox/matchbox \
+ ${datadir}/themes/borillo/matchbox"
+
+EXTRA_OECONF = "--enable-composite --enable-startup-notification --enable-expat"
+
+pkg_postinst() {
+update-alternatives --install ${bindir}/x-window-manager x-window-manager ${bindir}/matchbox-session 10
+}
+
+pkg_postrm() {
+update-alternatives --remove x-window-manager ${bindir}/matchbox-session
+}
diff --git a/packages/matchbox-wm/matchbox-wm_0.8.4.bb b/packages/matchbox-wm/matchbox-wm_0.8.4.bb
index e69de29bb2..0a005d1f81 100644
--- a/packages/matchbox-wm/matchbox-wm_0.8.4.bb
+++ b/packages/matchbox-wm/matchbox-wm_0.8.4.bb
@@ -0,0 +1,27 @@
+SECTION = "x11/wm"
+DESCRIPTION = "Matchbox window manager"
+LICENSE = "GPL"
+DEPENDS = "libmatchbox x11 xext xcomposite libxfixes xdamage libxrender startup-notification expat gconf matchbox-common"
+RDEPENDS = "matchbox-common"
+
+SRC_URI = "ftp://ftp.handhelds.org/matchbox/sources/matchbox-window-manager/0.8/matchbox-window-manager-${PV}.tar.bz2 \
+ file://kbdconfig_keylaunch_simpad.patch;patch=1;pnum=0"
+S = "${WORKDIR}/matchbox-window-manager-${PV}"
+
+inherit autotools pkgconfig
+
+FILES_${PN} = "${bindir} \
+ ${datadir}/matchbox \
+ ${datadir}/themes/blondie/matchbox \
+ ${datadir}/themes/bluebox/matchbox \
+ ${datadir}/themes/borillo/matchbox"
+
+EXTRA_OECONF = "--enable-composite --enable-startup-notification --enable-expat"
+
+pkg_postinst() {
+update-alternatives --install ${bindir}/x-window-manager x-window-manager ${bindir}/matchbox-session 10
+}
+
+pkg_postrm() {
+update-alternatives --remove x-window-manager ${bindir}/matchbox-session
+}
diff --git a/packages/matchbox-wm/matchbox-wm_0.9.2.bb b/packages/matchbox-wm/matchbox-wm_0.9.2.bb
index f8db87358f..9bf7be1e69 100644
--- a/packages/matchbox-wm/matchbox-wm_0.9.2.bb
+++ b/packages/matchbox-wm/matchbox-wm_0.9.2.bb
@@ -22,10 +22,10 @@ FILES_${PN} = "${bindir} \
EXTRA_OECONF = "--enable-composite --enable-startup-notification --disable-xrm"
pkg_postinst() {
-update-alternatives --install /usr/bin/x-window-manager x-window-manager /usr/bin/matchbox-session 10
+update-alternatives --install ${bindir}/x-window-manager x-window-manager ${bindir}/matchbox-session 10
}
pkg_postrm() {
-update-alternatives --remove x-window-manager /usr/bin/matchbox-session
+update-alternatives --remove x-window-manager ${bindir}/matchbox-session
}
diff --git a/packages/matchbox-wm/matchbox-wm_0.9.3.bb b/packages/matchbox-wm/matchbox-wm_0.9.3.bb
index e69de29bb2..9bf7be1e69 100644
--- a/packages/matchbox-wm/matchbox-wm_0.9.3.bb
+++ b/packages/matchbox-wm/matchbox-wm_0.9.3.bb
@@ -0,0 +1,31 @@
+SECTION = "x11/wm"
+DESCRIPTION = "Matchbox window manager"
+LICENSE = "GPL"
+DEPENDS = "libmatchbox x11 xext xcomposite libxfixes xdamage libxrender startup-notification expat gconf matchbox-common"
+RDEPENDS = "matchbox-common"
+PR = "r1"
+
+
+SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-window-manager/0.9/matchbox-window-manager-${PV}.tar.gz"
+
+S = "${WORKDIR}/matchbox-window-manager-${PV}"
+
+inherit autotools pkgconfig
+
+FILES_${PN} = "${bindir} \
+ ${datadir}/matchbox \
+ ${sysconfdir}/matchbox \
+ ${datadir}/themes/blondie/matchbox \
+ ${datadir}/themes/Default/matchbox \
+ ${datadir}/themes/MBOpus/matchbox"
+
+EXTRA_OECONF = "--enable-composite --enable-startup-notification --disable-xrm"
+
+pkg_postinst() {
+update-alternatives --install ${bindir}/x-window-manager x-window-manager ${bindir}/matchbox-session 10
+}
+
+pkg_postrm() {
+update-alternatives --remove x-window-manager ${bindir}/matchbox-session
+}
+
diff --git a/packages/matchbox-wm/matchbox-wm_0.9.bb b/packages/matchbox-wm/matchbox-wm_0.9.bb
index e69de29bb2..8a581b0c93 100644
--- a/packages/matchbox-wm/matchbox-wm_0.9.bb
+++ b/packages/matchbox-wm/matchbox-wm_0.9.bb
@@ -0,0 +1,26 @@
+SECTION = "x11/wm"
+DESCRIPTION = "Matchbox window manager"
+LICENSE = "GPL"
+DEPENDS = "libmatchbox x11 xext xcomposite libxfixes xdamage libxrender startup-notification expat gconf matchbox-common"
+RDEPENDS = "matchbox-common"
+
+SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-window-manager/${PV}/matchbox-window-manager-${PV}.tar.gz"
+S = "${WORKDIR}/matchbox-window-manager-${PV}"
+
+inherit autotools pkgconfig
+
+FILES_${PN} = "${bindir} \
+ ${datadir}/matchbox \
+ ${datadir}/themes/blondie/matchbox \
+ ${datadir}/themes/bluebox/matchbox \
+ ${datadir}/themes/borillo/matchbox"
+
+EXTRA_OECONF = "--enable-composite --enable-startup-notification --enable-expat"
+
+pkg_postinst() {
+update-alternatives --install ${bindir}/x-window-manager x-window-manager ${bindir}/matchbox-session 10
+}
+
+pkg_postrm() {
+update-alternatives --remove x-window-manager ${bindir}/matchbox-session
+}
diff --git a/packages/matchbox-wm/matchbox-wm_svn.bb b/packages/matchbox-wm/matchbox-wm_svn.bb
index d9148d436d..ad6b67414b 100644
--- a/packages/matchbox-wm/matchbox-wm_svn.bb
+++ b/packages/matchbox-wm/matchbox-wm_svn.bb
@@ -21,9 +21,9 @@ FILES_${PN} = "${bindir} \
EXTRA_OECONF = "--enable-composite --enable-startup-notification --enable-expat"
pkg_postinst() {
-update-alternatives --install /usr/bin/x-window-manager x-window-manager /usr/bin/matchbox-session 10
+update-alternatives --install ${bindir}/x-window-manager x-window-manager ${bindir}/matchbox-session 10
}
pkg_postrm() {
-update-alternatives --remove x-window-manager /usr/bin/matchbox-session
+update-alternatives --remove x-window-manager ${bindir}/matchbox-session
}